summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-07-09 10:36:15 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-07-09 10:36:15 +0000
commit4f6b6cc23400dbe8e212ee36c26e5292f61f9ae3 (patch)
tree49317cbc6dff717983fea985f48313ea839e2c2a /media-libs
parentMask latest slv2 because it has api changes (diff)
downloadgentoo-2-4f6b6cc23400dbe8e212ee36c26e5292f61f9ae3.tar.gz
gentoo-2-4f6b6cc23400dbe8e212ee36c26e5292f61f9ae3.tar.bz2
gentoo-2-4f6b6cc23400dbe8e212ee36c26e5292f61f9ae3.zip
version bump
(Portage version: 2.2_rc1/cvs/Linux 2.6.25.7 x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/slv2/ChangeLog7
-rw-r--r--media-libs/slv2/slv2-0.6.0.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/media-libs/slv2/ChangeLog b/media-libs/slv2/ChangeLog
index 3087c88da377..0ca1f782ce5d 100644
--- a/media-libs/slv2/ChangeLog
+++ b/media-libs/slv2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/slv2
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/slv2/ChangeLog,v 1.8 2008/01/26 22:44:47 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/slv2/ChangeLog,v 1.9 2008/07/09 10:36:15 aballier Exp $
+
+*slv2-0.6.0 (09 Jul 2008)
+
+ 09 Jul 2008; Alexis Ballier <aballier@gentoo.org> +slv2-0.6.0.ebuild:
+ version bump
26 Jan 2008; Alexis Ballier <aballier@gentoo.org> -slv2-0.4.2.ebuild:
remove old
diff --git a/media-libs/slv2/slv2-0.6.0.ebuild b/media-libs/slv2/slv2-0.6.0.ebuild
new file mode 100644
index 000000000000..68e922fe56fd
--- /dev/null
+++ b/media-libs/slv2/slv2-0.6.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/slv2/slv2-0.6.0.ebuild,v 1.1 2008/07/09 10:36:15 aballier Exp $
+
+DESCRIPTION="A library to make the use of LV2 plugins as simple as possible for applications"
+HOMEPAGE="http://wiki.drobilla.net/SLV2"
+SRC_URI="http://download.drobilla.net/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc jack"
+
+RDEPEND="dev-libs/redland
+ media-libs/raptor
+ jack? ( media-sound/jack-audio-connection-kit )
+ media-libs/lv2core"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ dev-util/pkgconfig"
+
+src_compile() {
+ econf $(use_enable debug) \
+ $(use_enable jack) \
+ $(use_enable doc documentation)
+
+ emake || die "make failed"
+ if use doc; then
+ emake docs || die "creating documentation failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS README ChangeLog
+ doman doc/man/man3/*
+ use doc && dohtml doc/html/*
+}