summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-05-06 18:37:41 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-05-06 18:37:41 +0000
commit42834283ef874bd2fa2e28852bf343f39b352352 (patch)
tree13aada1576cbeedffcc6f3a6d2c99868a8a4e808 /media-libs
parentfixed whitespace warnings (Manifest recommit) (diff)
downloadgentoo-2-42834283ef874bd2fa2e28852bf343f39b352352.tar.gz
gentoo-2-42834283ef874bd2fa2e28852bf343f39b352352.tar.bz2
gentoo-2-42834283ef874bd2fa2e28852bf343f39b352352.zip
Version bump.
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/portaudio/ChangeLog8
-rw-r--r--media-libs/portaudio/Manifest2
-rw-r--r--media-libs/portaudio/files/digest-portaudio-18.11
-rw-r--r--media-libs/portaudio/files/portaudio-18.1-use-fpic.patch121
-rw-r--r--media-libs/portaudio/portaudio-18.1.ebuild43
5 files changed, 174 insertions, 1 deletions
diff --git a/media-libs/portaudio/ChangeLog b/media-libs/portaudio/ChangeLog
index b611b1e600b3..d2db49add9ad 100644
--- a/media-libs/portaudio/ChangeLog
+++ b/media-libs/portaudio/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/portaudio
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/portaudio/ChangeLog,v 1.7 2004/03/31 17:32:17 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/portaudio/ChangeLog,v 1.8 2004/05/06 18:37:41 eradicator Exp $
+
+*portaudio-18.1 (06 May 2004)
+
+ 06 May 2004; Jeremy Huddleston <eradicator@gentoo.org>
+ portaudio-18.1.ebuild, files/portaudio-18.1-use-fpic.patch:
+ Version bump.
31 Mar 2004; Jeremy Huddleston <eradicator@gentoo.org> portaudio-18.ebuild:
inherit eutils.
diff --git a/media-libs/portaudio/Manifest b/media-libs/portaudio/Manifest
index 4e9d9f81d54b..73c9fbe12e55 100644
--- a/media-libs/portaudio/Manifest
+++ b/media-libs/portaudio/Manifest
@@ -1,5 +1,7 @@
+MD5 ad7eed3c8b8448ace3f96afdd6c67d16 portaudio-18.1.ebuild 894
MD5 07c2962f2fd5139da390e1593fe2a2f4 portaudio-18.ebuild 881
MD5 5c809ae79cabfb5d2afa96b229e602af ChangeLog 776
MD5 a1eaeb2ae801daeb712c90c060e922dc metadata.xml 158
+MD5 24037d452fff400001cf4a3a4dec3585 files/digest-portaudio-18.1 64
MD5 18d9bba97a0da6eb457678c0ea20aa4b files/portaudio-use-fpic.patch 323
MD5 216bea28964aee7308b174121350d20d files/digest-portaudio-18 62
diff --git a/media-libs/portaudio/files/digest-portaudio-18.1 b/media-libs/portaudio/files/digest-portaudio-18.1
new file mode 100644
index 000000000000..75343fea7e3d
--- /dev/null
+++ b/media-libs/portaudio/files/digest-portaudio-18.1
@@ -0,0 +1 @@
+MD5 ce66a732d263fde2b5ad2262ef37a691 portaudio_v18_1.zip 550130
diff --git a/media-libs/portaudio/files/portaudio-18.1-use-fpic.patch b/media-libs/portaudio/files/portaudio-18.1-use-fpic.patch
new file mode 100644
index 000000000000..4911ac1ff7a3
--- /dev/null
+++ b/media-libs/portaudio/files/portaudio-18.1-use-fpic.patch
@@ -0,0 +1,121 @@
+--- Makefile.linux.orig 2004-05-06 11:33:44.000000000 -0700
++++ Makefile.linux 2004-05-06 11:34:05.000000000 -0700
+@@ -1,59 +1,59 @@
+-# Make PortAudio for Linux
+-# Updated 2001/08/25 Bill Eldridge bill@rfa.org
+-# Updated 2001/10/16, philburk@softsynth.com, s/unix_oss/unix_oss/
+-# Updated 2002/04/30 Bill Eldridge bill@rfa.org
+-# Made the libinstall and tests compile a bit cleaner
+-
+-# A pretty bare makefile, that figures out all the test files
+-# and compiles them against the library in the pa_unix_oss directory.
+-
+-# Do "make all" and then when happy, "make libinstall"
+-# (if not happy, "make clean")
+-
+-# The ldconfig stuff in libinstall is the wrong way to do it -
+-# someone tell me the right way, please
+-
+-
+-LIBS = -lm -lpthread
+-
+-CDEFINES = -I../pa_common
+-CFLAGS = -g
+-LIBINST = /usr/local/lib
+-
+-TESTS:= $(wildcard pa_tests/pa*.c pa_tests/debug*.c)
+-TESTO:= $(wildcard pa_tests/pa*.o pa_tests/debug*.o)
+-
+-LIBFILES:= ./pa_common/pa_lib.c ./pa_unix_oss/pa_unix_oss.c ./pa_unix_oss/pa_unix.c
+-
+-#all: sharedlib libinstall tests
+-all: sharedlib libinstall testo testq
+-
+-.c.o:
+- -gcc $(CFLAGS) -c -I./pa_common $< -o $*.o
+-
+-.o:
+- -gcc $*.o -o $* -Lpa_unix_oss -lportaudio $(LIBS)
+-
+-#.c.o:
+-# -gcc -c -I./pa_common $< -o $*.o
+-# -gcc $*.o -o $* -Lpa_unix_oss $(LIBS) -lportaudio
+-
+-
+-sharedlib: $(LIBFILES:.c=.o)
+- gcc -shared -o ./pa_unix_oss/libportaudio.so ./pa_common/pa_lib.o ./pa_unix_oss/pa_unix_oss.o ./pa_unix_oss/pa_unix.o
+-
+-libinstall: ./pa_unix_oss/libportaudio.so
+- @cp -f ./pa_unix_oss/libportaudio.so $(LIBINST)
+- @/sbin/ldconfig
+-
+-testo: $(TESTS:.c=.o)
+-
+-testq: $(TESTO:.o=)
+-
+-clean:
+- -@rm -f $(TESTS:.c=.o)
+- -@rm -f $(TESTS:.c=)
+- -@rm -f $(LIBFILES:.c=.o)
+- -@rm -f ./pa_unix_oss/libportaudio.so
+-
+-
++# Make PortAudio for Linux
++# Updated 2001/08/25 Bill Eldridge bill@rfa.org
++# Updated 2001/10/16, philburk@softsynth.com, s/unix_oss/unix_oss/
++# Updated 2002/04/30 Bill Eldridge bill@rfa.org
++# Made the libinstall and tests compile a bit cleaner
++
++# A pretty bare makefile, that figures out all the test files
++# and compiles them against the library in the pa_unix_oss directory.
++
++# Do "make all" and then when happy, "make libinstall"
++# (if not happy, "make clean")
++
++# The ldconfig stuff in libinstall is the wrong way to do it -
++# someone tell me the right way, please
++
++
++LIBS = -lm -lpthread
++
++CDEFINES = -I../pa_common
++CFLAGS = -g
++LIBINST = /usr/local/lib
++
++TESTS:= $(wildcard pa_tests/pa*.c pa_tests/debug*.c)
++TESTO:= $(wildcard pa_tests/pa*.o pa_tests/debug*.o)
++
++LIBFILES:= ./pa_common/pa_lib.c ./pa_unix_oss/pa_unix_oss.c ./pa_unix_oss/pa_unix.c
++
++#all: sharedlib libinstall tests
++all: sharedlib libinstall testo testq
++
++.c.o:
++ -gcc -fPIC $(CFLAGS) -c -I./pa_common $< -o $*.o
++
++.o:
++ -gcc $*.o -o $* -Lpa_unix_oss -lportaudio $(LIBS)
++
++#.c.o:
++# -gcc -c -I./pa_common $< -o $*.o
++# -gcc $*.o -o $* -Lpa_unix_oss $(LIBS) -lportaudio
++
++
++sharedlib: $(LIBFILES:.c=.o)
++ gcc -shared -o ./pa_unix_oss/libportaudio.so ./pa_common/pa_lib.o ./pa_unix_oss/pa_unix_oss.o ./pa_unix_oss/pa_unix.o
++
++libinstall: ./pa_unix_oss/libportaudio.so
++ @cp -f ./pa_unix_oss/libportaudio.so $(LIBINST)
++ @/sbin/ldconfig
++
++testo: $(TESTS:.c=.o)
++
++testq: $(TESTO:.o=)
++
++clean:
++ -@rm -f $(TESTS:.c=.o)
++ -@rm -f $(TESTS:.c=)
++ -@rm -f $(LIBFILES:.c=.o)
++ -@rm -f ./pa_unix_oss/libportaudio.so
++
++
diff --git a/media-libs/portaudio/portaudio-18.1.ebuild b/media-libs/portaudio/portaudio-18.1.ebuild
new file mode 100644
index 000000000000..5496f90e357f
--- /dev/null
+++ b/media-libs/portaudio/portaudio-18.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/portaudio/portaudio-18.1.ebuild,v 1.1 2004/05/06 18:37:41 eradicator Exp $
+
+inherit eutils
+
+MY_P=${PN}_v${PV/./_}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="An open-source cross platform audio API."
+HOMEPAGE="http://www.portaudio.com"
+SRC_URI="http://www.portaudio.com/archives/${MY_P}.zip"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~amd64"
+
+IUSE=""
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}-use-fpic.patch
+}
+
+src_compile() {
+ make -f Makefile.linux sharedlib || die
+}
+
+src_install() {
+
+ dodir /usr/lib
+ cp -f ./pa_unix_oss/libportaudio.so ${D}/usr/lib || die
+
+ dodir /usr/include
+ cp ./pa_common/portaudio.h ${D}/usr/include || die
+
+ dodir /usr/share/doc/portaudio-18
+ cp ./docs/* ${D}/usr/share/doc/portaudio-18 || die
+
+}