summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-02-22 23:55:52 +0000
committerMike Frysinger <vapier@gentoo.org>2005-02-22 23:55:52 +0000
commit379f1edddb94b72cd4e667a2a571055f76aee4e6 (patch)
treeb5ccf8620f95311119d599bd15b0549b34393796 /media-libs
parentadded 1.1.10 to portage (diff)
downloadgentoo-2-379f1edddb94b72cd4e667a2a571055f76aee4e6.tar.gz
gentoo-2-379f1edddb94b72cd4e667a2a571055f76aee4e6.tar.bz2
gentoo-2-379f1edddb94b72cd4e667a2a571055f76aee4e6.zip
fix building with USE=-X #82919 by Diego Pettenò
(Portage version: 2.0.51-r15)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/imlib2/files/imlib2-1.2.0.20050220-no-x.patch18
-rw-r--r--media-libs/imlib2/imlib2-1.2.0-r1.ebuild4
-rw-r--r--media-libs/imlib2/imlib2-1.2.0.20050220.ebuild10
-rw-r--r--media-libs/imlib2/imlib2-9999.ebuild4
4 files changed, 30 insertions, 6 deletions
diff --git a/media-libs/imlib2/files/imlib2-1.2.0.20050220-no-x.patch b/media-libs/imlib2/files/imlib2-1.2.0.20050220-no-x.patch
new file mode 100644
index 000000000000..6e14892bcdea
--- /dev/null
+++ b/media-libs/imlib2/files/imlib2-1.2.0.20050220-no-x.patch
@@ -0,0 +1,18 @@
+Index: src/lib/image.h
+===================================================================
+RCS file: /cvsroot/enlightenment/e17/libs/imlib2/src/lib/image.h,v
+retrieving revision 1.2
+diff -u -r1.2 image.h
+--- src/lib/image.h 16 Jan 2005 18:23:47 -0000 1.2
++++ src/lib/image.h 22 Feb 2005 23:52:42 -0000
+@@ -3,7 +3,9 @@
+
+ #include "common.h"
+ #ifdef BUILD_X11
+-#include <X11/Xlib.h>
++# include <X11/Xlib.h>
++#else
++# define X_DISPLAY_MISSING
+ #endif
+
+ #include <dlfcn.h>
diff --git a/media-libs/imlib2/imlib2-1.2.0-r1.ebuild b/media-libs/imlib2/imlib2-1.2.0-r1.ebuild
index 9b3f7fd9ee98..11d71e00bbbe 100644
--- a/media-libs/imlib2/imlib2-1.2.0-r1.ebuild
+++ b/media-libs/imlib2/imlib2-1.2.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/imlib2/imlib2-1.2.0-r1.ebuild,v 1.1 2005/02/21 05:49:55 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/imlib2/imlib2-1.2.0-r1.ebuild,v 1.2 2005/02/22 23:55:52 vapier Exp $
EHACKAUTOGEN=yes
inherit enlightenment
@@ -34,7 +34,7 @@ src_compile() {
export MY_ECONF="
${mymmx} \
- $(use_with X x) \
+ $(use_enable X x11) \
"
enlightenment_src_compile
}
diff --git a/media-libs/imlib2/imlib2-1.2.0.20050220.ebuild b/media-libs/imlib2/imlib2-1.2.0.20050220.ebuild
index 8e111c717bbe..8c1a1e18a014 100644
--- a/media-libs/imlib2/imlib2-1.2.0.20050220.ebuild
+++ b/media-libs/imlib2/imlib2-1.2.0.20050220.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/imlib2/imlib2-1.2.0.20050220.ebuild,v 1.1 2005/02/21 10:45:37 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/imlib2/imlib2-1.2.0.20050220.ebuild,v 1.2 2005/02/22 23:55:52 vapier Exp $
EHACKAUTOGEN=yes
inherit enlightenment
@@ -18,6 +18,12 @@ DEPEND="=media-libs/freetype-2*
tiff? ( >=media-libs/tiff-3.5.5 )
X? ( virtual/x11 )"
+src_unpack() {
+ enlightenment_src_unpack
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-no-x.patch
+}
+
src_compile() {
local mymmx=""
if [ "${ARCH}" == "amd64" ] ; then
@@ -28,7 +34,7 @@ src_compile() {
export MY_ECONF="
${mymmx} \
- $(use_with X x) \
+ $(use_enable X x11) \
"
enlightenment_src_compile
}
diff --git a/media-libs/imlib2/imlib2-9999.ebuild b/media-libs/imlib2/imlib2-9999.ebuild
index 387b9960a87c..a9cb040b21b0 100644
--- a/media-libs/imlib2/imlib2-9999.ebuild
+++ b/media-libs/imlib2/imlib2-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/imlib2/imlib2-9999.ebuild,v 1.3 2005/01/08 09:00:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/imlib2/imlib2-9999.ebuild,v 1.4 2005/02/22 23:55:52 vapier Exp $
EHACKAUTOGEN=yes
inherit enlightenment
@@ -28,7 +28,7 @@ src_compile() {
export MY_ECONF="
${mymmx} \
- $(use_with X x) \
+ $(use_enable X x11) \
"
enlightenment_src_compile
}