summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-02-02 23:59:14 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-02-02 23:59:14 +0000
commit347bfca8d0f9ef09979451f38baf4de7d9c98c90 (patch)
treea3c3da65e1c8bd245da9e0ac5e5e7e5e41f5d318 /media-libs
parentMarked ~hppa (bug #164775). (diff)
downloadgentoo-2-347bfca8d0f9ef09979451f38baf4de7d9c98c90.tar.gz
gentoo-2-347bfca8d0f9ef09979451f38baf4de7d9c98c90.tar.bz2
gentoo-2-347bfca8d0f9ef09979451f38baf4de7d9c98c90.zip
strip ldflags from allegro-config --libs
(Portage version: 2.1.2-r6)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/allegro/ChangeLog6
-rw-r--r--media-libs/allegro/allegro-4.0.3.ebuild102
-rw-r--r--media-libs/allegro/allegro-4.1.18.ebuild109
-rw-r--r--media-libs/allegro/allegro-4.2.1.ebuild15
-rw-r--r--media-libs/allegro/files/allegro-4.1.18-gcc4.patch35
-rw-r--r--media-libs/allegro/files/allegro-4.1.18-m4.patch11
-rw-r--r--media-libs/allegro/files/allegro-4.2.1-flags.patch52
-rw-r--r--media-libs/allegro/files/digest-allegro-4.0.33
-rw-r--r--media-libs/allegro/files/digest-allegro-4.1.183
9 files changed, 44 insertions, 292 deletions
diff --git a/media-libs/allegro/ChangeLog b/media-libs/allegro/ChangeLog
index 596f97273548..a0f26c9470f8 100644
--- a/media-libs/allegro/ChangeLog
+++ b/media-libs/allegro/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/allegro
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/allegro/ChangeLog,v 1.62 2007/02/02 20:25:46 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/allegro/ChangeLog,v 1.63 2007/02/02 23:59:14 nyhm Exp $
+
+ 02 Feb 2007; Tristan Heaven <nyhm@gentoo.org>
+ files/allegro-4.2.1-flags.patch, allegro-4.2.1.ebuild:
+ strip ldflags from allegro-config --libs
02 Feb 2007; Tristan Heaven <nyhm@gentoo.org> allegro-4.2.1.ebuild:
Add vga USE flag for bug #129534
diff --git a/media-libs/allegro/allegro-4.0.3.ebuild b/media-libs/allegro/allegro-4.0.3.ebuild
deleted file mode 100644
index 8523389c25cb..000000000000
--- a/media-libs/allegro/allegro-4.0.3.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/allegro/allegro-4.0.3.ebuild,v 1.12 2006/03/31 21:15:34 tupone Exp $
-
-inherit flag-o-matic
-
-DESCRIPTION="cross-platform multimedia library"
-HOMEPAGE="http://alleg.sourceforge.net/"
-SRC_URI="mirror://sourceforge/alleg/${P}.tar.gz"
-
-LICENSE="Allegro"
-SLOT="0"
-KEYWORDS="x86 sparc"
-IUSE="static mmx sse oss alsa esd arts X fbcon svga tetex doc"
-
-RDEPEND="alsa? ( media-libs/alsa-lib )
- esd? ( media-sound/esound )
- arts? ( kde-base/arts )
- X? (
- || (
- (
- x11-libs/libXxf86vm
- x11-libs/libXxf86dga
- )
- virtual/x11
- )
- )
- svga? ( media-libs/svgalib )"
-DEPEND="${RDEPEND}
- X? (
- || (
- (
- x11-proto/xextproto
- x11-proto/xf86dgaproto
- x11-proto/xf86vidmodeproto
- )
- virtual/x11
- )
- )
- tetex? ( virtual/tetex )"
-
-src_unpack() {
- unpack ${A}
- # remove the prototype for malloc for gcc34 (bug #58279)
- sed -i \
- -e '/*malloc/d' \
- -e '/TARGET_ARCH=/s:=.*:=:' \
- ${S}/configure \
- || die 'couldnt remove pentium cpu'
-}
-
-src_compile() {
- filter-flags -fPIC
- econf \
- --enable-linux \
- --enable-vga \
- $(use_enable static) \
- $(use_enable static staticprog) \
- $(use_enable mmx) \
- $(use_enable sse) \
- $(use_enable oss ossdigi) \
- $(use_enable oss ossmidi) \
- $(use_enable alsa alsadigi) \
- $(use_enable alsa alsamidi) \
- $(use_enable esd esddigi) \
- $(use_enable arts artsdigi) \
- $(use_with X x) \
- $(use_enable X xwin-shm) \
- $(use_enable X xwin-vidmode) \
- $(use_enable X xwin-dga) \
- $(use_enable X xwin-dga2) \
- $(use_enable fbcon) \
- $(use_enable svga svgalib) \
- || die
-
- sed -i \
- -e "/CFLAGS =.*/s:$: ${CFLAGS}:" \
- makefile \
- || die "sed makefile failed"
- emake -j1 || die # parallel fails
-
- if use tetex ; then
- addwrite /var/lib/texmf
- addwrite /usr/share/texmf
- addwrite /var/cache/fonts
- make docs-dvi docs-ps || die
- fi
-}
-
-src_install() {
- addpredict /usr/share/info
- make DESTDIR=${D} install install-gzipped-man install-gzipped-info || die
-
- # Different format versions of the Allegro documentation
- dodoc AUTHORS CHANGES THANKS readme.txt todo.txt
- use tetex && dodoc docs/allegro.{dvi,ps}
- use doc && dodoc examples/*
- dohtml docs/html/*
- docinto txt ; dodoc docs/txt/*.txt
- docinto rtf ; dodoc docs/rtf/*.rtf
- docinto build ; dodoc docs/build/*.txt
-}
diff --git a/media-libs/allegro/allegro-4.1.18.ebuild b/media-libs/allegro/allegro-4.1.18.ebuild
deleted file mode 100644
index f7a43760c969..000000000000
--- a/media-libs/allegro/allegro-4.1.18.ebuild
+++ /dev/null
@@ -1,109 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/allegro/allegro-4.1.18.ebuild,v 1.8 2006/07/13 13:11:21 agriffis Exp $
-
-inherit flag-o-matic eutils
-
-DESCRIPTION="cross-platform multimedia library"
-HOMEPAGE="http://alleg.sourceforge.net/"
-SRC_URI="mirror://sourceforge/alleg/${P}.tar.gz"
-
-LICENSE="Allegro"
-SLOT="0"
-#-amd64, -sparc: inportb, outportb, outportw undefined
-KEYWORDS="~alpha ~amd64 ia64 ppc -sparc ~x86"
-IUSE="static mmx sse oss alsa esd arts X fbcon svga tetex doc"
-
-RDEPEND="alsa? ( media-libs/alsa-lib )
- esd? ( media-sound/esound )
- arts? ( kde-base/arts )
- X? (
- || (
- (
- x11-libs/libXxf86vm
- x11-libs/libXxf86dga
- )
- virtual/x11
- )
- )
- svga? ( media-libs/svgalib )"
-
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4
- X? (
- || (
- (
- x11-proto/xextproto
- x11-proto/xf86dgaproto
- x11-proto/xf86vidmodeproto
- )
- virtual/x11
- )
- )
- tetex? ( virtual/tetex )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-m4.patch
- epatch "${FILESDIR}"/${P}-gcc4.patch
- sed -i \
- -e 's/&_oss_\(numfrags\|fragsize\)/NULL/' \
- "${S}/setup/setup.c" \
- || die "sed failed"
-}
-
-src_compile() {
- filter-flags -fPIC -fprefetch-loop-arrays
- econf \
- --enable-linux \
- --enable-vga \
- $(use_enable static) \
- $(use_enable static staticprog) \
- $(use_enable mmx) \
- $(use_enable sse) \
- $(use_enable oss ossdigi) \
- $(use_enable oss ossmidi) \
- $(use_enable alsa alsadigi) \
- $(use_enable alsa alsamidi) \
- $(use_enable esd esddigi) \
- $(use_enable arts artsdigi) \
- $(use_with X x) \
- $(use_enable X xwin-shm) \
- $(use_enable X xwin-vidmode) \
- $(use_enable X xwin-dga) \
- $(use_enable X xwin-dga2) \
- $(use_enable fbcon) \
- $(use_enable svga svgalib) \
- || die
-
- emake -j1 CFLAGS="${CFLAGS}" || die "emake failed"
-
- if use tetex ; then
- addwrite /var/lib/texmf
- addwrite /usr/share/texmf
- addwrite /var/cache/fonts
- make docs-dvi docs-ps || die
- fi
-}
-
-src_install() {
- addpredict /usr/share/info
- make DESTDIR="${D}" \
- install \
- install-gzipped-man \
- install-gzipped-info \
- || die "make install failed"
-
- # Different format versions of the Allegro documentation
- dodoc AUTHORS CHANGES THANKS readme.txt todo.txt
- use tetex && dodoc docs/allegro.{dvi,ps}
- use doc && dodoc examples/*
- dohtml docs/html/*
- docinto txt
- dodoc docs/txt/*.txt
- docinto rtf
- dodoc docs/rtf/*.rtf
- docinto build
- dodoc docs/build/*.txt
-}
diff --git a/media-libs/allegro/allegro-4.2.1.ebuild b/media-libs/allegro/allegro-4.2.1.ebuild
index 3660ae2ff9b2..0d40034de957 100644
--- a/media-libs/allegro/allegro-4.2.1.ebuild
+++ b/media-libs/allegro/allegro-4.2.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/allegro/allegro-4.2.1.ebuild,v 1.2 2007/02/02 20:25:46 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/allegro/allegro-4.2.1.ebuild,v 1.3 2007/02/02 23:59:14 nyhm Exp $
-inherit eutils
+inherit autotools eutils
DESCRIPTION="cross-platform multimedia library"
HOMEPAGE="http://alleg.sourceforge.net/"
@@ -40,6 +40,7 @@ src_unpack() {
epatch \
"${FILESDIR}"/${P}-exec-stack.patch \
"${FILESDIR}"/${P}-flags.patch
+ eautoreconf
}
src_compile() {
@@ -64,7 +65,7 @@ src_compile() {
$(use_enable svga svgalib) \
$(use_enable vga) \
|| die
- emake -j1 CFLAGS="${CFLAGS}" || die "emake failed"
+ emake -j1 || die "emake failed"
}
src_install() {
@@ -82,11 +83,3 @@ src_install() {
docinto build
dodoc docs/build/*.txt
}
-
-pkg_postinst() {
- ewarn "\"revdep-rebuild\" must be run now for applications already"
- ewarn "using allegro to continue to work."
- ewarn "revdep-rebuild is part of the gentoolkit package."
- ewarn "(Run \"emerge gentoolkit\" if revdep-rebuild isn't already"
- ewarn "available on your system.)"
-}
diff --git a/media-libs/allegro/files/allegro-4.1.18-gcc4.patch b/media-libs/allegro/files/allegro-4.1.18-gcc4.patch
deleted file mode 100644
index 28f65563cb3d..000000000000
--- a/media-libs/allegro/files/allegro-4.1.18-gcc4.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-Clean up code to work with gcc4
-
-patch by Mark Loeser
-
---- allegro-4.1.18/src/gui.c
-+++ allegro-4.1.18/src/gui.c
-@@ -1798,6 +1798,7 @@
-
-
-
-+static int shutdown_single_menu(MENU_PLAYER *, int *);
- /* update_menu:
- * Updates the status of a menu player object returned by init_menu(),
- * returning TRUE if it is still active or FALSE if it has finished.
-@@ -1810,8 +1810,6 @@
- */
- int update_menu(MENU_PLAYER *player)
- {
-- static int shutdown_single_menu(MENU_PLAYER *, int *);
--
- MENU_PLAYER *i;
- int c, c2;
- int old_sel, child_ret;
---- allegro-4.1.18/src/sound.c
-+++ allegro-4.1.18/src/sound.c
-@@ -25,7 +25,7 @@
-
-
-
--extern DIGI_DRIVER digi_none;
-+static DIGI_DRIVER digi_none;
-
-
-
-
diff --git a/media-libs/allegro/files/allegro-4.1.18-m4.patch b/media-libs/allegro/files/allegro-4.1.18-m4.patch
deleted file mode 100644
index d2ea265e95c2..000000000000
--- a/media-libs/allegro/files/allegro-4.1.18-m4.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- misc/allegro.m4
-+++ misc/allegro.m4
-@@ -11,7 +11,7 @@
- dnl AM_PATH_allegro([MINIMUM-VERSION, [ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND]]])
- dnl Test for allegro, and define allegro_CFLAGS and allegro_LIBS
- dnl
--AC_DEFUN(AM_PATH_ALLEGRO,[
-+AC_DEFUN([AM_PATH_ALLEGRO],[
- AC_ARG_WITH(allegro-prefix,
- [ --with-allegro-prefix=PFX Prefix where liballegro is installed (optional)],
- ALLEGRO_CONFIG_prefix="$withval", ALLEGRO_CONFIG_prefix="")
diff --git a/media-libs/allegro/files/allegro-4.2.1-flags.patch b/media-libs/allegro/files/allegro-4.2.1-flags.patch
index 26aee313d06d..57435622b5d7 100644
--- a/media-libs/allegro/files/allegro-4.2.1-flags.patch
+++ b/media-libs/allegro/files/allegro-4.2.1-flags.patch
@@ -1,23 +1,19 @@
---- configure
-+++ configure
-@@ -2880,7 +2880,6 @@
- echo "$as_me:$LINENO: checking whether linker works with -s option" >&5
- echo $ECHO_N "checking whether linker works with -s option... $ECHO_C" >&6
- allegro_save_LDFLAGS=$LDFLAGS
--LDFLAGS="-s $LDFLAGS"
- if test "${allegro_cv_prog_ld_s+set}" = set; then
- echo $ECHO_N "(cached) $ECHO_C" >&6
- else
-@@ -4959,7 +4958,7 @@
+--- configure.in
++++ configure.in
+@@ -280,11 +280,7 @@
+ COMPILE_PROGRAM=COMPILE_NORMAL
COMPILE_CXX_PROGRAM=COMPILE_CXX_NORMAL
COMPILE_S_PROGRAM=COMPILE_S_NORMAL
- if test "X$allegro_cv_prog_ld_s" = "Xyes"; then
+- if test "X$allegro_cv_prog_ld_s" = "Xyes"; then
- PROG_LDFLAGS="-s \$(LDFLAGS)"
-+ PROG_LDFLAGS="\$(LDFLAGS)"
- else
- PROG_LDFLAGS="\$(LDFLAGS)"
- fi
-@@ -11367,11 +11366,7 @@
+- else
+- PROG_LDFLAGS="\$(LDFLAGS)"
+- fi
++ PROG_LDFLAGS="\$(LDFLAGS)"
+ LIB_TO_LINK=alleg
+ PLUGIN_LIB=lib/unix/libaldat.a
+ allegro_build_normal_library=yes
+@@ -761,11 +757,7 @@
ALLEGRO_DEBUG_CFLAGS="$ALLEGRO_DEBUG_CFLAGS -DDMALLOC"
fi
ALLEGRO_PROFILE_CFLAGS="$CFLAGS -pg $TARGET_ARCH -O2 -funroll-loops -ffast-math $WFLAGS"
@@ -30,6 +26,28 @@
ALLEGRO_SFLAGS="-x assembler-with-cpp"
ALLEGRO_SHAREDLIB_CFLAGS="-fPIC -DALLEGRO_SHARED"
else
+--- misc/allegro-config.in
++++ misc/allegro-config.in
+@@ -21,7 +21,6 @@
+
+ accepts_frameworks=no
+
+-allegro_ldflags="@LDFLAGS@"
+ allegro_libs="@LIBS@"
+ allegro_frameworks="@FRAMEWORKS@"
+ allegro_cflags=""
+@@ -180,9 +179,9 @@
+ if test "$echo_libs" = "yes"; then
+ libdirs=-L${exec_prefix}/lib
+ if test "$static_libs" = "yes"; then
+- echo $libdirs $allegro_ldflags -l${lib_type} $allegro_libs
++ echo $libdirs -l${lib_type} $allegro_libs
+ else
+- echo $libdirs $allegro_ldflags -l${lib_type}-${version} -l${lib_type}_unsharable
++ echo $libdirs -l${lib_type}-${version} -l${lib_type}_unsharable
+ fi
+ fi
+
--- misc/deplib.sh
+++ misc/deplib.sh
@@ -70,7 +70,7 @@
diff --git a/media-libs/allegro/files/digest-allegro-4.0.3 b/media-libs/allegro/files/digest-allegro-4.0.3
deleted file mode 100644
index 49f3ed389a5a..000000000000
--- a/media-libs/allegro/files/digest-allegro-4.0.3
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 4fd1d27c323ba33b6d6cad6c5a1d8a44 allegro-4.0.3.tar.gz 2440083
-RMD160 920b5536c71a7dfc60b0cfa39a7d14a780b270f7 allegro-4.0.3.tar.gz 2440083
-SHA256 fefd91ead73d1e3c3109440e2d465ee7e56eb88f0952199d36b3bc2a2f221f0f allegro-4.0.3.tar.gz 2440083
diff --git a/media-libs/allegro/files/digest-allegro-4.1.18 b/media-libs/allegro/files/digest-allegro-4.1.18
deleted file mode 100644
index 6a3fadeb84fe..000000000000
--- a/media-libs/allegro/files/digest-allegro-4.1.18
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 215b84351f349f5998a77f99bf1218fa allegro-4.1.18.tar.gz 2900486
-RMD160 05dc8ca8783487c9cca694bc22f95a06e77d64fe allegro-4.1.18.tar.gz 2900486
-SHA256 a1d588449d467cd3a0a9c116402f531ef2eb7f8d58836663d12c5188b4cd9982 allegro-4.1.18.tar.gz 2900486