summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-02-19 14:15:48 +0000
committerMichał Górny <mgorny@gentoo.org>2013-02-19 14:15:48 +0000
commit32a70613db39af99b20c1ba3cda760d7e46bebc2 (patch)
treee40fe24f5313977b7c5b9583d01f5617739eacdb /media-libs
parentPick up for proxy maintainership (diff)
downloadgentoo-2-32a70613db39af99b20c1ba3cda760d7e46bebc2.tar.gz
gentoo-2-32a70613db39af99b20c1ba3cda760d7e46bebc2.tar.bz2
gentoo-2-32a70613db39af99b20c1ba3cda760d7e46bebc2.zip
Migrate to python-single-r1.
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/alsa-lib/ChangeLog9
-rw-r--r--media-libs/alsa-lib/alsa-lib-1.0.26-r1.ebuild69
2 files changed, 76 insertions, 2 deletions
diff --git a/media-libs/alsa-lib/ChangeLog b/media-libs/alsa-lib/ChangeLog
index 445a44b90686..c1813cf384bf 100644
--- a/media-libs/alsa-lib/ChangeLog
+++ b/media-libs/alsa-lib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/alsa-lib
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/ChangeLog,v 1.334 2012/09/09 08:32:27 ssuominen Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/ChangeLog,v 1.335 2013/02/19 14:15:48 mgorny Exp $
+
+*alsa-lib-1.0.26-r1 (19 Feb 2013)
+
+ 19 Feb 2013; Michał Górny <mgorny@gentoo.org> +alsa-lib-1.0.26-r1.ebuild:
+ Migrate to python-single-r1.
09 Sep 2012; Samuli Suominen <ssuominen@gentoo.org> alsa-lib-1.0.26.ebuild:
Punt base.eclass from inherit because it was never used and PATCHES was
diff --git a/media-libs/alsa-lib/alsa-lib-1.0.26-r1.ebuild b/media-libs/alsa-lib/alsa-lib-1.0.26-r1.ebuild
new file mode 100644
index 000000000000..536b97bbacc8
--- /dev/null
+++ b/media-libs/alsa-lib/alsa-lib-1.0.26-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/alsa-lib-1.0.26-r1.ebuild,v 1.1 2013/02/19 14:15:48 mgorny Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit autotools eutils multilib python-single-r1
+
+DESCRIPTION="Advanced Linux Sound Architecture Library"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/lib/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc debug alisp python"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ >=media-sound/alsa-headers-1.0.25
+ doc? ( >=app-doc/doxygen-1.2.6 )"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/1.0.25-extraneous-cflags.diff
+ eautoreconf
+ epunt_cxx
+}
+
+src_configure() {
+ local myconf
+ use elibc_uclibc && myconf="--without-versioned"
+
+ econf \
+ --enable-shared \
+ --disable-resmgr \
+ --enable-rawmidi \
+ --enable-seq \
+ --enable-aload \
+ $(use_with debug) \
+ $(use_enable alisp) \
+ $(use_enable python) \
+ ${myconf}
+}
+
+src_compile() {
+ emake
+
+ if use doc; then
+ emake doc
+ fgrep -Zrl "${S}" "${S}/doc/doxygen/html" | \
+ xargs -0 sed -i -e "s:${S}::"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ prune_libtool_files --all
+ find "${ED}"/usr/$(get_libdir)/alsa-lib -name '*.a' -exec rm -f {} +
+
+ dodoc ChangeLog TODO
+ use doc && dohtml -r doc/doxygen/html/*
+}