summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-03-19 21:10:36 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-03-19 21:10:36 +0000
commit27ba7efd3ed63cf72c0c80662159eb5dbec8c04b (patch)
tree7003c8e90ba8bfd31de1e70046954ed0493fc163 /media-libs
parentwork around odd portage and/or bash bug (bug #310197) (diff)
downloadgentoo-2-27ba7efd3ed63cf72c0c80662159eb5dbec8c04b.tar.gz
gentoo-2-27ba7efd3ed63cf72c0c80662159eb5dbec8c04b.tar.bz2
gentoo-2-27ba7efd3ed63cf72c0c80662159eb5dbec8c04b.zip
Version bump to 0.6.2 Bug #308173
(Portage version: 2.1.7.17/cvs/Linux i686)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/atlas-c++/ChangeLog9
-rw-r--r--media-libs/atlas-c++/atlas-c++-0.6.2.ebuild35
2 files changed, 42 insertions, 2 deletions
diff --git a/media-libs/atlas-c++/ChangeLog b/media-libs/atlas-c++/ChangeLog
index 2001cd33a10f..7f6691ff75a2 100644
--- a/media-libs/atlas-c++/ChangeLog
+++ b/media-libs/atlas-c++/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/atlas-c++
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/ChangeLog,v 1.30 2009/07/06 08:13:03 tupone Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/ChangeLog,v 1.31 2010/03/19 21:10:36 tupone Exp $
+
+*atlas-c++-0.6.2 (19 Mar 2010)
+
+ 19 Mar 2010; Tupone Alfredo <tupone@gentoo.org> +atlas-c++-0.6.2.ebuild:
+ Version bump to 0.6.2 Bug #308173 by Guido
06 Jul 2009; Alfredo Tupone <tupone@gentoo.org>
+files/atlas-c++-0.6.1-gcc-4.4.patch, atlas-c++-0.4.5.ebuild,
diff --git a/media-libs/atlas-c++/atlas-c++-0.6.2.ebuild b/media-libs/atlas-c++/atlas-c++-0.6.2.ebuild
new file mode 100644
index 000000000000..715684206f90
--- /dev/null
+++ b/media-libs/atlas-c++/atlas-c++-0.6.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/atlas-c++-0.6.2.ebuild,v 1.1 2010/03/19 21:10:36 tupone Exp $
+EAPI=2
+
+MY_PN="Atlas-C++"
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Atlas protocol, used in role playing games at worldforge."
+HOMEPAGE="http://www.worldforge.org/dev/eng/libraries/atlas_cpp"
+SRC_URI="mirror://sourceforge/worldforge/${MY_P}.tar.bz2"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="doc"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ emake || die "Error: emake failed!"
+ if use doc; then
+ emake docs || die "Error: emake docs failed!"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ use doc && dohtml -r doc/html/*
+ use doc && doman doc/man/*
+ dodoc AUTHORS ChangeLog HACKING NEWS README ROADMAP THANKS TODO
+}