summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2008-01-30 15:42:11 +0000
committerTony Vroon <chainsaw@gentoo.org>2008-01-30 15:42:11 +0000
commit24e556d8c773a8bd63c247109eed7a47001fb0fb (patch)
tree3288611f083fc859b1c034f2f28270c25787155a /media-libs
parentAdding 1.0.16 release candidates, for bug #207427. (diff)
downloadgentoo-2-24e556d8c773a8bd63c247109eed7a47001fb0fb.tar.gz
gentoo-2-24e556d8c773a8bd63c247109eed7a47001fb0fb.tar.bz2
gentoo-2-24e556d8c773a8bd63c247109eed7a47001fb0fb.zip
Adding 1.0.16 release candidates, for bug #207427.
(Portage version: 2.1.4)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/alsa-lib/ChangeLog9
-rw-r--r--media-libs/alsa-lib/alsa-lib-1.0.16_rc1.ebuild98
-rw-r--r--media-libs/alsa-lib/alsa-lib-1.0.16_rc2.ebuild98
-rw-r--r--media-libs/alsa-lib/files/digest-alsa-lib-1.0.16_rc13
-rw-r--r--media-libs/alsa-lib/files/digest-alsa-lib-1.0.16_rc23
5 files changed, 210 insertions, 1 deletions
diff --git a/media-libs/alsa-lib/ChangeLog b/media-libs/alsa-lib/ChangeLog
index f51bb44dc20b..5020d00ebade 100644
--- a/media-libs/alsa-lib/ChangeLog
+++ b/media-libs/alsa-lib/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/alsa-lib
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/ChangeLog,v 1.248 2008/01/10 06:55:17 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/ChangeLog,v 1.249 2008/01/30 15:42:10 chainsaw Exp $
+
+*alsa-lib-1.0.16_rc2 (30 Jan 2008)
+*alsa-lib-1.0.16_rc1 (30 Jan 2008)
+
+ 30 Jan 2008; Tony Vroon <chainsaw@gentoo.org> +alsa-lib-1.0.16_rc1.ebuild,
+ +alsa-lib-1.0.16_rc2.ebuild:
+ Adding 1.0.16 release candidates, for bug #207427.
10 Jan 2008; Mike Frysinger <vapier@gentoo.org> alsa-lib-1.0.15.ebuild:
Since uclibc does not support symbol versioning, make sure to disable
diff --git a/media-libs/alsa-lib/alsa-lib-1.0.16_rc1.ebuild b/media-libs/alsa-lib/alsa-lib-1.0.16_rc1.ebuild
new file mode 100644
index 000000000000..074e78d539af
--- /dev/null
+++ b/media-libs/alsa-lib/alsa-lib-1.0.16_rc1.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/alsa-lib-1.0.16_rc1.ebuild,v 1.1 2008/01/30 15:42:10 chainsaw Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="1.9"
+
+inherit eutils autotools libtool
+
+MY_P="${P/_rc/rc}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Advanced Linux Sound Architecture Library"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/lib/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="doc debug alisp midi"
+
+RDEPEND=""
+DEPEND=">=media-sound/alsa-headers-${PV}
+ doc? ( >=app-doc/doxygen-1.2.6 )"
+
+IUSE_PCM_PLUGIN="copy linear route mulaw alaw adpcm rate plug multi shm file null empty share meter hooks lfloat ladspa dmix dshare dsnoop asym iec958
+softvol extplug ioplug"
+
+for plugin in ${IUSE_PCM_PLUGIN}; do
+ IUSE="${IUSE} alsa_pcm_plugins_${plugin}"
+done
+
+pkg_setup() {
+ if [ -z "${ALSA_PCM_PLUGINS}" ] ; then
+ ewarn "You haven't selected _any_ PCM plugins. Either you set it to something like the default"
+ ewarn "(which is being set in the profile UNLESS you unset them) or alsa based applications"
+ ewarn "are going to *misbehave* !"
+ epause 5
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ elibtoolize
+ epunt_cxx
+}
+
+src_compile() {
+ local myconf
+ use elibc_uclibc && myconf="--without-versioned"
+
+ # needed to avoid gcc looping internaly
+ use hppa && export CFLAGS="-O1 -pipe"
+
+ econf \
+ --enable-static \
+ --enable-shared \
+ --disable-resmgr \
+ $(use_with debug) \
+ $(use_enable alisp) \
+ $(use_enable midi instr) \
+ $(use_enable midi seq) $(use_enable midi aload) \
+ --with-pcm-plugins="${ALSA_PCM_PLUGINS}" \
+ --disable-dependency-tracking \
+ ${myconf} \
+ || die "configure failed"
+
+ emake || die "make failed"
+
+ if use doc; then
+ emake doc || die "failed to generate docs"
+ fgrep -Zrl "${S}" "${S}/doc/doxygen/html" | \
+ xargs -0 sed -i -e "s:${S}::"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodoc ChangeLog TODO
+ use doc && dohtml -r doc/doxygen/html/*
+}
+
+pkg_postinst() {
+ ewarn "Starting from alsa 1.0.11_rc3 the configuration for dmix is changed."
+ ewarn "Leaving around old asound.conf or ~/.asoundrc might make all apps"
+ ewarn "using ALSA output crash."
+ ewarn "Note that dmix output is enabled by default on the 'default' device"
+ ewarn "since ALSA 1.0.9."
+ elog ""
+ elog "Please try in-kernel ALSA drivers instead of the alsa-drivers ebuild."
+ elog "If alsa-drivers works for you where a recent kernel does not, we want "
+ elog "to know about this. Our e-mail address is alsa-bugs@gentoo.org"
+ elog "However, if you notice no sound output or instability, please try to "
+ elog "upgrade your kernel to a newer version first."
+}
diff --git a/media-libs/alsa-lib/alsa-lib-1.0.16_rc2.ebuild b/media-libs/alsa-lib/alsa-lib-1.0.16_rc2.ebuild
new file mode 100644
index 000000000000..8503efde29a6
--- /dev/null
+++ b/media-libs/alsa-lib/alsa-lib-1.0.16_rc2.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/alsa-lib-1.0.16_rc2.ebuild,v 1.1 2008/01/30 15:42:10 chainsaw Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="1.9"
+
+inherit eutils autotools libtool
+
+MY_P="${P/_rc/rc}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Advanced Linux Sound Architecture Library"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/lib/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="doc debug alisp midi"
+
+RDEPEND=""
+DEPEND=">=media-sound/alsa-headers-${PV}
+ doc? ( >=app-doc/doxygen-1.2.6 )"
+
+IUSE_PCM_PLUGIN="copy linear route mulaw alaw adpcm rate plug multi shm file null empty share meter hooks lfloat ladspa dmix dshare dsnoop asym iec958
+softvol extplug ioplug"
+
+for plugin in ${IUSE_PCM_PLUGIN}; do
+ IUSE="${IUSE} alsa_pcm_plugins_${plugin}"
+done
+
+pkg_setup() {
+ if [ -z "${ALSA_PCM_PLUGINS}" ] ; then
+ ewarn "You haven't selected _any_ PCM plugins. Either you set it to something like the default"
+ ewarn "(which is being set in the profile UNLESS you unset them) or alsa based applications"
+ ewarn "are going to *misbehave* !"
+ epause 5
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ elibtoolize
+ epunt_cxx
+}
+
+src_compile() {
+ local myconf
+ use elibc_uclibc && myconf="--without-versioned"
+
+ # needed to avoid gcc looping internaly
+ use hppa && export CFLAGS="-O1 -pipe"
+
+ econf \
+ --enable-static \
+ --enable-shared \
+ --disable-resmgr \
+ $(use_with debug) \
+ $(use_enable alisp) \
+ $(use_enable midi instr) \
+ $(use_enable midi seq) $(use_enable midi aload) \
+ --with-pcm-plugins="${ALSA_PCM_PLUGINS}" \
+ --disable-dependency-tracking \
+ ${myconf} \
+ || die "configure failed"
+
+ emake || die "make failed"
+
+ if use doc; then
+ emake doc || die "failed to generate docs"
+ fgrep -Zrl "${S}" "${S}/doc/doxygen/html" | \
+ xargs -0 sed -i -e "s:${S}::"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodoc ChangeLog TODO
+ use doc && dohtml -r doc/doxygen/html/*
+}
+
+pkg_postinst() {
+ ewarn "Starting from alsa 1.0.11_rc3 the configuration for dmix is changed."
+ ewarn "Leaving around old asound.conf or ~/.asoundrc might make all apps"
+ ewarn "using ALSA output crash."
+ ewarn "Note that dmix output is enabled by default on the 'default' device"
+ ewarn "since ALSA 1.0.9."
+ elog ""
+ elog "Please try in-kernel ALSA drivers instead of the alsa-drivers ebuild."
+ elog "If alsa-drivers works for you where a recent kernel does not, we want "
+ elog "to know about this. Our e-mail address is alsa-bugs@gentoo.org"
+ elog "However, if you notice no sound output or instability, please try to "
+ elog "upgrade your kernel to a newer version first."
+}
diff --git a/media-libs/alsa-lib/files/digest-alsa-lib-1.0.16_rc1 b/media-libs/alsa-lib/files/digest-alsa-lib-1.0.16_rc1
new file mode 100644
index 000000000000..121b4c8e83b3
--- /dev/null
+++ b/media-libs/alsa-lib/files/digest-alsa-lib-1.0.16_rc1
@@ -0,0 +1,3 @@
+MD5 e66c2ac8578d75678e99b30727518fce alsa-lib-1.0.16rc1.tar.bz2 781932
+RMD160 40f2b331903d0faa803de5c73b647e35ae6d319d alsa-lib-1.0.16rc1.tar.bz2 781932
+SHA256 7d452552ad2e1d1b4767c6842e69d6c8d9bc92ff469c524f840ef755812c1e3b alsa-lib-1.0.16rc1.tar.bz2 781932
diff --git a/media-libs/alsa-lib/files/digest-alsa-lib-1.0.16_rc2 b/media-libs/alsa-lib/files/digest-alsa-lib-1.0.16_rc2
new file mode 100644
index 000000000000..a932d1783869
--- /dev/null
+++ b/media-libs/alsa-lib/files/digest-alsa-lib-1.0.16_rc2
@@ -0,0 +1,3 @@
+MD5 c66cb13ec2fb5695d2e587c3a6a017c5 alsa-lib-1.0.16rc2.tar.bz2 782576
+RMD160 f76e7c2245ae09a757aa5a75104c59ba922832d8 alsa-lib-1.0.16rc2.tar.bz2 782576
+SHA256 3860fcb9a9b6f025484bc719c1af3471105e71ee4bd2769105e6cab263d22131 alsa-lib-1.0.16rc2.tar.bz2 782576