summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-01-12 05:45:55 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-01-12 05:45:55 +0000
commit20c49b93ed842a918913da4920f919bc135943b8 (patch)
treef95c453974357d5a043855d995fa74669cf66c58 /media-libs
parentAdd pyclutter-1.3 to the >=clutter-1.4 mask (diff)
downloadgentoo-2-20c49b93ed842a918913da4920f919bc135943b8.tar.gz
gentoo-2-20c49b93ed842a918913da4920f919bc135943b8.tar.bz2
gentoo-2-20c49b93ed842a918913da4920f919bc135943b8.zip
Bump to 1.5.12, remove old, always use the gdk-pixbuf backend, cogl2 reference building was broken, and has been removed by upstream
(Portage version: 2.1.9.30/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/clutter/ChangeLog11
-rw-r--r--media-libs/clutter/clutter-1.5.12.ebuild (renamed from media-libs/clutter/clutter-1.5.10.ebuild)22
-rw-r--r--media-libs/clutter/clutter-1.5.8.ebuild85
3 files changed, 17 insertions, 101 deletions
diff --git a/media-libs/clutter/ChangeLog b/media-libs/clutter/ChangeLog
index 4290d83dced8..87bf4a3e1b86 100644
--- a/media-libs/clutter/ChangeLog
+++ b/media-libs/clutter/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/clutter
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/clutter/ChangeLog,v 1.12 2010/12/24 01:49:39 nirbheek Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/clutter/ChangeLog,v 1.13 2011/01/12 05:45:55 nirbheek Exp $
+
+*clutter-1.5.12 (12 Jan 2011)
+
+ 12 Jan 2011; <nirbheek@gentoo.org> -clutter-1.5.8.ebuild,
+ -clutter-1.5.10.ebuild, +clutter-1.5.12.ebuild:
+ Bump to 1.5.12, remove old, always use the gdk-pixbuf backend, cogl2
+ reference building was broken, and has been removed by upstream
*clutter-1.5.10 (24 Dec 2010)
diff --git a/media-libs/clutter/clutter-1.5.10.ebuild b/media-libs/clutter/clutter-1.5.12.ebuild
index 34d938de5a5c..36c5659379d2 100644
--- a/media-libs/clutter/clutter-1.5.10.ebuild
+++ b/media-libs/clutter/clutter-1.5.12.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/clutter/clutter-1.5.10.ebuild,v 1.1 2010/12/24 01:49:39 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/clutter/clutter-1.5.12.ebuild,v 1.1 2011/01/12 05:45:55 nirbheek Exp $
EAPI="2"
@@ -10,9 +10,10 @@ DESCRIPTION="Clutter is a library for creating graphical user interfaces"
SLOT="1.0"
KEYWORDS="~amd64 ~ppc64 ~x86"
-IUSE="debug doc +gtk +introspection"
+IUSE="debug doc +introspection"
# NOTE: glx flavour uses libdrm + >=mesa-7.3
+# We always use the gdk-pixbuf backend now since it's been split out
RDEPEND=">=dev-libs/glib-2.26
>=x11-libs/cairo-1.10
>=x11-libs/pango-1.20[introspection?]
@@ -29,9 +30,9 @@ RDEPEND=">=dev-libs/glib-2.26
>=x11-libs/libXfixes-3
>=x11-libs/libXcomposite-0.4
- gtk? ( || (
- x11-libs/gdk-pixbuf
- >=x11-libs/gtk+-2.0 ) )
+ || ( x11-libs/gdk-pixbuf
+ >=x11-libs/gtk+-2.0 )
+
introspection? ( >=dev-libs/gobject-introspection-0.9.6 )
"
DEPEND="${RDEPEND}
@@ -67,14 +68,7 @@ src_configure() {
--with-flavour=glx
--with-imagebackend=gdk-pixbuf
$(use_enable introspection)
- $(use_enable doc docs)
- $(use_enable doc cogl2-reference)"
-
- if ! use gtk; then
- myconf="${myconf} --with-imagebackend=internal"
- # Internal image backend is experimental
- ewarn "You have selected the experimental internal image backend"
- fi
+ $(use_enable doc docs)"
if use debug; then
myconf="${myconf}
diff --git a/media-libs/clutter/clutter-1.5.8.ebuild b/media-libs/clutter/clutter-1.5.8.ebuild
deleted file mode 100644
index 31e1778d4133..000000000000
--- a/media-libs/clutter/clutter-1.5.8.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/clutter/clutter-1.5.8.ebuild,v 1.1 2010/12/05 14:37:51 nirbheek Exp $
-
-EAPI="2"
-
-inherit clutter
-
-DESCRIPTION="Clutter is a library for creating graphical user interfaces"
-
-SLOT="1.0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
-IUSE="debug doc +gtk +introspection"
-
-# NOTE: glx flavour uses libdrm + >=mesa-7.3
-RDEPEND=">=dev-libs/glib-2.26
- >=x11-libs/cairo-1.10
- >=x11-libs/pango-1.20[introspection?]
- >=dev-libs/json-glib-0.12[introspection?]
- >=dev-libs/atk-1.7
-
- virtual/opengl
- x11-libs/libdrm
- x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXdamage
- x11-libs/libXi
- x11-proto/inputproto
- >=x11-libs/libXfixes-3
- >=x11-libs/libXcomposite-0.4
-
- gtk? ( || (
- x11-libs/gdk-pixbuf
- >=x11-libs/gtk+-2.0 ) )
- introspection? ( >=dev-libs/gobject-introspection-0.9.6 )
-"
-DEPEND="${RDEPEND}
- sys-devel/gettext
- dev-util/pkgconfig
- >=dev-util/gtk-doc-am-1.13
- doc? (
- >=dev-util/gtk-doc-1.13
- >=app-text/docbook-sgml-utils-0.6.14[jadetex]
- dev-libs/libxslt )
-"
-DOCS="AUTHORS README NEWS ChangeLog*"
-
-src_configure() {
- # We only need conformance tests, the rest are useless for us
- sed -e 's/^\(SUBDIRS =\).*/\1/g' \
- -i tests/Makefile.am || die "am tests sed failed"
- sed -e 's/^\(SUBDIRS =\).*/\1/g' \
- -i tests/Makefile.in || die "in tests sed failed"
-
- # XXX: Conformance test suite (and clutter itself) does not work under Xvfb
- # XXX: Profiling, coverage disabled for now
- # XXX: What about eglx/eglnative/opengl-egl-xlib/osx/wayland/etc flavours?
- local myconf="
- --enable-debug=minimum
- --enable-cogl-debug=minimum
- --enable-conformance=no
- --disable-gcov
- --enable-profile=no
- --enable-maintainer-flags=no
- --enable-xinput
- --with-flavour=glx
- --with-imagebackend=gdk-pixbuf
- $(use_enable introspection)
- $(use_enable doc docs)
- $(use_enable doc cogl2-reference)"
-
- if ! use gtk; then
- myconf="${myconf} --with-imagebackend=internal"
- # Internal image backend is experimental
- ewarn "You have selected the experimental internal image backend"
- fi
-
- if use debug; then
- myconf="${myconf}
- --enable-debug=yes
- --enable-cogl-debug=yes"
- fi
-
- econf ${myconf}
-}