summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-01-19 11:15:29 +0000
committerPacho Ramos <pacho@gentoo.org>2015-01-19 11:15:29 +0000
commit1bacd033091329d2d4ccc73ba89c77de31e09a41 (patch)
tree6524b1385a43a9786ae68b8f32a56672bea22f41 /media-libs
parentUse development homepage instead of defunct website. (diff)
downloadgentoo-2-1bacd033091329d2d4ccc73ba89c77de31e09a41.tar.gz
gentoo-2-1bacd033091329d2d4ccc73ba89c77de31e09a41.tar.bz2
gentoo-2-1bacd033091329d2d4ccc73ba89c77de31e09a41.zip
Fix compilation with gcc-4.9 (#529962 by Martin Väth and Stephan Hartmann), fix hang during gapless transition (#520090 by Georg Rudoy), drop old
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/gst-plugins-base/ChangeLog12
-rw-r--r--media-libs/gst-plugins-base/files/gst-plugins-base-0.10.36-gcc-4.9.patch18
-rw-r--r--media-libs/gst-plugins-base/files/gst-plugins-base-0.10.36-resync-ringbuffer.patch15
-rw-r--r--media-libs/gst-plugins-base/gst-plugins-base-0.10.36-r1.ebuild12
-rw-r--r--media-libs/gst-plugins-base/gst-plugins-base-0.10.36.ebuild64
-rw-r--r--media-libs/gst-plugins-base/gst-plugins-base-1.2.4-r1.ebuild9
6 files changed, 58 insertions, 72 deletions
diff --git a/media-libs/gst-plugins-base/ChangeLog b/media-libs/gst-plugins-base/ChangeLog
index b129007131c2..0eb9f27dfd3d 100644
--- a/media-libs/gst-plugins-base/ChangeLog
+++ b/media-libs/gst-plugins-base/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-libs/gst-plugins-base
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-base/ChangeLog,v 1.259 2014/12/24 18:43:16 leio Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-base/ChangeLog,v 1.260 2015/01/19 11:15:29 pacho Exp $
+
+ 19 Jan 2015; Pacho Ramos <pacho@gentoo.org>
+ +files/gst-plugins-base-0.10.36-gcc-4.9.patch,
+ +files/gst-plugins-base-0.10.36-resync-ringbuffer.patch,
+ -gst-plugins-base-0.10.36.ebuild, gst-plugins-base-0.10.36-r1.ebuild,
+ gst-plugins-base-1.2.4-r1.ebuild:
+ Fix compilation with gcc-4.9 (#529962 by Martin Väth and Stephan Hartmann),
+ fix hang during gapless transition (#520090 by Georg Rudoy), drop old
*gst-plugins-base-1.4.5 (24 Dec 2014)
diff --git a/media-libs/gst-plugins-base/files/gst-plugins-base-0.10.36-gcc-4.9.patch b/media-libs/gst-plugins-base/files/gst-plugins-base-0.10.36-gcc-4.9.patch
new file mode 100644
index 000000000000..8ee0e7e4acbd
--- /dev/null
+++ b/media-libs/gst-plugins-base/files/gst-plugins-base-0.10.36-gcc-4.9.patch
@@ -0,0 +1,18 @@
+--- 1/gst/audioresample/resample.c
++++ 1/gst/audioresample/resample.c
+@@ -77,13 +77,13 @@
+ #define EXPORT G_GNUC_INTERNAL
+
+ #ifdef _USE_SSE
+-#ifndef HAVE_XMMINTRIN_H
++#if !defined(__SSE__) || !defined(HAVE_XMMINTRIN_H)
+ #undef _USE_SSE
+ #endif
+ #endif
+
+ #ifdef _USE_SSE2
+-#ifndef HAVE_EMMINTRIN_H
++#if !defined(__SSE2__) || !defined(HAVE_EMMINTRIN_H)
+ #undef _USE_SSE2
+ #endif
+ #endif
diff --git a/media-libs/gst-plugins-base/files/gst-plugins-base-0.10.36-resync-ringbuffer.patch b/media-libs/gst-plugins-base/files/gst-plugins-base-0.10.36-resync-ringbuffer.patch
new file mode 100644
index 000000000000..1aae7099659e
--- /dev/null
+++ b/media-libs/gst-plugins-base/files/gst-plugins-base-0.10.36-resync-ringbuffer.patch
@@ -0,0 +1,15 @@
+--- a/gst-libs/gst/audio/gstbaseaudiosink.c
++++ b/gst-libs/gst/audio/gstbaseaudiosink.c
+@@ -921,6 +921,12 @@
+ if (!gst_ring_buffer_acquire (sink->ringbuffer, spec))
+ goto acquire_error;
+
++ /* We need to resync since the ringbuffer restarted */
++ sink->priv->avg_skew = -1;
++ sink->next_sample = -1;
++ sink->priv->eos_time = -1;
++ sink->priv->discont_time = -1;
++
+ if (bsink->pad_mode == GST_ACTIVATE_PUSH) {
+ GST_DEBUG_OBJECT (sink, "activate ringbuffer");
+ gst_ring_buffer_activate (sink->ringbuffer, TRUE); \ No newline at end of file
diff --git a/media-libs/gst-plugins-base/gst-plugins-base-0.10.36-r1.ebuild b/media-libs/gst-plugins-base/gst-plugins-base-0.10.36-r1.ebuild
index 0c5af397c313..246f4a6f8c34 100644
--- a/media-libs/gst-plugins-base/gst-plugins-base-0.10.36-r1.ebuild
+++ b/media-libs/gst-plugins-base/gst-plugins-base-0.10.36-r1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-base/gst-plugins-base-0.10.36-r1.ebuild,v 1.11 2014/10/11 12:41:40 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-base/gst-plugins-base-0.10.36-r1.ebuild,v 1.12 2015/01/19 11:15:29 pacho Exp $
EAPI="5"
GST_ORG_MODULE="gst-plugins-base"
-inherit gstreamer
+inherit eutils gstreamer
DESCRIPTION="Basepack of plugins for gstreamer"
HOMEPAGE="http://gstreamer.freedesktop.org/"
@@ -37,6 +37,12 @@ src_prepare() {
# though they are not actually used. This needs to be fixed upstream by
# replacing AC_PATH_XTRA with PKG_CONFIG calls.
sed -i -e 's:X_PRE_LIBS -lSM -lICE:X_PRE_LIBS:' "${S}"/configure || die
+
+ # Fix compilation with gcc-4.9, bug #529962
+ epatch "${FILESDIR}"/${PN}-0.10.36-gcc-4.9.patch
+
+ # baseaudiosink: Resync when ringbuffer resets (from '0.10' branch)
+ epatch "${FILESDIR}"/${PN}-0.10.36-resync-ringbuffer.patch
}
multilib_src_configure() {
diff --git a/media-libs/gst-plugins-base/gst-plugins-base-0.10.36.ebuild b/media-libs/gst-plugins-base/gst-plugins-base-0.10.36.ebuild
deleted file mode 100644
index ff404f0b1a19..000000000000
--- a/media-libs/gst-plugins-base/gst-plugins-base-0.10.36.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-base/gst-plugins-base-0.10.36.ebuild,v 1.15 2013/02/24 17:55:12 ago Exp $
-
-EAPI="5"
-
-inherit gst-plugins-base gst-plugins10
-
-DESCRIPTION="Basepack of plugins for gstreamer"
-HOMEPAGE="http://gstreamer.freedesktop.org/"
-
-LICENSE="GPL-2+ LGPL-2+"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="+introspection nls +orc"
-
-RDEPEND=">=dev-libs/glib-2.24:2
- >=media-libs/gstreamer-${PV}:0.10[introspection?]
- dev-libs/libxml2:2
- sys-libs/zlib
- app-text/iso-codes
- introspection? ( >=dev-libs/gobject-introspection-0.9.12 )
- orc? ( >=dev-lang/orc-0.4.11 )
-"
-DEPEND="${RDEPEND}
- >=dev-util/gtk-doc-am-1.3
-"
-RDEPEND="${RDEPEND}
- !<media-libs/gst-plugins-bad-0.10.10:0.10
-"
-
-src_prepare() {
- # The AC_PATH_XTRA macro unnecessarily pulls in libSM and libICE even
- # though they are not actually used. This needs to be fixed upstream by
- # replacing AC_PATH_XTRA with PKG_CONFIG calls.
- sed -i -e 's:X_PRE_LIBS -lSM -lICE:X_PRE_LIBS:' "${S}"/configure || die
-}
-
-src_configure() {
- gst-plugins10_src_configure \
- $(use_enable introspection) \
- $(use_enable nls) \
- $(use_enable orc) \
- --disable-examples \
- --disable-debug \
- --disable-static
-
- # bug #366931, flag-o-matic for the whole thing is overkill
- if [[ ${CHOST} == *86-*-darwin* ]] ; then
- sed -i \
- -e '/FLAGS = /s|-O[23]|-O1|g' \
- gst/audioconvert/Makefile \
- gst/volume/Makefile || die
- fi
-}
-
-src_compile() {
- default
-}
-
-src_install() {
- DOCS="AUTHORS NEWS README RELEASE"
- default
- prune_libtool_files --modules
-}
diff --git a/media-libs/gst-plugins-base/gst-plugins-base-1.2.4-r1.ebuild b/media-libs/gst-plugins-base/gst-plugins-base-1.2.4-r1.ebuild
index 20b9fcdd679d..d3616473fb51 100644
--- a/media-libs/gst-plugins-base/gst-plugins-base-1.2.4-r1.ebuild
+++ b/media-libs/gst-plugins-base/gst-plugins-base-1.2.4-r1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-base/gst-plugins-base-1.2.4-r1.ebuild,v 1.12 2014/10/11 12:40:59 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-base/gst-plugins-base-1.2.4-r1.ebuild,v 1.13 2015/01/19 11:15:29 pacho Exp $
EAPI="5"
GST_ORG_MODULE="gst-plugins-base"
-inherit gstreamer
+inherit eutils gstreamer
DESCRIPTION="Basepack of plugins for gstreamer"
HOMEPAGE="http://gstreamer.freedesktop.org/"
@@ -50,6 +50,9 @@ src_prepare() {
# though they are not actually used. This needs to be fixed upstream by
# replacing AC_PATH_XTRA with PKG_CONFIG calls, upstream bug #731047
sed -i -e 's:X_PRE_LIBS -lSM -lICE:X_PRE_LIBS:' "${S}"/configure || die
+
+ # Fix compilation with gcc-4.9, bug #529962
+ epatch "${FILESDIR}"/${PN}-0.10.36-gcc-4.9.patch
}
multilib_src_configure() {