summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-06-16 19:22:15 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-06-16 19:22:15 +0000
commit0ea019e9af09d24b746f9ed0bb0cc79217280848 (patch)
tree2a68c1442ad2f43c36b91bf01fbba01984c22428 /media-libs
parentrphil forgot the _01 in the directory name (diff)
downloadgentoo-2-0ea019e9af09d24b746f9ed0bb0cc79217280848.tar.gz
gentoo-2-0ea019e9af09d24b746f9ed0bb0cc79217280848.tar.bz2
gentoo-2-0ea019e9af09d24b746f9ed0bb0cc79217280848.zip
This is a bunch of gcc-3.1 fixes, updates and generally preparing to unmask
xine-0.9.10, when we do unmask it users of xine-d4d and xine-d5d will need to know that those plugins are not yet available for the new version.
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libdvdnav/ChangeLog10
-rw-r--r--media-libs/libdvdnav/files/digest-libdvdnav-0.1.11
-rw-r--r--media-libs/libdvdnav/libdvdnav-0.1.1.ebuild29
-rw-r--r--media-libs/xine-lib/ChangeLog13
-rw-r--r--media-libs/xine-lib/files/digest-xine-lib-0.9.10-r11
-rw-r--r--media-libs/xine-lib/xine-lib-0.9.10-r1.ebuild88
6 files changed, 138 insertions, 4 deletions
diff --git a/media-libs/libdvdnav/ChangeLog b/media-libs/libdvdnav/ChangeLog
index 3ebf2ce47962..545904c19df8 100644
--- a/media-libs/libdvdnav/ChangeLog
+++ b/media-libs/libdvdnav/ChangeLog
@@ -1,9 +1,15 @@
# ChangeLog for media-lib/libdvdnav
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libdvdnav/ChangeLog,v 1.1 2002/05/01 03:07:14 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libdvdnav/ChangeLog,v 1.2 2002/06/16 19:22:15 lostlogic Exp $
+
+*libdvdnav-0.1.1 (16 Jun 2002)
+
+ 16 Jun 2002; Brandon Low <lostlogic@gentoo.org> libdvdnav-0.1.1.ebuild:
+
+ Update to new version for xine-0.9.10
*libdvdnav-0.1.0 (30 Apr 2002)
30 April 2002; Arcady Genkin <agenkin@thpoon.com> libdvdnav-0.1.0.ebuild:
- Initial version. \ No newline at end of file
+ Initial version.
diff --git a/media-libs/libdvdnav/files/digest-libdvdnav-0.1.1 b/media-libs/libdvdnav/files/digest-libdvdnav-0.1.1
new file mode 100644
index 000000000000..12f64f532572
--- /dev/null
+++ b/media-libs/libdvdnav/files/digest-libdvdnav-0.1.1
@@ -0,0 +1 @@
+MD5 8bd7de2e866b2cd0b336b1a0287a8730 libdvdnav-0.1.1.tar.gz 219327
diff --git a/media-libs/libdvdnav/libdvdnav-0.1.1.ebuild b/media-libs/libdvdnav/libdvdnav-0.1.1.ebuild
new file mode 100644
index 000000000000..6d5be69c1a7d
--- /dev/null
+++ b/media-libs/libdvdnav/libdvdnav-0.1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2002 Arcady Genkin <agenkin@thpoon.com>
+# Distributed under the terms of the GNU General Public License, v2
+# Maintainer: Arcady Genkin <agenkin@thpoon.com>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libdvdnav/libdvdnav-0.1.1.ebuild,v 1.1 2002/06/16 19:22:15 lostlogic Exp $
+
+DESCRIPTION="Library for DVD navigation tools."
+HOMEPAGE="http://sourceforge.net/projects/dvd/"
+
+SRC_URI="mirror://sourceforge/dvd/${P}.tar.gz"
+S=${WORKDIR}/${P}
+
+LICENSE="GPL"
+
+DEPEND="media-libs/libdvdread"
+
+src_compile() {
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS COPYING INSTALL NEWS README
+}
diff --git a/media-libs/xine-lib/ChangeLog b/media-libs/xine-lib/ChangeLog
index fc9ae8ba7401..23bca5356e2e 100644
--- a/media-libs/xine-lib/ChangeLog
+++ b/media-libs/xine-lib/ChangeLog
@@ -1,8 +1,17 @@
# ChangeLog for media-libs/xine-lib
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/ChangeLog,v 1.8 2002/06/08 13:52:04 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/ChangeLog,v 1.9 2002/06/16 19:22:15 lostlogic Exp $
-*xine-lib-0.9.9-r2 (r87 Jun 2002)
+*xine-lib-0.9.10-r1 (16 Jun 2002)
+
+ 16 Jun 2002; Brandon Low <lostlogic@gentoo.org> xine-lib-0.9.10-r1.ebuild
+
+ Put dxr3 compilation back in, it works fine with xine-lib-0.9.10.
+
+ A note, gcc-3.1 users will not be able to compile xine-lib-0.9.10 if they
+ have DirectFB installed. Still working on this.
+
+*xine-lib-0.9.9-r2 (8 Jun 2002)
8 Jun 2002; Seemant Kulleen <seemant@gentoo.org> xine-lib-0.9.9-r2.ebuild
files/digest-xine-lib-0.9.9-r2 :
diff --git a/media-libs/xine-lib/files/digest-xine-lib-0.9.10-r1 b/media-libs/xine-lib/files/digest-xine-lib-0.9.10-r1
new file mode 100644
index 000000000000..69d20b605797
--- /dev/null
+++ b/media-libs/xine-lib/files/digest-xine-lib-0.9.10-r1
@@ -0,0 +1 @@
+MD5 2f17619b58b2e6c84c1421ed36045983 xine-lib-0.9.10.tar.gz 2023140
diff --git a/media-libs/xine-lib/xine-lib-0.9.10-r1.ebuild b/media-libs/xine-lib/xine-lib-0.9.10-r1.ebuild
new file mode 100644
index 000000000000..057f1c3c3e64
--- /dev/null
+++ b/media-libs/xine-lib/xine-lib-0.9.10-r1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Author Martin Schlemmer <azarah@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-0.9.10-r1.ebuild,v 1.1 2002/06/16 19:22:15 lostlogic Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Xine is a free gpl-licensed video player for unix-like systems"
+SRC_URI="http://xine.sourceforge.net/files/xine-lib-${PV}.tar.gz"
+HOMEPAGE="http://xine.sourceforge.net/"
+
+DEPEND="X? ( virtual/x11 )
+ avi? ( >=media-libs/win32codecs-0.50
+ media-libs/divx4linux )
+ esd? ( media-sound/esound )
+ dvd? ( >=media-libs/libdvdcss-0.0.3.3
+ >=media-libs/libdvdread-0.9.2 )
+ arts? ( kde-base/kdelibs )
+ alsa? ( media-libs/alsa-lib )
+ aalib? ( media-libs/aalib )
+ oggvorbis? ( media-libs/libvorbis )"
+
+RDEPEND="${DEPEND}
+ nls? ( sys-devel/gettext )"
+
+SLOT="0"
+
+src_compile() {
+
+ libtoolize --copy --force
+
+ # Most of these are not working currently, but are here for completeness
+ local myconf
+ use X || myconf="${myconf} --disable-x11 --disable-xv"
+ use esd || myconf="${myconf} --disable-esd --disable-esdtest"
+ use nls || myconf="${myconf} --disable-nls"
+ use alsa || myconf="${myconf} --disable-alsa --disable-alsatest"
+ use arts || myconf="${myconf} --disable-arts --disable-artstest"
+ # This breaks because with the test disabled, it defaults to "found" check with
+ # the next release until then let it autodetect. See bug #2377.
+ # use aalib || myconf="${myconf} --disable-aalib --disable-aalibtest"
+
+ use oggvorbis \
+ || myconf="${myconf} --disable-ogg --disable-oggtest --disable-vorbis --disable-vorbistest"
+
+ use avi \
+ && myconf="${myconf} --with-w32-path=/usr/lib/win32" \
+ || myconf="${myconf} --disable-asf"
+
+ # This is ``fixes'' compilation problems when em8300 libs installed
+ # The proper fix is to follow.
+ # myconf="${myconf} --disable-dxr3 --disable-dxr3test"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --sysconfdir=/etc \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ docdir=${D}/usr/share/doc/${PF}/html \
+ sysconfdir=${D}/etc \
+ install || die
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL README TODO
+ cd ${S}/doc
+ dodoc dataflow.dia README*
+
+}
+
+pkg_postinst() {
+
+ einfo
+ einfo "Please note, a new version of xine-lib has been installed,"
+ einfo "for library consistency you need to unmerge old versions"
+ einfo "of xine-lib before merging xine-ui."
+ einfo "Please also note that xine-d4d and xine-d5d plugins are"
+ einfo "not yet compatible with this new library."
+ einfo
+
+}