summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2008-12-12 05:41:57 +0000
committerSteve Dibb <beandog@gentoo.org>2008-12-12 05:41:57 +0000
commit192f03f7da3f0842b0f2b0ba9515420fdba91a05 (patch)
tree654eff96a9ff0e60c515ca09d7219cbcb9e69754 /media-libs/xvid
parentVersion bump, bug 249934 (diff)
downloadgentoo-2-192f03f7da3f0842b0f2b0ba9515420fdba91a05.tar.gz
gentoo-2-192f03f7da3f0842b0f2b0ba9515420fdba91a05.tar.bz2
gentoo-2-192f03f7da3f0842b0f2b0ba9515420fdba91a05.zip
Version bump, bug 249934
(Portage version: 2.2_rc17/cvs/Linux 2.6.27-gentoo x86_64)
Diffstat (limited to 'media-libs/xvid')
-rw-r--r--media-libs/xvid/ChangeLog7
-rw-r--r--media-libs/xvid/xvid-1.2.1.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/media-libs/xvid/ChangeLog b/media-libs/xvid/ChangeLog
index 6afdd8250961..601f748e1eb0 100644
--- a/media-libs/xvid/ChangeLog
+++ b/media-libs/xvid/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/xvid
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xvid/ChangeLog,v 1.101 2008/12/12 05:31:20 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xvid/ChangeLog,v 1.102 2008/12/12 05:41:57 beandog Exp $
+
+*xvid-1.2.1 (12 Dec 2008)
+
+ 12 Dec 2008; Steve Dibb <beandog@gentoo.org> +xvid-1.2.1.ebuild:
+ Version bump, bug 249934
*xvid-1.2.0 (12 Dec 2008)
diff --git a/media-libs/xvid/xvid-1.2.1.ebuild b/media-libs/xvid/xvid-1.2.1.ebuild
new file mode 100644
index 000000000000..815f5994c672
--- /dev/null
+++ b/media-libs/xvid/xvid-1.2.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xvid/xvid-1.2.1.ebuild,v 1.1 2008/12/12 05:41:57 beandog Exp $
+
+inherit eutils fixheadtails autotools
+
+MY_PN="${PN}core"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="XviD, a high performance/quality MPEG-4 video de-/encoding solution"
+HOMEPAGE="http://www.xvid.org"
+SRC_URI="http://downloads.xvid.org/downloads/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="examples altivec"
+
+# once yasm-0.6.0+ comes out, we can switch this to
+# dev-lang/nasm >=dev-lang/yasm-0.6.0
+# and then drop the quotes from section in the noexec-stack.patch
+
+# yasm < 0.6.2 has a bug when computing pic adresses.
+# See http://www.tortall.net/projects/yasm/ticket/114
+# the build system prefers yasm if it finds it
+# thus if we intend to have || (yasm nasm) for building
+# we need to make it block yasm < 0.6.2 on x86
+# otherwise it will compile wrong code
+NASM=">=dev-lang/yasm-0.6.2"
+DEPEND="x86? ( ${NASM} )
+ amd64? ( ${NASM} )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_PN}/build/generic"
+
+src_compile() {
+ econf $(use_enable altivec)
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+
+ dodoc "${S}"/../../{AUTHORS,ChangeLog*,README,TODO}
+
+ if [[ ${CHOST} == *-darwin* ]]; then
+ local mylib=$(basename $(ls "${D}"/usr/$(get_libdir)/libxvidcore.*.dylib))
+ dosym ${mylib} /usr/$(get_libdir)/libxvidcore.dylib
+ else
+ local mylib=$(basename $(ls "${D}"/usr/$(get_libdir)/libxvidcore.so*))
+ dosym ${mylib} /usr/$(get_libdir)/libxvidcore.so
+ dosym ${mylib} /usr/$(get_libdir)/${mylib/.1}
+ fi
+
+ if use examples; then
+ dodoc "${S}"/../../CodingStyle
+ insinto /usr/share/${PN}
+ doins -r "${S}"/../../examples
+ fi
+}