summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-06-10 14:08:36 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-06-10 14:08:36 +0000
commitf4f5f8ee94092f0b6be8d3a29d743962d5fa9172 (patch)
tree2be2972f826ec34009a9600c2b85f80206c4b57b /media-libs/xine-lib
parentRevision bump. Bring back --pid functionality from 3.x, more proper than usin... (diff)
downloadgentoo-2-f4f5f8ee94092f0b6be8d3a29d743962d5fa9172.tar.gz
gentoo-2-f4f5f8ee94092f0b6be8d3a29d743962d5fa9172.tar.bz2
gentoo-2-f4f5f8ee94092f0b6be8d3a29d743962d5fa9172.zip
Version bump.
(Portage version: 2.2.0_alpha179/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'media-libs/xine-lib')
-rw-r--r--media-libs/xine-lib/ChangeLog8
-rw-r--r--media-libs/xine-lib/files/accel_vaapi.h135
-rw-r--r--media-libs/xine-lib/metadata.xml3
-rw-r--r--media-libs/xine-lib/xine-lib-1.2.3.ebuild214
-rw-r--r--media-libs/xine-lib/xine-lib-1.2.9999.ebuild10
5 files changed, 366 insertions, 4 deletions
diff --git a/media-libs/xine-lib/ChangeLog b/media-libs/xine-lib/ChangeLog
index 8ccee180e9ce..3d6fef9f2b53 100644
--- a/media-libs/xine-lib/ChangeLog
+++ b/media-libs/xine-lib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/xine-lib
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/ChangeLog,v 1.692 2013/05/16 18:41:45 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/ChangeLog,v 1.693 2013/06/10 14:08:36 ssuominen Exp $
+
+*xine-lib-1.2.3 (10 Jun 2013)
+
+ 10 Jun 2013; Samuli Suominen <ssuominen@gentoo.org> +xine-lib-1.2.3.ebuild,
+ xine-lib-1.2.9999.ebuild, +files/accel_vaapi.h, metadata.xml:
+ Version bump wrt #471846 by "teidakankan"
16 May 2013; Ulrich Müller <ulm@gentoo.org> xine-lib-1.2.1-r1.ebuild,
xine-lib-1.2.2.ebuild, xine-lib-1.2.9999.ebuild, metadata.xml:
diff --git a/media-libs/xine-lib/files/accel_vaapi.h b/media-libs/xine-lib/files/accel_vaapi.h
new file mode 100644
index 000000000000..666b23fd6033
--- /dev/null
+++ b/media-libs/xine-lib/files/accel_vaapi.h
@@ -0,0 +1,135 @@
+/*
+ * Copyright (C) 2008 the xine project
+ *
+ * This file is part of xine, a free video player.
+ *
+ * xine is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation; either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * xine is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program; if not, write to the Free Software
+ * Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110, USA
+ *
+ *
+ * Common acceleration definitions for vdpau
+ *
+ *
+ */
+
+#ifndef HAVE_XINE_ACCEL_VAAPI_H
+#define HAVE_XINE_ACCEL_VAAPI_H
+
+#ifdef __cplusplus
+extern "C" {
+#endif
+
+#ifdef HAVE_CONFIG_H
+#include "config.h"
+#endif
+
+#include <va/va_x11.h>
+#include <pthread.h>
+#ifdef HAVE_FFMPEG_AVUTIL_H
+# include <avcodec.h>
+#else
+# include <libavcodec/avcodec.h>
+#endif
+
+#if LIBAVCODEC_VERSION_MAJOR >= 53 || (LIBAVCODEC_VERSION_MAJOR == 52 && LIBAVCODEC_VERSION_MINOR >= 32)
+# define AVVIDEO 2
+#else
+# define AVVIDEO 1
+# define pp_context pp_context_t
+# define pp_mode pp_mode_t
+#endif
+
+#define NUM_OUTPUT_SURFACES 22
+
+#define SURFACE_FREE 0
+#define SURFACE_ALOC 1
+#define SURFACE_RELEASE 2
+#define SURFACE_RENDER 3
+#define SURFACE_RENDER_RELEASE 5
+
+struct vaapi_equalizer {
+ VADisplayAttribute brightness;
+ VADisplayAttribute contrast;
+ VADisplayAttribute hue;
+ VADisplayAttribute saturation;
+};
+
+typedef struct ff_vaapi_context_s ff_vaapi_context_t;
+
+struct ff_vaapi_context_s {
+ VADisplay va_display;
+ VAContextID va_context_id;
+ VAConfigID va_config_id;
+ int width;
+ int height;
+ int sw_width;
+ int sw_height;
+ int va_profile;
+ unsigned int va_colorspace;
+ VAImage va_subpic_image;
+ VASubpictureID va_subpic_id;
+ int va_subpic_width;
+ int va_subpic_height;
+ int is_bound;
+ void *gl_surface;
+ unsigned int soft_head;
+ unsigned int valid_context;
+ unsigned int va_head;
+ unsigned int va_soft_head;
+ vo_driver_t *driver;
+ unsigned int last_sub_image_fmt;
+ VASurfaceID last_sub_surface_id;
+ struct vaapi_equalizer va_equalizer;
+ VAImageFormat *va_image_formats;
+ int va_num_image_formats;
+ VAImageFormat *va_subpic_formats;
+ int va_num_subpic_formats;
+};
+
+typedef struct ff_vaapi_surface_s ff_vaapi_surface_t;
+typedef struct vaapi_accel_s vaapi_accel_t;
+
+struct ff_vaapi_surface_s {
+ unsigned int index;
+ vaapi_accel_t *accel;
+ VASurfaceID va_surface_id;
+ unsigned int status;
+};
+
+struct vaapi_accel_s {
+ unsigned int index;
+ vo_frame_t *vo_frame;
+
+#if AVVIDEO > 1
+ int (*avcodec_decode_video2)(vo_frame_t *frame_gen, AVCodecContext *avctx, AVFrame *picture,
+ int *got_picture_ptr, AVPacket *avpkt);
+#else
+ int (*avcodec_decode_video)(vo_frame_t *frame_gen, AVCodecContext *avctx, AVFrame *picture,
+ int *got_picture_ptr, uint8_t *buf, int buf_size);
+#endif
+ VAStatus (*vaapi_init)(vo_frame_t *frame_gen, int va_profile, int width, int height, int softrender);
+ int (*profile_from_imgfmt)(vo_frame_t *frame_gen, enum PixelFormat pix_fmt, int codec_id, int vaapi_mpeg_sofdec);
+ ff_vaapi_context_t *(*get_context)(vo_frame_t *frame_gen);
+ int (*guarded_render)(vo_frame_t *frame_gen);
+ ff_vaapi_surface_t *(*get_vaapi_surface)(vo_frame_t *frame_gen);
+ void (*render_vaapi_surface)(vo_frame_t *frame_gen, ff_vaapi_surface_t *va_surface);
+ void (*release_vaapi_surface)(vo_frame_t *frame_gen, ff_vaapi_surface_t *va_surface);
+};
+
+#ifdef __cplusplus
+}
+#endif
+
+#endif
+
diff --git a/media-libs/xine-lib/metadata.xml b/media-libs/xine-lib/metadata.xml
index 6c2ee8ac9e34..9ec7ad94167f 100644
--- a/media-libs/xine-lib/metadata.xml
+++ b/media-libs/xine-lib/metadata.xml
@@ -48,6 +48,9 @@
is still experimental, and might not be as good looking as the bitmap fonts
used with this USE flag disabled.
</flag>
+ <flag name="vaapi">
+ Enables VAAPI (Video Acceleration API) for hardware decoding
+ </flag>
<flag name="vdr">
Build the VDR plugin
</flag>
diff --git a/media-libs/xine-lib/xine-lib-1.2.3.ebuild b/media-libs/xine-lib/xine-lib-1.2.3.ebuild
new file mode 100644
index 000000000000..82d3f3e69f3b
--- /dev/null
+++ b/media-libs/xine-lib/xine-lib-1.2.3.ebuild
@@ -0,0 +1,214 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1.2.3.ebuild,v 1.1 2013/06/10 14:08:36 ssuominen Exp $
+
+EAPI=5
+
+inherit flag-o-matic libtool multilib
+
+if [[ ${PV} == *9999* ]]; then
+ EHG_REPO_URI="http://hg.debian.org/hg/xine-lib/xine-lib-1.2"
+ inherit autotools mercurial eutils
+ unset NLS_IUSE
+ NLS_DEPEND="sys-devel/gettext"
+ NLS_RDEPEND="virtual/libintl"
+else
+ KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd"
+ SRC_URI="mirror://sourceforge/xine/${P}.tar.xz"
+ NLS_IUSE="nls"
+ NLS_DEPEND="nls? ( sys-devel/gettext )"
+ NLS_RDEPEND="nls? ( virtual/libintl )"
+fi
+
+DESCRIPTION="Core libraries for Xine movie player"
+HOMEPAGE="http://xine.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="1"
+IUSE="a52 aac aalib +alsa altivec bluray +css directfb dts dvb dxr3 fbcon flac fusion gtk imagemagick ipv6 jack jpeg libcaca mad +mmap mng modplug musepack opengl oss pulseaudio samba sdl speex theora truetype v4l vaapi vcd vdpau vdr vidix +vis vorbis wavpack +X +xcb xinerama +xv xvmc ${NLS_IUSE}"
+
+RDEPEND="${NLS_RDEPEND}
+ dev-libs/libxdg-basedir
+ media-libs/libdvdnav
+ sys-libs/zlib
+ || ( media-video/ffmpeg media-libs/libpostproc <media-video/libav-0.8.2-r1 )
+ virtual/ffmpeg
+ virtual/libiconv
+ a52? ( media-libs/a52dec )
+ aac? ( media-libs/faad2 )
+ aalib? ( media-libs/aalib )
+ alsa? ( media-libs/alsa-lib )
+ bluray? ( >=media-libs/libbluray-0.2.1 )
+ css? ( >=media-libs/libdvdcss-1.2.10 )
+ directfb? ( dev-libs/DirectFB )
+ dts? ( media-libs/libdca )
+ dxr3? ( media-libs/libfame )
+ flac? ( media-libs/flac )
+ fusion? ( media-libs/FusionSound )
+ gtk? ( x11-libs/gdk-pixbuf:2 )
+ imagemagick? ( || ( media-gfx/imagemagick media-gfx/graphicsmagick ) )
+ jack? ( >=media-sound/jack-audio-connection-kit-0.100 )
+ jpeg? ( virtual/jpeg )
+ libcaca? ( media-libs/libcaca )
+ mad? ( media-libs/libmad )
+ mng? ( media-libs/libmng )
+ modplug? ( >=media-libs/libmodplug-0.8.8.1 )
+ musepack? ( >=media-sound/musepack-tools-444 )
+ opengl? (
+ virtual/glu
+ virtual/opengl
+ )
+ pulseaudio? ( media-sound/pulseaudio )
+ samba? ( net-fs/samba )
+ sdl? ( media-libs/libsdl )
+ speex? (
+ media-libs/libogg
+ media-libs/speex
+ )
+ theora? (
+ media-libs/libogg
+ media-libs/libtheora
+ )
+ truetype? (
+ media-libs/fontconfig
+ media-libs/freetype:2
+ )
+ v4l? ( media-libs/libv4l )
+ vaapi? ( x11-libs/libva )
+ vcd? (
+ >=media-video/vcdimager-0.7.23
+ dev-libs/libcdio[-minimal]
+ )
+ vdpau? ( x11-libs/libvdpau )
+ vorbis? (
+ media-libs/libogg
+ media-libs/libvorbis
+ )
+ wavpack? ( media-sound/wavpack )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXext
+ )
+ xcb? ( x11-libs/libxcb )
+ xinerama? ( x11-libs/libXinerama )
+ xv? ( x11-libs/libXv )
+ xvmc? ( x11-libs/libXvMC )"
+DEPEND="${RDEPEND}
+ ${NLS_DEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig
+ >=sys-devel/libtool-2.2.6b
+ oss? ( virtual/os-headers )
+ v4l? ( virtual/os-headers )
+ X? (
+ x11-libs/libXt
+ x11-proto/xf86vidmodeproto
+ x11-proto/xproto
+ )
+ xv? ( x11-proto/videoproto )
+ xvmc? ( x11-proto/videoproto )
+ xinerama? ( x11-proto/xineramaproto )"
+REQUIRED_USE="vidix? ( || ( X fbcon ) )
+ xv? ( X )
+ xinerama? ( X )"
+
+src_prepare() {
+ cp "${FILESDIR}"/accel_vaapi.h src/xine-engine/
+
+ sed -i -e '/define VDR_ABS_FIFO_DIR/s|".*"|"/var/vdr/xine"|' src/vdr/input_vdr.c || die
+
+ if [[ ${PV} == *9999* ]]; then
+ epatch_user
+ eautoreconf
+ else
+ elibtoolize
+ fi
+}
+
+src_configure() {
+ [[ ${CHOST} == i?86-* ]] && append-flags -fomit-frame-pointer #422519
+
+ local win32dir #197236
+ if has_multilib_profile; then
+ win32dir=/usr/$(ABI="x86" get_libdir)/win32
+ else
+ win32dir=/usr/$(get_libdir)/win32
+ fi
+
+ local myconf
+ [[ ${PV} == *9999* ]] || myconf="$(use_enable nls)"
+
+ econf \
+ $(use_enable ipv6) \
+ $(use_enable altivec) \
+ $(use_enable vis) \
+ --disable-optimizations \
+ $(use_enable mmap) \
+ $(use_enable oss) \
+ $(use_enable aalib) \
+ $(use_enable directfb) \
+ $(use_enable dxr3) \
+ $(use_enable fbcon fb) \
+ $(use_enable opengl) $(use_enable opengl glu) \
+ $(use_enable vidix) \
+ $(use_enable xinerama) \
+ $(use_enable xvmc) \
+ $(use_enable vdpau) \
+ $(use_enable vaapi) \
+ $(use_enable dvb) \
+ --disable-gnomevfs \
+ $(use_enable samba) \
+ --disable-v4l $(use_enable v4l v4l2) $(use_enable v4l libv4l) \
+ $(use_enable vcd) \
+ $(use_enable vdr) \
+ $(use_enable bluray) \
+ $(use_enable a52 a52dec) \
+ $(use_enable aac faad) \
+ $(use_enable gtk gdkpixbuf) \
+ $(use_enable jpeg libjpeg) \
+ $(use_enable dts) \
+ $(use_enable mad) \
+ $(use_enable modplug) \
+ $(use_enable musepack) \
+ $(use_enable mng) \
+ --disable-real-codecs \
+ --disable-w32dll \
+ $(use_with truetype freetype) $(use_with truetype fontconfig) \
+ $(use_with X x) \
+ $(use_with alsa) \
+ --without-esound \
+ $(use_with fusion fusionsound) \
+ $(use_with jack) \
+ $(use_with pulseaudio) \
+ $(use_with libcaca caca) \
+ $(use_with sdl) \
+ $(use_with xcb) \
+ --with-xv-path=/usr/$(get_libdir) \
+ $(use_with imagemagick) \
+ --with-external-dvdnav \
+ $(use_with flac libflac) \
+ $(use_with speex) \
+ $(use_with theora) \
+ $(use_with vorbis) \
+ --with-real-codecs-path=/usr/$(get_libdir)/codecs \
+ --with-w32-path=${win32dir} \
+ $(use_with wavpack) \
+ ${myconf}
+}
+
+src_compile() {
+ # enable verbose building, bug #448140
+ emake V=1
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ docdir="/usr/share/doc/${PF}" \
+ htmldir="/usr/share/doc/${PF}/html" \
+ install
+
+ rm -f \
+ "${ED}"usr/lib*/libxine*.la \
+ "${ED}"usr/share/doc/${PF}/COPYING
+}
diff --git a/media-libs/xine-lib/xine-lib-1.2.9999.ebuild b/media-libs/xine-lib/xine-lib-1.2.9999.ebuild
index 4f0562e2dddd..a5833e5a44eb 100644
--- a/media-libs/xine-lib/xine-lib-1.2.9999.ebuild
+++ b/media-libs/xine-lib/xine-lib-1.2.9999.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1.2.9999.ebuild,v 1.21 2013/05/16 18:41:45 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1.2.9999.ebuild,v 1.22 2013/06/10 14:08:36 ssuominen Exp $
-EAPI=4
+EAPI=5
inherit flag-o-matic libtool multilib
@@ -25,7 +25,7 @@ HOMEPAGE="http://xine.sourceforge.net/"
LICENSE="GPL-2"
SLOT="1"
-IUSE="a52 aac aalib +alsa altivec bluray +css directfb dts dvb dxr3 fbcon flac fusion gtk imagemagick ipv6 jack libcaca mad +mmap mng modplug musepack opengl oss pulseaudio samba sdl speex theora truetype v4l vcd vdpau vdr vidix +vis vorbis wavpack +X +xcb xinerama +xv xvmc ${NLS_IUSE}"
+IUSE="a52 aac aalib +alsa altivec bluray +css directfb dts dvb dxr3 fbcon flac fusion gtk imagemagick ipv6 jack jpeg libcaca mad +mmap mng modplug musepack opengl oss pulseaudio samba sdl speex theora truetype v4l vaapi vcd vdpau vdr vidix +vis vorbis wavpack +X +xcb xinerama +xv xvmc ${NLS_IUSE}"
RDEPEND="${NLS_RDEPEND}
dev-libs/libxdg-basedir
@@ -48,6 +48,7 @@ RDEPEND="${NLS_RDEPEND}
gtk? ( x11-libs/gdk-pixbuf:2 )
imagemagick? ( || ( media-gfx/imagemagick media-gfx/graphicsmagick ) )
jack? ( >=media-sound/jack-audio-connection-kit-0.100 )
+ jpeg? ( virtual/jpeg )
libcaca? ( media-libs/libcaca )
mad? ( media-libs/libmad )
mng? ( media-libs/libmng )
@@ -73,6 +74,7 @@ RDEPEND="${NLS_RDEPEND}
media-libs/freetype:2
)
v4l? ( media-libs/libv4l )
+ vaapi? ( x11-libs/libva )
vcd? (
>=media-video/vcdimager-0.7.23
dev-libs/libcdio[-minimal]
@@ -150,6 +152,7 @@ src_configure() {
$(use_enable xinerama) \
$(use_enable xvmc) \
$(use_enable vdpau) \
+ $(use_enable vaapi) \
$(use_enable dvb) \
--disable-gnomevfs \
$(use_enable samba) \
@@ -160,6 +163,7 @@ src_configure() {
$(use_enable a52 a52dec) \
$(use_enable aac faad) \
$(use_enable gtk gdkpixbuf) \
+ $(use_enable jpeg libjpeg) \
$(use_enable dts) \
$(use_enable mad) \
$(use_enable modplug) \