summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2008-04-07 21:43:24 +0000
committerBen de Groot <yngwin@gentoo.org>2008-04-07 21:43:24 +0000
commitcb048257e4a5670a14924e7a81bee9de64dbf075 (patch)
tree9ef894fd07ef3f21b52352e4cbdd0f27929005fb /media-libs/x264/x264-0.0.20070924.ebuild
parentbump to 2.4.1, bugs and regression test fixes. (diff)
downloadgentoo-2-cb048257e4a5670a14924e7a81bee9de64dbf075.tar.gz
gentoo-2-cb048257e4a5670a14924e7a81bee9de64dbf075.tar.bz2
gentoo-2-cb048257e4a5670a14924e7a81bee9de64dbf075.zip
Pkgmove from x264-svn to x264, and adding fresh snapshot
(Portage version: 2.1.5_rc2, RepoMan options: --force)
Diffstat (limited to 'media-libs/x264/x264-0.0.20070924.ebuild')
-rw-r--r--media-libs/x264/x264-0.0.20070924.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/media-libs/x264/x264-0.0.20070924.ebuild b/media-libs/x264/x264-0.0.20070924.ebuild
new file mode 100644
index 000000000000..de9b5d50ca8a
--- /dev/null
+++ b/media-libs/x264/x264-0.0.20070924.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/x264-0.0.20070924.ebuild,v 1.1 2008/04/07 21:43:23 yngwin Exp $
+
+inherit multilib eutils toolchain-funcs versionator
+
+X264_SVN_P="x264-svn-$(get_version_component_range 3)"
+
+DESCRIPTION="A free library for encoding X264/AVC streams"
+HOMEPAGE="http://www.videolan.org/developers/x264.html"
+SRC_URI="mirror://gentoo/${X264_SVN_P}.tar.bz2"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="alpha amd64 ~mips ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE="debug threads"
+
+RDEPEND=""
+DEPEND="amd64? ( >=dev-lang/yasm-0.6.0 )
+ x86? ( || ( >=dev-lang/yasm-0.6.2 dev-lang/nasm ) )
+ x86-fbsd? ( dev-lang/nasm )"
+
+# Block older than 0.6.2 versions of yasm
+# It generates incorect pic code and will cause segfaults
+# See http://www.tortall.net/projects/yasm/ticket/114
+DEPEND="${DEPEND}
+ x86? ( !<dev-lang/yasm-0.6.2 )"
+
+S="${WORKDIR}/${PN}-svn"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-nostrip.patch"
+ epatch "${FILESDIR}/${PN}-onlylib.patch"
+}
+
+src_compile() {
+ local myconf=""
+ use debug && myconf="${myconf} --enable-debug"
+ ./configure --prefix=/usr \
+ --libdir=/usr/$(get_libdir) \
+ --enable-pic --enable-shared \
+ "--extra-cflags=${CFLAGS}" \
+ "--extra-ldflags=${LDFLAGS}" \
+ "--extra-asflags=${ASFLAGS}" \
+ $(use_enable threads pthread) \
+ ${myconf} \
+ --disable-mp4-output \
+ || die "configure failed"
+ emake CC="$(tc-getCC)" || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS
+}
+
+pkg_postinst() {
+ elog "Please note that this package now only installs"
+ elog "${PN} libraries. In order to have the encoder,"
+ elog "please emerge media-video/x264-svn-encoder"
+}