summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2009-01-18 01:57:48 +0000
committerRyan Hill <dirtyepic@gentoo.org>2009-01-18 01:57:48 +0000
commitcaa1c5ca5c2f8f9e7498cbe4be968309834bfea1 (patch)
treeba60a29ca3f2a15493bd77ffcc8a49b500f6a3d9 /media-libs/wxsvg
parenthppa stable, #255219 (diff)
downloadgentoo-2-caa1c5ca5c2f8f9e7498cbe4be968309834bfea1.tar.gz
gentoo-2-caa1c5ca5c2f8f9e7498cbe4be968309834bfea1.tar.bz2
gentoo-2-caa1c5ca5c2f8f9e7498cbe4be968309834bfea1.zip
Version bump for dragonheart in bug #215665.
(Portage version: 2.2_rc22/cvs/Linux 2.6.28-gentoo x86_64)
Diffstat (limited to 'media-libs/wxsvg')
-rw-r--r--media-libs/wxsvg/ChangeLog9
-rw-r--r--media-libs/wxsvg/wxsvg-1.0.ebuild46
2 files changed, 53 insertions, 2 deletions
diff --git a/media-libs/wxsvg/ChangeLog b/media-libs/wxsvg/ChangeLog
index 0af49357a3ad..c4acac1df728 100644
--- a/media-libs/wxsvg/ChangeLog
+++ b/media-libs/wxsvg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/wxsvg
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/wxsvg/ChangeLog,v 1.8 2008/05/19 07:04:35 drac Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/wxsvg/ChangeLog,v 1.9 2009/01/18 01:57:48 dirtyepic Exp $
+
+*wxsvg-1.0 (18 Jan 2009)
+
+ 18 Jan 2009; Ryan Hill <dirtyepic@gentoo.org> +wxsvg-1.0.ebuild:
+ Version bump for dragonheart in bug #215665.
19 May 2008; Samuli Suominen <drac@gentoo.org> wxsvg-1.0_beta7.ebuild:
Move pkgconfig to DEPEND.
diff --git a/media-libs/wxsvg/wxsvg-1.0.ebuild b/media-libs/wxsvg/wxsvg-1.0.ebuild
new file mode 100644
index 000000000000..e5245d567269
--- /dev/null
+++ b/media-libs/wxsvg/wxsvg-1.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/wxsvg/wxsvg-1.0.ebuild,v 1.1 2009/01/18 01:57:48 dirtyepic Exp $
+
+WX_GTK_VER="2.8"
+
+inherit autotools wxwidgets
+
+DESCRIPTION="C++ library to create, manipulate and render SVG files."
+HOMEPAGE="http://wxsvg.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="wxWinLL-3"
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+IUSE="ffmpeg"
+
+RDEPEND="=x11-libs/wxGTK-2.8*
+ >=dev-libs/glib-2.12
+ >=dev-libs/libxml2-2.6.26
+ >=media-libs/fontconfig-2.4
+ >=media-libs/freetype-2.2.0
+ >=media-libs/libart_lgpl-2.3.17
+ >=x11-libs/pango-1.14.9
+ ffmpeg? ( >=media-video/ffmpeg-0.4.9_p20080326 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+# epatch "${FILESDIR}"/${P}-new-ffmpeg-headers.patch
+
+ AT_M4DIR="${S}" eautoreconf
+}
+
+src_compile() {
+ econf --with-wx-config="${WXCONFIG}" || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog TODO
+}