summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2007-04-23 03:27:28 +0000
committerRyan Hill <dirtyepic@gentoo.org>2007-04-23 03:27:28 +0000
commit5cbfbab198db86d5555468f4eec835a22787f7f9 (patch)
treeb5ad9542944be56b53e6c4ebf254e034a732b656 /media-libs/wxsvg
parentSome more tweaks but still not 100% (diff)
downloadgentoo-2-5cbfbab198db86d5555468f4eec835a22787f7f9.tar.gz
gentoo-2-5cbfbab198db86d5555468f4eec835a22787f7f9.tar.bz2
gentoo-2-5cbfbab198db86d5555468f4eec835a22787f7f9.zip
Add patch to allow building with later freetype versions. Bug #175640.
(Portage version: 2.1.2.4)
Diffstat (limited to 'media-libs/wxsvg')
-rw-r--r--media-libs/wxsvg/ChangeLog6
-rw-r--r--media-libs/wxsvg/files/wxsvg-1.0_beta7-freetype.patch41
-rw-r--r--media-libs/wxsvg/wxsvg-1.0_beta7.ebuild9
3 files changed, 54 insertions, 2 deletions
diff --git a/media-libs/wxsvg/ChangeLog b/media-libs/wxsvg/ChangeLog
index b9a98cf2d150..50c9c38a24b3 100644
--- a/media-libs/wxsvg/ChangeLog
+++ b/media-libs/wxsvg/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/wxsvg
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/wxsvg/ChangeLog,v 1.1 2007/01/28 20:02:38 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/wxsvg/ChangeLog,v 1.2 2007/04/23 03:27:28 dirtyepic Exp $
+
+ 23 Apr 2007; Ryan Hill <dirtyepic@gentoo.org>
+ +files/wxsvg-1.0_beta7-freetype.patch, wxsvg-1.0_beta7.ebuild:
+ Add patch to allow building with later freetype versions. Bug #175640.
*wxsvg-1.0_beta7 (28 Jan 2007)
diff --git a/media-libs/wxsvg/files/wxsvg-1.0_beta7-freetype.patch b/media-libs/wxsvg/files/wxsvg-1.0_beta7-freetype.patch
new file mode 100644
index 000000000000..cfc7acddb499
--- /dev/null
+++ b/media-libs/wxsvg/files/wxsvg-1.0_beta7-freetype.patch
@@ -0,0 +1,41 @@
+diff -Naur wxsvg-1.0b7-orig/src/freetype/SVGCanvasTextFreetype.cpp wxsvg-1.0b7/src/freetype/SVGCanvasTextFreetype.cpp
+--- wxsvg-1.0b7-orig/src/freetype/SVGCanvasTextFreetype.cpp 2007-04-22 21:08:31.000000000 -0600
++++ wxsvg-1.0b7/src/freetype/SVGCanvasTextFreetype.cpp 2007-04-22 21:14:32.000000000 -0600
+@@ -163,7 +163,7 @@
+ }
+ }
+
+-static gint moveto(FT_Vector* to, gpointer data)
++static gint moveto(const FT_Vector* to, gpointer data)
+ {
+ wxSVGCanvasTextFreetype* canvasText = (wxSVGCanvasTextFreetype*) data;
+
+@@ -179,7 +179,7 @@
+ return 0;
+ }
+
+-static gint lineto (FT_Vector* to, gpointer data)
++static gint lineto (const FT_Vector* to, gpointer data)
+ {
+ wxSVGCanvasTextFreetype* canvasText = (wxSVGCanvasTextFreetype*) data;
+ if (!canvasText->m_endpath)
+@@ -192,7 +192,7 @@
+ return 0;
+ }
+
+-static gint conicto(FT_Vector* ftcontrol, FT_Vector* to, gpointer data)
++static gint conicto(const FT_Vector* ftcontrol, const FT_Vector* to, gpointer data)
+ {
+ wxSVGCanvasTextFreetype* canvasText = (wxSVGCanvasTextFreetype*) data;
+ if (!canvasText->m_endpath)
+@@ -207,8 +207,8 @@
+ return 0;
+ }
+
+-static gint cubicto(FT_Vector* ftcontrol1, FT_Vector* ftcontrol2,
+- FT_Vector* to, gpointer data)
++static gint cubicto(const FT_Vector* ftcontrol1, const FT_Vector* ftcontrol2,
++ const FT_Vector* to, gpointer data)
+ {
+ wxSVGCanvasTextFreetype* canvasText = (wxSVGCanvasTextFreetype*) data;
+ if (!canvasText->m_endpath)
diff --git a/media-libs/wxsvg/wxsvg-1.0_beta7.ebuild b/media-libs/wxsvg/wxsvg-1.0_beta7.ebuild
index 9dcbe3c0b93d..44f5a43f0f49 100644
--- a/media-libs/wxsvg/wxsvg-1.0_beta7.ebuild
+++ b/media-libs/wxsvg/wxsvg-1.0_beta7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/wxsvg/wxsvg-1.0_beta7.ebuild,v 1.1 2007/01/28 20:02:38 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/wxsvg/wxsvg-1.0_beta7.ebuild,v 1.2 2007/04/23 03:27:28 dirtyepic Exp $
inherit eutils wxwidgets
@@ -26,6 +26,13 @@ DEPEND="=x11-libs/wxGTK-2.6*
S=${WORKDIR}/${PN}-${MY_PV}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-freetype.patch
+}
+
src_compile() {
export WX_GTK_VER="2.6"
need-wxwidgets gtk2