summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-02-20 21:18:44 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-02-20 21:18:44 +0000
commit8fc5d42eadb434a9689d4531c19006b4006a08c7 (patch)
treec5be17397d7d11c494b26de61cae6db9fbdebe15 /media-libs/vo-amrwbenc
parentversion bump and propagate ~arch keywords to live-template-ebuild (diff)
downloadgentoo-2-8fc5d42eadb434a9689d4531c19006b4006a08c7.tar.gz
gentoo-2-8fc5d42eadb434a9689d4531c19006b4006a08c7.tar.bz2
gentoo-2-8fc5d42eadb434a9689d4531c19006b4006a08c7.zip
version bump and make 9999 ekeyword friendly too
(Portage version: 2.2.0_alpha88/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/vo-amrwbenc')
-rw-r--r--media-libs/vo-amrwbenc/ChangeLog10
-rw-r--r--media-libs/vo-amrwbenc/vo-amrwbenc-0.1.2.ebuild47
-rw-r--r--media-libs/vo-amrwbenc/vo-amrwbenc-9999.ebuild7
3 files changed, 59 insertions, 5 deletions
diff --git a/media-libs/vo-amrwbenc/ChangeLog b/media-libs/vo-amrwbenc/ChangeLog
index ad4191c10bd0..f6b94f507ef5 100644
--- a/media-libs/vo-amrwbenc/ChangeLog
+++ b/media-libs/vo-amrwbenc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/vo-amrwbenc
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/vo-amrwbenc/ChangeLog,v 1.15 2011/08/10 15:13:57 xarthisius Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/vo-amrwbenc/ChangeLog,v 1.16 2012/02/20 21:18:44 aballier Exp $
+
+*vo-amrwbenc-0.1.2 (20 Feb 2012)
+
+ 20 Feb 2012; Alexis Ballier <aballier@gentoo.org> +vo-amrwbenc-0.1.2.ebuild,
+ vo-amrwbenc-9999.ebuild:
+ version bump and make 9999 ekeyword friendly too
10 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org> vo-amrwbenc-0.1.1.ebuild:
ppc64/ppc stable to lift mask from bug 365273
diff --git a/media-libs/vo-amrwbenc/vo-amrwbenc-0.1.2.ebuild b/media-libs/vo-amrwbenc/vo-amrwbenc-0.1.2.ebuild
new file mode 100644
index 000000000000..72b65574d37e
--- /dev/null
+++ b/media-libs/vo-amrwbenc/vo-amrwbenc-0.1.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/vo-amrwbenc/vo-amrwbenc-0.1.2.ebuild,v 1.1 2012/02/20 21:18:44 aballier Exp $
+
+EAPI=4
+
+if [[ ${PV} == *9999 ]] ; then
+ SCM="git-2"
+ EGIT_REPO_URI="git://github.com/mstorsjo/${PN}.git"
+ [[ ${PV%9999} != "" ]] && EGIT_BRANCH="release/${PV%.9999}"
+fi
+
+inherit eutils multilib autotools ${SCM}
+
+DESCRIPTION="VisualOn AMR-WB encoder library"
+HOMEPAGE="http://sourceforge.net/projects/opencore-amr/"
+
+if [[ ${PV} == *9999 ]] ; then
+ SRC_URI=""
+elif [[ ${PV%_p*} != ${PV} ]] ; then # Gentoo snapshot
+ SRC_URI="mirror://gentoo/${P}.tar.xz"
+else # Official release
+ SRC_URI="mirror://sourceforge/opencore-amr/${P}.tar.gz"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+[[ ${PV} == *9999 ]] || \
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x64-macos"
+IUSE="examples static-libs"
+
+src_prepare() {
+ [[ ${PV} == *9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable examples example) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ find "${D}"usr/$(get_libdir) -name '*.la' -delete
+}
diff --git a/media-libs/vo-amrwbenc/vo-amrwbenc-9999.ebuild b/media-libs/vo-amrwbenc/vo-amrwbenc-9999.ebuild
index 4a7616c26a99..4b2bd6c2ebce 100644
--- a/media-libs/vo-amrwbenc/vo-amrwbenc-9999.ebuild
+++ b/media-libs/vo-amrwbenc/vo-amrwbenc-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/vo-amrwbenc/vo-amrwbenc-9999.ebuild,v 1.3 2011/05/24 12:49:54 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/vo-amrwbenc/vo-amrwbenc-9999.ebuild,v 1.4 2012/02/20 21:18:44 aballier Exp $
EAPI=4
@@ -26,7 +26,8 @@ fi
LICENSE="Apache-2.0"
SLOT="0"
-[[ ${PV} == *9999 ]] || KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~sparc ~x86 ~x86-fbsd ~x64-macos"
+[[ ${PV} == *9999 ]] || \
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x64-macos"
IUSE="examples static-libs"
src_prepare() {