summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-02-23 10:02:17 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-02-23 10:02:17 +0000
commit3693f74986739d8f9508bb172853f8f768a54e6e (patch)
tree0d2f18094f253385b150db07c6dd330e7bcfa825 /media-libs/tremor
parentStable for sparc, wrt bug #458188 (diff)
downloadgentoo-2-3693f74986739d8f9508bb172853f8f768a54e6e.tar.gz
gentoo-2-3693f74986739d8f9508bb172853f8f768a54e6e.tar.bz2
gentoo-2-3693f74986739d8f9508bb172853f8f768a54e6e.zip
New snapshot; new USE flag "low-accuracy" to enable 32bit only multiply operations
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'media-libs/tremor')
-rw-r--r--media-libs/tremor/ChangeLog9
-rw-r--r--media-libs/tremor/metadata.xml5
-rw-r--r--media-libs/tremor/tremor-0_pre20130223.ebuild41
3 files changed, 53 insertions, 2 deletions
diff --git a/media-libs/tremor/ChangeLog b/media-libs/tremor/ChangeLog
index 47d8b40cc281..52318d4113df 100644
--- a/media-libs/tremor/ChangeLog
+++ b/media-libs/tremor/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/tremor
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/tremor/ChangeLog,v 1.12 2013/02/23 09:41:36 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/tremor/ChangeLog,v 1.13 2013/02/23 10:02:17 ssuominen Exp $
+
+*tremor-0_pre20130223 (23 Feb 2013)
+
+ 23 Feb 2013; Samuli Suominen <ssuominen@gentoo.org>
+ +tremor-0_pre20130223.ebuild, metadata.xml:
+ New snapshot; new USE flag "low-accuracy" to enable 32bit only multiply
+ operations
23 Feb 2013; Agostino Sarubbo <ago@gentoo.org> tremor-0_pre20120120.ebuild:
Stable for sparc, wrt bug #458188
diff --git a/media-libs/tremor/metadata.xml b/media-libs/tremor/metadata.xml
index e1774e3d9ad7..39ff19909ce8 100644
--- a/media-libs/tremor/metadata.xml
+++ b/media-libs/tremor/metadata.xml
@@ -1,5 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sound</herd>
+ <herd>sound</herd>
+ <use>
+ <flag name='low-accuracy'>enable 32bit only multiply operations</flag>
+ </use>
</pkgmetadata>
diff --git a/media-libs/tremor/tremor-0_pre20130223.ebuild b/media-libs/tremor/tremor-0_pre20130223.ebuild
new file mode 100644
index 000000000000..1ece19f82132
--- /dev/null
+++ b/media-libs/tremor/tremor-0_pre20130223.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/tremor/tremor-0_pre20130223.ebuild,v 1.1 2013/02/23 10:02:17 ssuominen Exp $
+
+EAPI=5
+
+# svn export http://svn.xiph.org/trunk/Tremor tremor-${PV}
+
+inherit autotools eutils
+
+DESCRIPTION="A fixed-point version of the Ogg Vorbis decoder (also known as libvorbisidec)"
+HOMEPAGE="http://wiki.xiph.org/Tremor"
+SRC_URI="http://dev.gentoo.org/~ssuominen/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+IUSE="low-accuracy static-libs"
+
+RDEPEND="media-libs/libogg:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="CHANGELOG README"
+
+src_prepare() {
+ sed -i -e '/CFLAGS/s:-O2::' configure.in || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable low-accuracy)
+}
+
+src_install() {
+ default
+ dohtml -r doc/*
+ prune_libtool_files
+}