summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2011-04-16 21:25:41 +0000
committerSteve Arnold <nerdboy@gentoo.org>2011-04-16 21:25:41 +0000
commit9f96f55b29550ce6241504fe190b0aad1df81213 (patch)
tree21cca06c7bceaef19d3ed16f56952af595770f9f /media-libs/tiff/tiff-4.0.0_beta7.ebuild
parentNew package. (diff)
downloadgentoo-2-9f96f55b29550ce6241504fe190b0aad1df81213.tar.gz
gentoo-2-9f96f55b29550ce6241504fe190b0aad1df81213.tar.bz2
gentoo-2-9f96f55b29550ce6241504fe190b0aad1df81213.zip
Two new version releases and 2 patches to stable (see ChangeLog).
(Portage version: 2.1.9.46/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'media-libs/tiff/tiff-4.0.0_beta7.ebuild')
-rw-r--r--media-libs/tiff/tiff-4.0.0_beta7.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/media-libs/tiff/tiff-4.0.0_beta7.ebuild b/media-libs/tiff/tiff-4.0.0_beta7.ebuild
new file mode 100644
index 000000000000..baab75abedf8
--- /dev/null
+++ b/media-libs/tiff/tiff-4.0.0_beta7.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/tiff/tiff-4.0.0_beta7.ebuild,v 1.1 2011/04/16 21:25:41 nerdboy Exp $
+
+EAPI=3
+inherit eutils libtool
+
+MY_P=${P/_}
+
+DESCRIPTION="Library for manipulation of TIFF (Tag Image File Format) images"
+HOMEPAGE="http://www.remotesensing.org/libtiff/"
+SRC_URI="ftp://ftp.remotesensing.org/pub/libtiff/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="+cxx jbig jpeg static-libs zlib"
+
+RDEPEND="${DEPEND}"
+
+DEPEND="jpeg? ( virtual/jpeg )
+ jbig? ( media-libs/jbigkit )
+ zlib? ( sys-libs/zlib )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.9.2-CVE-2009-2347.patch
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable static-libs static) \
+ $(use_enable cxx) \
+ $(use_enable zlib) \
+ $(use_enable jpeg) \
+ $(use_enable jbig) \
+ --without-x \
+ --with-docdir="${EPREFIX}"/usr/share/doc/${PF}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc ChangeLog README TODO
+
+ use static-libs || find "${ED}" -name '*.la' -exec rm -f '{}' +
+}
+
+pkg_postinst() {
+ if use jbig; then
+ echo
+ elog "JBIG support is intended for Hylafax fax compression, so we"
+ elog "really need more feedback in other areas (most testing has"
+ elog "been done with fax). Be sure to recompile anything linked"
+ elog "against tiff if you rebuild it with jbig support."
+ echo
+ fi
+}