summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-06-20 19:48:50 +0000
committerMike Frysinger <vapier@gentoo.org>2006-06-20 19:48:50 +0000
commit5d4439576016893b28dad12307e6ce8d30c11b21 (patch)
treef249b4c515ad9df8e6895f87caf0a6bd048cde3c /media-libs/svgalib/files
parentkill off pointless whitespace (diff)
downloadgentoo-2-5d4439576016893b28dad12307e6ce8d30c11b21.tar.gz
gentoo-2-5d4439576016893b28dad12307e6ce8d30c11b21.tar.bz2
gentoo-2-5d4439576016893b28dad12307e6ce8d30c11b21.zip
Fix building with linux-2.6.17 #137234 by Ivan Yosifov.
(Portage version: 2.1.1_pre1-r1)
Diffstat (limited to 'media-libs/svgalib/files')
-rw-r--r--media-libs/svgalib/files/svgalib-1.9.24-linux2.6.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/media-libs/svgalib/files/svgalib-1.9.24-linux2.6.patch b/media-libs/svgalib/files/svgalib-1.9.24-linux2.6.patch
index 6e07283ab646..4dfd6b3864c3 100644
--- a/media-libs/svgalib/files/svgalib-1.9.24-linux2.6.patch
+++ b/media-libs/svgalib/files/svgalib-1.9.24-linux2.6.patch
@@ -2,6 +2,7 @@
- touch up the Makefile to let the ebuild handle the module details
- fix support with io remap stuff in newer kernels
- dont include headers that dont exist in 2.4.x kernels
+ - use module_param() for 2.6.x and MODULE_PARM() for all others
--- svgalib/kernel/svgalib_helper/Makefile
+++ svgalib/kernel/svgalib_helper/Makefile
@@ -121,3 +122,21 @@
#define __KERNEL_SYSCALLS__
#include <linux/unistd.h>
+@@ -770,10 +770,15 @@
+
+ }
+
++#ifdef KERNEL_2_6
++module_param(debug, int, 0);
++module_param(all_devices, int, 0);
++#else
+ MODULE_PARM(debug, "i");
+-MODULE_PARM_DESC(debug, "Debug output level.");
+-
+ MODULE_PARM(all_devices, "i");
++#endif
++
++MODULE_PARM_DESC(debug, "Debug output level.");
+ MODULE_PARM_DESC(all_devices, "Give access to all PCI devices, regardless of class.");
+
+