summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-02-07 03:01:43 +0000
committerMike Frysinger <vapier@gentoo.org>2006-02-07 03:01:43 +0000
commit05d1c0fad7094460c1e109c948a9b00b5f943140 (patch)
treec3820276a4b907b291aedf361ecb497e02f3e188 /media-libs/svgalib/files
parentdisable more calls to ldconfig (diff)
downloadgentoo-2-05d1c0fad7094460c1e109c948a9b00b5f943140.tar.gz
gentoo-2-05d1c0fad7094460c1e109c948a9b00b5f943140.tar.bz2
gentoo-2-05d1c0fad7094460c1e109c948a9b00b5f943140.zip
Version bump.
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'media-libs/svgalib/files')
-rw-r--r--media-libs/svgalib/files/digest-svgalib-1.9.243
-rw-r--r--media-libs/svgalib/files/svgalib-1.9.24-linux2.6.patch89
2 files changed, 92 insertions, 0 deletions
diff --git a/media-libs/svgalib/files/digest-svgalib-1.9.24 b/media-libs/svgalib/files/digest-svgalib-1.9.24
new file mode 100644
index 000000000000..88169866373e
--- /dev/null
+++ b/media-libs/svgalib/files/digest-svgalib-1.9.24
@@ -0,0 +1,3 @@
+MD5 3be376c08462caf88cfc150239481110 svgalib-1.9.24.tar.gz 986612
+RMD160 5ecab1a6945b8b3747850a0fa283fb2bf558e24d svgalib-1.9.24.tar.gz 986612
+SHA256 12f74fd44c13991ece0fb4bb0d4d95366ba1de2758c7eec10b59290bc6237ca1 svgalib-1.9.24.tar.gz 986612
diff --git a/media-libs/svgalib/files/svgalib-1.9.24-linux2.6.patch b/media-libs/svgalib/files/svgalib-1.9.24-linux2.6.patch
new file mode 100644
index 000000000000..a7e18d82580d
--- /dev/null
+++ b/media-libs/svgalib/files/svgalib-1.9.24-linux2.6.patch
@@ -0,0 +1,89 @@
+ - touch up the Makefile to let the ebuild handle the module details
+ - fix support with io remap stuff in newer kernels
+
+--- svgalib/kernel/svgalib_helper/Makefile.alt
++++ svgalib/kernel/svgalib_helper/Makefile.alt
+@@ -37,7 +37,7 @@
+ CFLAGS += -DSVGALIB_HELPER_MAJOR=$(SVGALIB_HELPER_MAJOR)
+
+ ifeq (1,$(findstring 1,$(MODVER)))
+- CFLAGS += -DMODVERSIONS -include $(INCLUDEDIR)/linux/modversions.h
++ CFLAGS += -DMODVERSIONS -DCONFIG_MODVERSIONS=1
+ endif
+
+ TARGET = svgalib_helper
+@@ -50,7 +50,8 @@
+ endif
+ endif
+
+-all: .depend $(OBJS)
++modules: $(OBJS)
++all: .depend modules
+
+ $(TARGET).o: $(SRC:.c=.o)
+ $(LD) -r $^ -o $@
+@@ -61,8 +62,8 @@
+ install: device modules_install
+
+ modules_install: $(OBJS)
+- mkdir -p /lib/modules/$(VER)/kernel/misc
+- install -m 0644 -c $(OBJS) /lib/modules/$(VER)/kernel/misc
++ mkdir -p $(TOPDIR)/lib/modules/$(VER)/kernel/misc
++ install -m 0644 -c $(OBJS) $(TOPDIR)/lib/modules/$(VER)/kernel/misc
+
+ device:
+ rm -f /dev/svgalib_helper* /dev/svga_helper* /dev/svga /dev/svga?
+--- svgalib/kernel/svgalib_helper/kernel26compat.h
++++ svgalib/kernel/svgalib_helper/kernel26compat.h
+@@ -10,7 +10,7 @@
+ # define PCI_GET_CLASS pci_find_class
+ # define PCI_GET_DEVICE pci_find_device
+
+-# if defined (PG_chainlock)
++# if LINUX_VERSION_CODE >= KERNEL_VERSION(2,5,3)
+ # define my_io_remap_page_range(vma, start, ofs, len, prot) \
+ io_remap_page_range(vma,start,ofs,len,prot)
+ # else
+@@ -84,6 +84,21 @@
+ # define SLH_SYSFS_REGISTER \
+ svgalib_helper_class = class_create(THIS_MODULE, "svgalib_helper");
+
++
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,15)
++
++# define SLH_SYSFS_ADD_CONTROL \
++ class_device_create(svgalib_helper_class, NULL, \
++ MKDEV(SVGALIB_HELPER_MAJOR, 0), \
++ NULL, "svga");
++
++# define SLH_SYSFS_ADD_DEVICE(_name, _minor) \
++ class_device_create(svgalib_helper_class, NULL, \
++ MKDEV(SVGALIB_HELPER_MAJOR, _minor), \
++ &sh_pci_devs[_minor]->dev->dev, _name);
++#else
++
++
+ # define SLH_SYSFS_ADD_CONTROL \
+ class_device_create(svgalib_helper_class, \
+ MKDEV(SVGALIB_HELPER_MAJOR, 0), \
+@@ -93,6 +108,8 @@
+ class_device_create(svgalib_helper_class, \
+ MKDEV(SVGALIB_HELPER_MAJOR, _minor), \
+ &sh_pci_devs[_minor]->dev->dev, _name);
++#endif
++
+
+ # define SLH_SYSFS_REMOVE_DEVICE(i) \
+ class_destroy(svgalib_helper_class);
+@@ -148,6 +148,11 @@
+ # define SLH_SYSFS_UNREGISTER
+ #endif
+
++/* gregkh was so kind as to remove a ton of PCI defines in linux-2.6.15 */
++#if !defined(PCI_VENDOR_ID_RENDITION)
++# define PCI_VENDOR_ID_RENDITION 0x1163
++#endif
++
+ #if (defined MINOR)
+ # define my_minor(x) MINOR(x)
+ #else