summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-04-26 17:47:39 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-04-26 17:47:39 +0000
commit36182e143182b6d43c8c77d713ad7d0ef668e5ec (patch)
tree4a0b4d0b021264c0f2f85d8b5c8a8a7007cbdb7e /media-libs/speex
parentFix metadata.xml (diff)
downloadgentoo-2-36182e143182b6d43c8c77d713ad7d0ef668e5ec.tar.gz
gentoo-2-36182e143182b6d43c8c77d713ad7d0ef668e5ec.tar.bz2
gentoo-2-36182e143182b6d43c8c77d713ad7d0ef668e5ec.zip
Use AC_CONFIG_HEADERS instead of the obsolete AM_CONFIG_HEADER wrt #467012 by Alphat-PC
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'media-libs/speex')
-rw-r--r--media-libs/speex/ChangeLog8
-rw-r--r--media-libs/speex/speex-1.2_rc1-r1.ebuild17
2 files changed, 15 insertions, 10 deletions
diff --git a/media-libs/speex/ChangeLog b/media-libs/speex/ChangeLog
index 71503e29b1e3..0dd6e05197fc 100644
--- a/media-libs/speex/ChangeLog
+++ b/media-libs/speex/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/speex
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/speex/ChangeLog,v 1.100 2012/09/07 22:41:11 radhermit Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/speex/ChangeLog,v 1.101 2013/04/26 17:47:39 ssuominen Exp $
+
+ 26 Apr 2013; Samuli Suominen <ssuominen@gentoo.org> speex-1.2_rc1-r1.ebuild:
+ Use AC_CONFIG_HEADERS instead of the obsolete AM_CONFIG_HEADER wrt #467012 by
+ Alphat-PC
07 Sep 2012; Tim Harder <radhermit@gentoo.org> metadata.xml:
Remove redundant maintainer from metadata.
diff --git a/media-libs/speex/speex-1.2_rc1-r1.ebuild b/media-libs/speex/speex-1.2_rc1-r1.ebuild
index 125bff789f94..6aa42747f262 100644
--- a/media-libs/speex/speex-1.2_rc1-r1.ebuild
+++ b/media-libs/speex/speex-1.2_rc1-r1.ebuild
@@ -1,14 +1,14 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/speex/speex-1.2_rc1-r1.ebuild,v 1.3 2012/05/15 13:10:33 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/speex/speex-1.2_rc1-r1.ebuild,v 1.4 2013/04/26 17:47:39 ssuominen Exp $
-EAPI=2
+EAPI=5
inherit autotools eutils flag-o-matic
MY_P=${P/_} ; MY_P=${MY_P/_p/.}
DESCRIPTION="Audio compression format designed for speech."
-HOMEPAGE="http://www.speex.org"
+HOMEPAGE="http://www.speex.org/"
SRC_URI="http://downloads.xiph.org/releases/speex/${MY_P}.tar.gz"
LICENSE="BSD"
@@ -16,7 +16,7 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
IUSE="ogg sse static-libs"
-RDEPEND="ogg? ( media-libs/libogg )"
+RDEPEND="ogg? ( media-libs/libogg:= )"
DEPEND="${RDEPEND}
virtual/pkgconfig"
@@ -25,6 +25,8 @@ S=${WORKDIR}/${MY_P}
src_prepare() {
epatch "${FILESDIR}"/${PF}-configure.patch
+ sed -i -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.ac || die #467012
+
sed -i \
-e 's:noinst_PROGRAMS:check_PROGRAMS:' \
libspeex/Makefile.am || die
@@ -37,14 +39,13 @@ src_configure() {
econf \
$(use_enable static-libs static) \
- --disable-dependency-tracking \
$(use_enable sse) \
$(use_enable ogg)
}
src_install() {
- emake DESTDIR="${D}" docdir=/usr/share/doc/${PF} install || die
+ emake DESTDIR="${D}" docdir=/usr/share/doc/${PF} install
dodoc AUTHORS ChangeLog NEWS README* TODO
- find "${D}" -name '*.la' -exec rm -f '{}' +
+ prune_libtool_files
}