summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2006-04-18 15:38:02 +0000
committerPatrick McLean <chutzpah@gentoo.org>2006-04-18 15:38:02 +0000
commitd4e9dc71e4d90a09d60f1891fdf7fe15ffb68e1c (patch)
tree69a241a3375ca6f2c62f045448bf76491214c665 /media-libs/speex/speex-1.1.12.ebuild
parentVersion bump and small config change for possible security issue (diff)
downloadgentoo-2-d4e9dc71e4d90a09d60f1891fdf7fe15ffb68e1c.tar.gz
gentoo-2-d4e9dc71e4d90a09d60f1891fdf7fe15ffb68e1c.tar.bz2
gentoo-2-d4e9dc71e4d90a09d60f1891fdf7fe15ffb68e1c.zip
Version bump, added vorbis-psy USE flag for new support for vorbis-style psychoacoustics (bug 130197)
(Portage version: 2.1_pre7-r5)
Diffstat (limited to 'media-libs/speex/speex-1.1.12.ebuild')
-rw-r--r--media-libs/speex/speex-1.1.12.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/media-libs/speex/speex-1.1.12.ebuild b/media-libs/speex/speex-1.1.12.ebuild
new file mode 100644
index 000000000000..6e47a9220a26
--- /dev/null
+++ b/media-libs/speex/speex-1.1.12.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/speex/speex-1.1.12.ebuild,v 1.1 2006/04/18 15:38:02 chutzpah Exp $
+
+inherit eutils autotools libtool
+
+DESCRIPTION="Speech encoding library"
+HOMEPAGE="http://www.speex.org/"
+SRC_URI="http://downloads.xiph.org/releases/speex/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~sh ~sparc ~x86"
+IUSE="ogg sse vorbis-psy"
+
+RDEPEND="ogg? ( >=media-libs/libogg-1.0 )"
+
+DEPEND="${RDEPEND}
+ sys-devel/autoconf
+ sys-devel/automake
+ sys-devel/libtool"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # This is needed to fix parallel make issues.
+ # As this changes the Makefile.am, need to rebuild autotools.
+ sed -i -e 's:\$(top_builddir)/libspeex/libspeex.la:libspeex.la:' \
+ ${S}/libspeex/Makefile.am
+
+ eautoreconf
+
+ # Better being safe
+ elibtoolize
+}
+
+src_compile() {
+ # ogg autodetect only
+ econf \
+ $(use_enable vorbis-psy) \
+ $(use_enable sse) \
+ || die
+ emake || die
+}
+
+src_install () {
+ make DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog README* TODO NEWS
+}