summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-05-19 18:07:00 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-05-19 18:07:00 +0000
commit18f2c6c725954f0ba9873c0f2b1e27d6592a1d58 (patch)
treeee4afb2f4c5e19c8c9728177cefdcb175d67037c /media-libs/sdl-mixer
parentAdded ~ppc64 (diff)
downloadgentoo-2-18f2c6c725954f0ba9873c0f2b1e27d6592a1d58.tar.gz
gentoo-2-18f2c6c725954f0ba9873c0f2b1e27d6592a1d58.tar.bz2
gentoo-2-18f2c6c725954f0ba9873c0f2b1e27d6592a1d58.zip
version bump
(Portage version: 2.1_rc1-r3)
Diffstat (limited to 'media-libs/sdl-mixer')
-rw-r--r--media-libs/sdl-mixer/ChangeLog8
-rw-r--r--media-libs/sdl-mixer/files/digest-sdl-mixer-1.2.73
-rw-r--r--media-libs/sdl-mixer/sdl-mixer-1.2.7.ebuild48
3 files changed, 58 insertions, 1 deletions
diff --git a/media-libs/sdl-mixer/ChangeLog b/media-libs/sdl-mixer/ChangeLog
index 2339bd4feeab..068cacc2424f 100644
--- a/media-libs/sdl-mixer/ChangeLog
+++ b/media-libs/sdl-mixer/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/sdl-mixer
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-mixer/ChangeLog,v 1.39 2006/04/11 19:45:13 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-mixer/ChangeLog,v 1.40 2006/05/19 18:07:00 mr_bones_ Exp $
+
+*sdl-mixer-1.2.7 (19 May 2006)
+
+ 19 May 2006; Michael Sterrett <mr_bones_@gentoo.org>
+ +sdl-mixer-1.2.7.ebuild:
+ version bump
11 Apr 2006; Diego Pettenò <flameeyes@gentoo.org>
sdl-mixer-1.2.6-r1.ebuild:
diff --git a/media-libs/sdl-mixer/files/digest-sdl-mixer-1.2.7 b/media-libs/sdl-mixer/files/digest-sdl-mixer-1.2.7
new file mode 100644
index 000000000000..58b8610a49d1
--- /dev/null
+++ b/media-libs/sdl-mixer/files/digest-sdl-mixer-1.2.7
@@ -0,0 +1,3 @@
+MD5 7959b89c8f8f1564ca90968f6c88fa1e SDL_mixer-1.2.7.tar.gz 1960614
+RMD160 cacb218f966d35cc66c663c0ce65b148869c08c3 SDL_mixer-1.2.7.tar.gz 1960614
+SHA256 bb3197285d8dc95a09068bbddefdf34c8b08ded8975bcc169050ff2bfded2ea4 SDL_mixer-1.2.7.tar.gz 1960614
diff --git a/media-libs/sdl-mixer/sdl-mixer-1.2.7.ebuild b/media-libs/sdl-mixer/sdl-mixer-1.2.7.ebuild
new file mode 100644
index 000000000000..3c252d205ba8
--- /dev/null
+++ b/media-libs/sdl-mixer/sdl-mixer-1.2.7.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-mixer/sdl-mixer-1.2.7.ebuild,v 1.1 2006/05/19 18:07:00 mr_bones_ Exp $
+
+MY_P=${P/sdl-/SDL_}
+DESCRIPTION="Simple Direct Media Layer Mixer Library"
+HOMEPAGE="http://www.libsdl.org/projects/SDL_mixer/index.html"
+SRC_URI="http://www.libsdl.org/projects/SDL_mixer/release/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="mp3 mikmod timidity vorbis"
+
+DEPEND=">=media-libs/libsdl-1.2.10
+ timidity? ( media-sound/timidity++ )
+ mp3? ( >=media-libs/smpeg-0.4.4-r1 )
+ vorbis? ( >=media-libs/libvorbis-1.0_beta4 media-libs/libogg )
+ mikmod? ( >=media-libs/libmikmod-3.1.10 )"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e 's:/usr/local/lib/timidity:/usr/share/timidity:' \
+ timidity/config.h \
+ || die "sed timidity/config.h failed"
+}
+
+src_compile() {
+ # don't use the internal mikmod library, use the system one if USE=mikmod
+ econf \
+ --disable-music-mod \
+ --disable-dependency-tracking \
+ $(use_enable timidity timidity-midi) \
+ $(use_enable mikmod music-libmikmod) \
+ $(use_enable mp3 music-mp3) \
+ $(use_enable vorbis music-ogg) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc CHANGES README
+}