summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2009-09-20 11:11:10 +0000
committerTristan Heaven <nyhm@gentoo.org>2009-09-20 11:11:10 +0000
commite6497ecec548073cf5e7bd737379973a892e2116 (patch)
treea1fbbf38f9f936aa873dd04217ed6b1bd2fd5726 /media-libs/sdl-image
parentAvoid linking with libusb and libbluetooth when usb respectively bluetooth US... (diff)
downloadgentoo-2-e6497ecec548073cf5e7bd737379973a892e2116.tar.gz
gentoo-2-e6497ecec548073cf5e7bd737379973a892e2116.tar.bz2
gentoo-2-e6497ecec548073cf5e7bd737379973a892e2116.zip
New revision to force a rebuild with jpeg-7 that revdep-rebuild won't catch (thanks to Sirko Schroeder for reporting)
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/sdl-image')
-rw-r--r--media-libs/sdl-image/ChangeLog8
-rw-r--r--media-libs/sdl-image/sdl-image-1.2.7-r1.ebuild46
2 files changed, 53 insertions, 1 deletions
diff --git a/media-libs/sdl-image/ChangeLog b/media-libs/sdl-image/ChangeLog
index 8ada6addcb04..f875caa7ccb7 100644
--- a/media-libs/sdl-image/ChangeLog
+++ b/media-libs/sdl-image/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/sdl-image
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-image/ChangeLog,v 1.52 2009/09/02 10:34:48 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-image/ChangeLog,v 1.53 2009/09/20 11:11:10 nyhm Exp $
+
+*sdl-image-1.2.7-r1 (20 Sep 2009)
+
+ 20 Sep 2009; Tristan Heaven <nyhm@gentoo.org> +sdl-image-1.2.7-r1.ebuild:
+ New revision to force a rebuild with jpeg-7 that revdep-rebuild won't
+ catch (thanks to Sirko Schroeder for reporting)
02 Sep 2009; Tristan Heaven <nyhm@gentoo.org> sdl-image-1.2.7.ebuild:
Don't control support for pnm with the png USE flag
diff --git a/media-libs/sdl-image/sdl-image-1.2.7-r1.ebuild b/media-libs/sdl-image/sdl-image-1.2.7-r1.ebuild
new file mode 100644
index 000000000000..4eb9604181b2
--- /dev/null
+++ b/media-libs/sdl-image/sdl-image-1.2.7-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-image/sdl-image-1.2.7-r1.ebuild,v 1.1 2009/09/20 11:11:10 nyhm Exp $
+
+MY_P="${P/sdl-/SDL_}"
+DESCRIPTION="image file loading library"
+HOMEPAGE="http://www.libsdl.org/projects/SDL_image/index.html"
+SRC_URI="http://www.libsdl.org/projects/SDL_image/release/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="gif jpeg tiff png"
+
+DEPEND="sys-libs/zlib
+ media-libs/libsdl
+ png? ( media-libs/libpng )
+ jpeg? ( >=media-libs/jpeg-7 )
+ tiff? ( media-libs/tiff )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ econf \
+ $(use_enable gif) \
+ $(use_enable jpeg jpg) \
+ $(use_enable tiff tif) \
+ $(use_enable png) \
+ --enable-bmp \
+ --enable-lbm \
+ --enable-pcx \
+ --enable-pnm \
+ --enable-tga \
+ --enable-xcf \
+ --enable-xpm \
+ --enable-xv \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dobin .libs/showimage || die "dobin failed"
+ dodoc CHANGES README
+}