summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-09-26 13:22:11 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-09-26 13:22:11 +0000
commitf61c0a06a57c557fa17aaf411f3d1dbe53734720 (patch)
treea2355677793afa936aa64a636eb5714a2f89bdcc /media-libs/rubberband
parentMarking ntfs3g-2009.3.8 ppc64 for bug 272355 (diff)
downloadgentoo-2-f61c0a06a57c557fa17aaf411f3d1dbe53734720.tar.gz
gentoo-2-f61c0a06a57c557fa17aaf411f3d1dbe53734720.tar.bz2
gentoo-2-f61c0a06a57c557fa17aaf411f3d1dbe53734720.zip
version bump
(Portage version: 2.2_rc42/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/rubberband')
-rw-r--r--media-libs/rubberband/ChangeLog8
-rw-r--r--media-libs/rubberband/files/rubberband-1.4-gcc44.patch12
-rw-r--r--media-libs/rubberband/files/rubberband-1.4-install.patch18
-rw-r--r--media-libs/rubberband/rubberband-1.4.ebuild40
4 files changed, 77 insertions, 1 deletions
diff --git a/media-libs/rubberband/ChangeLog b/media-libs/rubberband/ChangeLog
index 54cc6f1f908e..b7f7f7bba35d 100644
--- a/media-libs/rubberband/ChangeLog
+++ b/media-libs/rubberband/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/rubberband
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/rubberband/ChangeLog,v 1.10 2009/06/23 21:13:56 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/rubberband/ChangeLog,v 1.11 2009/09/26 13:22:11 aballier Exp $
+
+*rubberband-1.4 (26 Sep 2009)
+
+ 26 Sep 2009; Alexis Ballier <aballier@gentoo.org> +rubberband-1.4.ebuild,
+ +files/rubberband-1.4-gcc44.patch, +files/rubberband-1.4-install.patch:
+ version bump
23 Jun 2009; Alexis Ballier <aballier@gentoo.org>
-rubberband-1.0.1.ebuild, -files/rubberband-1.0.1-gcc43.patch,
diff --git a/media-libs/rubberband/files/rubberband-1.4-gcc44.patch b/media-libs/rubberband/files/rubberband-1.4-gcc44.patch
new file mode 100644
index 000000000000..6556df486ccb
--- /dev/null
+++ b/media-libs/rubberband/files/rubberband-1.4-gcc44.patch
@@ -0,0 +1,12 @@
+Index: rubberband-1.4/src/system/sysutils.h
+===================================================================
+--- rubberband-1.4.orig/src/system/sysutils.h
++++ rubberband-1.4/src/system/sysutils.h
+@@ -81,6 +81,7 @@ inline float princargf(float a) { return
+
+ #include <sys/mman.h>
+ #include <dlfcn.h>
++#include <stdio.h> // perror
+
+ #define MLOCK(a,b) ::mlock((char *)(a),(b))
+ #define MUNLOCK(a,b) (::munlock((char *)(a),(b)) ? (::perror("munlock failed"), 0) : 0)
diff --git a/media-libs/rubberband/files/rubberband-1.4-install.patch b/media-libs/rubberband/files/rubberband-1.4-install.patch
new file mode 100644
index 000000000000..c0f23757ac8e
--- /dev/null
+++ b/media-libs/rubberband/files/rubberband-1.4-install.patch
@@ -0,0 +1,18 @@
+Index: rubberband-1.4/Makefile.in
+===================================================================
+--- rubberband-1.4.orig/Makefile.in
++++ rubberband-1.4/Makefile.in
+@@ -150,10 +150,10 @@ install: all
+ test -n "$(DYNAMIC_FULL_VERSION)" && ln -s $(DYNAMIC_LIBNAME)$(DYNAMIC_FULL_VERSION) $(DESTDIR)$(INSTALL_LIBDIR)/$(DYNAMIC_LIBNAME)$(DYNAMIC_ABI_VERSION)
+ test -n "$(DYNAMIC_FULL_VERSION)" && ln -s $(DYNAMIC_LIBNAME)$(DYNAMIC_FULL_VERSION) $(DESTDIR)$(INSTALL_LIBDIR)/$(DYNAMIC_LIBNAME)
+ cp $(VAMP_TARGET) $(DESTDIR)$(INSTALL_VAMPDIR)
+- cp src/vamp/vamp-rubberband.cat $(DESTDIR)$(INSTALL_VAMPDIR)
++ cp vamp/vamp-rubberband.cat $(DESTDIR)$(INSTALL_VAMPDIR)
+ cp $(LADSPA_TARGET) $(DESTDIR)$(INSTALL_LADSPADIR)
+- cp src/ladspa/ladspa-rubberband.cat $(DESTDIR)$(INSTALL_LADSPADIR)
+- cp src/ladspa/ladspa-rubberband.rdf $(DESTDIR)$(INSTALL_LRDFDIR)
++ cp ladspa/ladspa-rubberband.cat $(DESTDIR)$(INSTALL_LADSPADIR)
++ cp ladspa/ladspa-rubberband.rdf $(DESTDIR)$(INSTALL_LRDFDIR)
+ sed "s,%PREFIX%,@prefix@," rubberband.pc.in \
+ > $(DESTDIR)$(INSTALL_PKGDIR)/rubberband.pc
+
diff --git a/media-libs/rubberband/rubberband-1.4.ebuild b/media-libs/rubberband/rubberband-1.4.ebuild
new file mode 100644
index 000000000000..434677aa5762
--- /dev/null
+++ b/media-libs/rubberband/rubberband-1.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/rubberband/rubberband-1.4.ebuild,v 1.1 2009/09/26 13:22:11 aballier Exp $
+
+EAPI=2
+inherit eutils multilib
+
+DESCRIPTION="An audio time-stretching and pitch-shifting library and utility program"
+HOMEPAGE="http://www.breakfastquay.com/rubberband/"
+SRC_URI="http://www.breakfastquay.com/rubberband/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="media-libs/vamp-plugin-sdk
+ media-libs/libsamplerate
+ media-libs/libsndfile
+ media-libs/ladspa-sdk
+ =sci-libs/fftw-3*"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc44.patch
+ epatch "${FILESDIR}"/${P}-install.patch
+}
+
+src_install() {
+ emake INSTALL_BINDIR="${D}/usr/bin" \
+ INSTALL_INCDIR="${D}/usr/include/rubberband" \
+ INSTALL_LIBDIR="${D}/usr/$(get_libdir)" \
+ INSTALL_VAMPDIR="${D}/usr/$(get_libdir)/vamp" \
+ INSTALL_LADSPADIR="${D}/usr/$(get_libdir)/ladspa" \
+ INSTALL_LRDFDIR="${D}/usr/share/ladspa/rdf" \
+ INSTALL_PKGDIR="${D}/usr/$(get_libdir)/pkgconfig" \
+ install || die "emake install failed"
+ dodoc CHANGELOG
+}