summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-12-25 19:39:04 +0000
committerMichał Górny <mgorny@gentoo.org>2014-12-25 19:39:04 +0000
commit9bb6094c98102e1789ac8e99a694aabc30235203 (patch)
treeea4566450539cafed4d38b1f2a3a2c9758af41b0 /media-libs/raul
parentAdd missing PYTHON_USEDEP. Port the changes to -9999. (diff)
downloadgentoo-2-9bb6094c98102e1789ac8e99a694aabc30235203.tar.gz
gentoo-2-9bb6094c98102e1789ac8e99a694aabc30235203.tar.bz2
gentoo-2-9bb6094c98102e1789ac8e99a694aabc30235203.zip
Convert to python-any-r1.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'media-libs/raul')
-rw-r--r--media-libs/raul/ChangeLog7
-rw-r--r--media-libs/raul/raul-0.8.0-r1.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/media-libs/raul/ChangeLog b/media-libs/raul/ChangeLog
index 8221f9d98c43..9f854b5f9c1d 100644
--- a/media-libs/raul/ChangeLog
+++ b/media-libs/raul/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/raul
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/raul/ChangeLog,v 1.18 2014/08/10 21:11:40 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/raul/ChangeLog,v 1.19 2014/12/25 19:39:04 mgorny Exp $
+
+*raul-0.8.0-r1 (25 Dec 2014)
+
+ 25 Dec 2014; Michał Górny <mgorny@gentoo.org> +raul-0.8.0-r1.ebuild:
+ Convert to python-any-r1.
10 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org> raul-0.8.0.ebuild:
QA: drop trailing '.' from DESCRIPTION
diff --git a/media-libs/raul/raul-0.8.0-r1.ebuild b/media-libs/raul/raul-0.8.0-r1.ebuild
new file mode 100644
index 000000000000..62c90076afa5
--- /dev/null
+++ b/media-libs/raul/raul-0.8.0-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/raul/raul-0.8.0-r1.ebuild,v 1.1 2014/12/25 19:39:04 mgorny Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit waf-utils python-any-r1 eutils
+
+DESCRIPTION="C++ utility library primarily aimed at audio/musical applications"
+HOMEPAGE="http://wiki.drobilla.net/Raul"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc test"
+
+RDEPEND="dev-libs/boost
+ >=dev-libs/glib-2.14.0"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+RAUL_TESTS="atomic_test atom_test list_test midi_ringbuffer_test path_test quantize_test queue_test ringbuffer_test smf_test table_test thread_test time_test"
+DOCS=( AUTHORS README ChangeLog )
+
+src_prepare() {
+ epatch "${FILESDIR}/ldconfig2.patch"
+ epatch "${FILESDIR}/${P}-gcc47.patch"
+}
+
+src_configure() {
+ waf-utils_src_configure \
+ --htmldir=/usr/share/doc/${PF}/html \
+ $(use debug && echo "--debug") \
+ $(use doc && echo "--docs") \
+ $(use test && echo "--test")
+}
+
+src_test() {
+ cd "${S}/build/test" || die
+ for i in ${RAUL_TESTS} ; do
+ einfo "Running test ${i}"
+ LD_LIBRARY_PATH=.. ./${i} || die
+ done
+}