summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny van Dyk <kugelfang@gentoo.org>2005-02-22 21:23:35 +0000
committerDanny van Dyk <kugelfang@gentoo.org>2005-02-22 21:23:35 +0000
commite102e236506a9d863fbfaf849c640aa2d85e577a (patch)
tree5c718195788fb85c95e55353167fa487cc189778 /media-libs/qhull
parentFixed ChangeLog header. (diff)
downloadgentoo-2-e102e236506a9d863fbfaf849c640aa2d85e577a.tar.gz
gentoo-2-e102e236506a9d863fbfaf849c640aa2d85e577a.tar.bz2
gentoo-2-e102e236506a9d863fbfaf849c640aa2d85e577a.zip
Cleaned ebuild. Fixed BUG #82646.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'media-libs/qhull')
-rw-r--r--media-libs/qhull/ChangeLog8
-rw-r--r--media-libs/qhull/files/qhull-3.1-makefile.patch65
-rw-r--r--media-libs/qhull/qhull-3.1-r1.ebuild21
3 files changed, 79 insertions, 15 deletions
diff --git a/media-libs/qhull/ChangeLog b/media-libs/qhull/ChangeLog
index 17f8894a14b1..282f6b9946ef 100644
--- a/media-libs/qhull/ChangeLog
+++ b/media-libs/qhull/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/qhull
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/qhull/ChangeLog,v 1.14 2004/07/01 08:02:58 eradicator Exp $
+# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/qhull/ChangeLog,v 1.15 2005/02/22 21:23:35 kugelfang Exp $
+
+ 22 Feb 2005; Danny van Dyk <kugelfang@gentoo.org>
+ +files/qhull-3.1-makefile.patch, qhull-3.1-r1.ebuild:
+ Cleared out the sed/echo hacks done to Makefile. Fixed BUG #82646.
01 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org> qhull-3.1-r1.ebuild:
virtual/glibc -> virtual/libc
diff --git a/media-libs/qhull/files/qhull-3.1-makefile.patch b/media-libs/qhull/files/qhull-3.1-makefile.patch
new file mode 100644
index 000000000000..4ea5e8bed550
--- /dev/null
+++ b/media-libs/qhull/files/qhull-3.1-makefile.patch
@@ -0,0 +1,65 @@
+--- Makefile 2001-02-12 03:26:08.000000000 +0100
++++ /root/Makefile 2005-02-22 22:00:15.077553880 +0100
+@@ -78,7 +78,7 @@
+ qh-poly.htm qh-qhull.htm qh-set.htm qh-stat.htm qh-user.htm \
+ qdelau_f.htm qhalf.htm qvoronoi.htm qvoron_f.htm rbox.htm
+
+-all: rbox qconvex qdelaunay qhalf qvoronoi qhull
++all: rbox qconvex qdelaunay qhalf qvoronoi qhull libqhull.so
+
+ unix.o: qhull.h user.h mem.h
+ qconvex.o: qhull.h user.h mem.h
+@@ -100,6 +100,8 @@
+
+ .c.o:
+ $(CC) -c $(CCOPTS1) $<
++ mkdir -p .libs
++ $(CC) -c $(CCOPTS1) -fPIC $< -o .libs/$@
+
+ clean:
+ rm -f *.o ../core qconvex qdelaunay qhalf qvoronoi qhull
+@@ -142,23 +144,23 @@
+
+ # don't use ../qconvex. Does not work on Red Hat Linux
+ qconvex: qconvex.o libqhull.a
+- $(CC) -o qconvex $(CCOPTS2) qconvex.o -L. -lqhull -lm
++ $(CC) -o qconvex $(CCOPTS2) qconvex.o -L. libqhull.a -lm
+ cp qconvex ..
+
+ qdelaunay: qdelaun.o libqhull.a
+- $(CC) -o qdelaunay $(CCOPTS2) qdelaun.o -L. -lqhull -lm
++ $(CC) -o qdelaunay $(CCOPTS2) qdelaun.o -L. libqhull.a -lm
+ cp qdelaunay ..
+
+ qhalf: qhalf.o libqhull.a
+- $(CC) -o qhalf $(CCOPTS2) qhalf.o -L. -lqhull -lm
++ $(CC) -o qhalf $(CCOPTS2) qhalf.o -L. libqhull.a -lm
+ cp qhalf ..
+
+ qvoronoi: qvoronoi.o libqhull.a
+- $(CC) -o qvoronoi $(CCOPTS2) qvoronoi.o -L. -lqhull -lm
++ $(CC) -o qvoronoi $(CCOPTS2) qvoronoi.o -L. libqhull.a -lm
+ cp qvoronoi ..
+
+ qhull: unix.o libqhull.a
+- $(CC) -o qhull $(CCOPTS2) unix.o -L. -lqhull -lm
++ $(CC) -o qhull $(CCOPTS2) unix.o -L. libqhull.a -lm
+ cp qhull ..
+ -chmod +x ../eg/q_test ../eg/q_eg ../eg/q_egtest
+ -cd ..; ./rbox D4 | ./qhull
+@@ -179,11 +181,13 @@
+ cp rbox ..
+
+ user_eg: user_eg.o libqhull.a
+- $(CC) -o user_eg $(CCOPTS2) user_eg.o -L. -lqhull -lm
++ $(CC) -o user_eg $(CCOPTS2) user_eg.o -L. libqhull.a -lm
+ cp user_eg ..
+
+ user_eg2: user_eg2.o libqhull.a
+- $(CC) -o user_eg2 $(CCOPTS2) user_eg2.o -L. -lqhull -lm
++ $(CC) -o user_eg2 $(CCOPTS2) user_eg2.o -L. libqhull.a -lm
+ cp user_eg2 ..
+
+ # end of Makefile
++libqhull.so: $(OBJS)
++ c++ -shared -Xlinker -soname -Xlinker $@ -o libqhull.so $(addprefix .libs/,$(OBJS))
diff --git a/media-libs/qhull/qhull-3.1-r1.ebuild b/media-libs/qhull/qhull-3.1-r1.ebuild
index 2db6f56f0e98..48b2b7c40458 100644
--- a/media-libs/qhull/qhull-3.1-r1.ebuild
+++ b/media-libs/qhull/qhull-3.1-r1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/qhull/qhull-3.1-r1.ebuild,v 1.9 2004/07/01 08:02:58 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/qhull/qhull-3.1-r1.ebuild,v 1.10 2005/02/22 21:23:35 kugelfang Exp $
+
+inherit eutils
MY_P="${PN}${PV}"
DESCRIPTION="Geometry library"
@@ -22,17 +24,10 @@ src_unpack() {
unpack ${A}
cd ${S}/src
mv Makefile.txt Makefile
- # This echo statement appends a new build target to the exisiting Makefile
- # for an additional shared library; originally added to support octave-forge
- echo 'libqhull.so: $(OBJS)
- c++ -shared -Xlinker -soname -Xlinker $@ -o libqhull.so $(OBJS)' >> Makefile
-
- # the newly compiled programs will be run during the build. seems
- # easiest to statically link.
- sed -i \
- -e 's/-lqhull/libqhull.a/' \
- -e '/^all:/ s/$/ libqhull.so/' Makefile \
- || die "sed Makefile failed"
+ # Replaced sed/echo hacks by a clean patch. Fix build error on -fPIC archs
+ # BUG #82646
+ # Danny van Dyk <kugelfang@gentoo.org> 2005/02/22
+ epatch ${FILESDIR}/${P}-makefile.patch
}
src_compile() {