summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-05-07 06:13:11 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-05-07 06:13:11 +0000
commit3790ede49ef639994292601dcfd7646a6f73b007 (patch)
tree18c0436ffddf41305f27558803cd61df9ff659e7 /media-libs/qhull
parentAdd missing patch, Big ooops (Manifest recommit) (diff)
downloadgentoo-2-3790ede49ef639994292601dcfd7646a6f73b007.tar.gz
gentoo-2-3790ede49ef639994292601dcfd7646a6f73b007.tar.bz2
gentoo-2-3790ede49ef639994292601dcfd7646a6f73b007.zip
use emake; tidy; fix HOMEPAGE (bug #50289)
Diffstat (limited to 'media-libs/qhull')
-rw-r--r--media-libs/qhull/ChangeLog5
-rw-r--r--media-libs/qhull/qhull-3.1-r1.ebuild72
2 files changed, 40 insertions, 37 deletions
diff --git a/media-libs/qhull/ChangeLog b/media-libs/qhull/ChangeLog
index bd4a7b8f28cb..a5b89301e348 100644
--- a/media-libs/qhull/ChangeLog
+++ b/media-libs/qhull/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-libs/qhull
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/qhull/ChangeLog,v 1.10 2004/05/07 05:34:08 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/qhull/ChangeLog,v 1.11 2004/05/07 06:13:11 mr_bones_ Exp $
+
+ 06 May 2004; Michael Sterrett <mr_bones_@gentoo.org> qhull-3.1-r1.ebuild:
+ use emake; tidy; fix HOMEPAGE (bug #50289)
06 May 2004; Michael Sterrett <mr_bones_@gentoo.org> qhull-3.1.ebuild:
clean older ebuild
diff --git a/media-libs/qhull/qhull-3.1-r1.ebuild b/media-libs/qhull/qhull-3.1-r1.ebuild
index 078d7066124c..a289c2113e1f 100644
--- a/media-libs/qhull/qhull-3.1-r1.ebuild
+++ b/media-libs/qhull/qhull-3.1-r1.ebuild
@@ -1,62 +1,62 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/qhull/qhull-3.1-r1.ebuild,v 1.5 2004/04/12 22:55:11 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/qhull/qhull-3.1-r1.ebuild,v 1.6 2004/05/07 06:13:11 mr_bones_ Exp $
-IUSE=""
-
-S=${WORKDIR}/qhull3.1
+MY_P="${PN}${PV}"
DESCRIPTION="Geometry library"
-SRC_URI="http://www.geom.umn.edu/software/qhull/qhull3.1.tgz"
-HOMEPAGE="http://www.geom.umn.edu/software/qhull/"
+HOMEPAGE="http://www.qhull.org"
+SRC_URI="http://www.geom.umn.edu/software/qhull/${MY_P}.tgz"
SLOT="0"
LICENSE="BSD"
KEYWORDS="x86 sparc ~ppc ~amd64"
+IUSE=""
-DEPEND=""
+RDEPEND="virtual/glibc"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
-src_compile() {
- cd src
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/src
+ mv Makefile.txt Makefile
# This echo statement appends a new build target to the exisiting Makefile
# for an additional shared library; originally added to support octave-forge
echo 'libqhull.so: $(OBJS)
- c++ -shared -Xlinker -soname -Xlinker $@ -o libqhull.so $(OBJS)' >> Makefile.txt
- # This line now specifies the build targets, including the target added on
- # the previous line
- make -f Makefile.txt all libqhull.so
-
+ c++ -shared -Xlinker -soname -Xlinker $@ -o libqhull.so $(OBJS)' >> Makefile
+
+ # the newly compiled programs will be run during the build. seems
+ # easiest to statically link.
+ sed -i \
+ -e 's/-lqhull/libqhull.a/' \
+ -e '/^all:/ s/$/ libqhull.so/' Makefile \
+ || die "sed Makefile failed"
}
-src_install () {
+src_compile() {
+ cd src
+ emake CCOPTS1="${CFLAGS}" || die "emake failed"
+}
+src_install() {
cd src
- dolib libqhull.a
- # This line installs the extra shared lib compiled with the target added
- # above
- dolib.so libqhull.so
- dobin qconvex
- dobin qdelaunay
- dobin qhalf
- dobin qhull
- dobin qvoronoi
- dobin rbox
-
- dodir /usr/include/qhull
+ dolib libqhull.a || die "dolib failed"
+ dolib.so libqhull.so || die "dolib.so failed"
+ dobin qconvex qdelaunay qhalf qhull qvoronoi rbox || die "dobin failed"
+
insinto /usr/include/qhull
doins *.h
cd ${S}
dodoc Announce.txt COPYING.txt File_id.diz README.txt REGISTER.txt
-
cd html
-
- rename .htm .html *.htm
- rename .man .1 *.man
-
- dohtml -a html,gif *
-
- doman *.1
-
+ dohtml *
dodoc *.txt
+ for m in *man
+ do
+ newman ${m} ${m/.man/.1}
+ done
}