summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2011-04-25 14:45:44 +0000
committerFabian Groffen <grobian@gentoo.org>2011-04-25 14:45:44 +0000
commitde8b51ec6436b1736109edfb99852c95ff51d8fc (patch)
tree2e43401216eed99ea31e0d9e82105bf48583978d /media-libs/phonon-qt7
parentsparc stable wrt #359333 (diff)
downloadgentoo-2-de8b51ec6436b1736109edfb99852c95ff51d8fc.tar.gz
gentoo-2-de8b51ec6436b1736109edfb99852c95ff51d8fc.tar.bz2
gentoo-2-de8b51ec6436b1736109edfb99852c95ff51d8fc.zip
Fix deps, add patch and keyword for ~ppc-macos, bug #353362
(Portage version: 2.2.01.18252-prefix/cvs/Darwin powerpc)
Diffstat (limited to 'media-libs/phonon-qt7')
-rw-r--r--media-libs/phonon-qt7/ChangeLog7
-rw-r--r--media-libs/phonon-qt7/files/phonon-qt7-0_pre20110424-QWidget-cast-dynamic.patch28
-rw-r--r--media-libs/phonon-qt7/phonon-qt7-0_pre20110424.ebuild12
3 files changed, 43 insertions, 4 deletions
diff --git a/media-libs/phonon-qt7/ChangeLog b/media-libs/phonon-qt7/ChangeLog
index 79472668c16f..43e52e8b35f9 100644
--- a/media-libs/phonon-qt7/ChangeLog
+++ b/media-libs/phonon-qt7/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/phonon-qt7
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/phonon-qt7/ChangeLog,v 1.1 2011/04/24 18:45:38 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/phonon-qt7/ChangeLog,v 1.2 2011/04/25 14:45:44 grobian Exp $
+
+ 25 Apr 2011; Fabian Groffen <grobian@gentoo.org>
+ phonon-qt7-0_pre20110424.ebuild,
+ +files/phonon-qt7-0_pre20110424-QWidget-cast-dynamic.patch:
+ Fix deps, add patch and keyword for ~ppc-macos, bug #353362
*phonon-qt7-0_pre20110424 (24 Apr 2011)
diff --git a/media-libs/phonon-qt7/files/phonon-qt7-0_pre20110424-QWidget-cast-dynamic.patch b/media-libs/phonon-qt7/files/phonon-qt7-0_pre20110424-QWidget-cast-dynamic.patch
new file mode 100644
index 000000000000..ae222027b892
--- /dev/null
+++ b/media-libs/phonon-qt7/files/phonon-qt7-0_pre20110424-QWidget-cast-dynamic.patch
@@ -0,0 +1,28 @@
+Revert commit:
+
+commit b22b86f6940d2605e78398eca4ae05c3ea44a92c
+Author: Ritt Konstantin <ritt.ks@gmail.com>
+Date: Thu Jun 10 07:38:14 2010 +0400
+
+ fix build with -fno-rtti
+
+ m_renderDrawWidget object inherits QWidget and can be safely static_cast-ed
+
+as it yields in:
+
+error: invalid static_cast from type ‘Phonon::QT7::IVideoRenderDrawWidget*’ to type ‘QWidget*’
+
+
+diff --git a/qt7/videowidget.mm b/qt7/videowidget.mm
+index 736dcdf..e471140 100644
+--- a/qt7/videowidget.mm
++++ b/qt7/videowidget.mm
+@@ -578,7 +578,7 @@ public:
+ PhononAutoReleasePool pool;
+ updateDrawFrameRect();
+ if (m_renderDrawWidget)
+- static_cast<QWidget *>(m_renderDrawWidget)->resize(size());
++ dynamic_cast<QWidget *>(m_renderDrawWidget)->resize(size());
+ break; }
+ case QEvent::Paint:{
+ PhononAutoReleasePool pool;
diff --git a/media-libs/phonon-qt7/phonon-qt7-0_pre20110424.ebuild b/media-libs/phonon-qt7/phonon-qt7-0_pre20110424.ebuild
index d4dc72962f76..89da6f076c59 100644
--- a/media-libs/phonon-qt7/phonon-qt7-0_pre20110424.ebuild
+++ b/media-libs/phonon-qt7/phonon-qt7-0_pre20110424.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/phonon-qt7/phonon-qt7-0_pre20110424.ebuild,v 1.1 2011/04/24 18:45:38 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/phonon-qt7/phonon-qt7-0_pre20110424.ebuild,v 1.2 2011/04/25 14:45:44 grobian Exp $
EAPI=4
@@ -11,7 +11,7 @@ HOMEPAGE="https://projects.kde.org/projects/kdesupport/phonon/phonon-quicktime"
SRC_URI="http://dev.gentoo.org/~dilfridge/distfiles/${P}.tar.bz2"
LICENSE="LGPL-2.1"
-KEYWORDS=""
+KEYWORDS="~ppc-macos"
SLOT="0"
IUSE="debug"
@@ -19,10 +19,16 @@ RDEPEND=">=media-libs/phonon-4.5"
DEPEND="${RDEPEND}
>=dev-util/automoc-0.9.87
dev-util/pkgconfig
+ media-libs/opengl-apple
+ sys-devel/gcc-apple[objc]
"
# needs OpenGL, how do I specify this properly?
+# I just depended on opengl-apple, hope this is what you meant -- grobian
S="${WORKDIR}/${PN}"
-PATCHES=( "${FILESDIR}/${PN}-noshow.patch" )
+PATCHES=(
+ "${FILESDIR}/${PN}-noshow.patch"
+ "${FILESDIR}"/${P}-QWidget-cast-dynamic.patch
+)