summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2004-01-14 04:42:26 +0000
committerSeemant Kulleen <seemant@gentoo.org>2004-01-14 04:42:26 +0000
commit6590285b14290baa9c2989a4efc6b05c96d8df85 (patch)
treea46a0300c28acd91eff6e000f0b34b11dea33d1a /media-libs/pdflib
parentfix unneeded escape in sed (diff)
downloadgentoo-2-6590285b14290baa9c2989a4efc6b05c96d8df85.tar.gz
gentoo-2-6590285b14290baa9c2989a4efc6b05c96d8df85.tar.bz2
gentoo-2-6590285b14290baa9c2989a4efc6b05c96d8df85.zip
version bump
Diffstat (limited to 'media-libs/pdflib')
-rw-r--r--media-libs/pdflib/ChangeLog9
-rw-r--r--media-libs/pdflib/files/digest-pdflib-5.0.21
-rw-r--r--media-libs/pdflib/pdflib-4.0.1-r3.ebuild4
-rw-r--r--media-libs/pdflib/pdflib-5.0.2.ebuild114
4 files changed, 125 insertions, 3 deletions
diff --git a/media-libs/pdflib/ChangeLog b/media-libs/pdflib/ChangeLog
index 26410ea7410e..c821b78b995f 100644
--- a/media-libs/pdflib/ChangeLog
+++ b/media-libs/pdflib/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/pdflib
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/pdflib/ChangeLog,v 1.22 2004/01/10 17:57:27 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/pdflib/ChangeLog,v 1.23 2004/01/14 04:42:26 seemant Exp $
+
+*pdflib-5.0.2 (13 Jan 2004)
+
+ 13 Jan 2004; Seemant Kulleen <seemant@gentoo.org> pdflib-5.0.2.ebuild :
+
+ Version bump, coz the previous version seems to have been taken offline
+ upstream.
10 Jan 2004; Aron Griffis <agriffis@gentoo.org> pdflib-4.0.3-r1.ebuild:
stable on alpha and ia64
diff --git a/media-libs/pdflib/files/digest-pdflib-5.0.2 b/media-libs/pdflib/files/digest-pdflib-5.0.2
new file mode 100644
index 000000000000..29fc2e9dcf26
--- /dev/null
+++ b/media-libs/pdflib/files/digest-pdflib-5.0.2
@@ -0,0 +1 @@
+MD5 009fb9a1bace2ba86d6ed5373a18fa4b PDFlib-Lite-5.0.2-Unix-src.tar.gz 2774610
diff --git a/media-libs/pdflib/pdflib-4.0.1-r3.ebuild b/media-libs/pdflib/pdflib-4.0.1-r3.ebuild
index 40ea1b40cd31..09b71702c6e2 100644
--- a/media-libs/pdflib/pdflib-4.0.1-r3.ebuild
+++ b/media-libs/pdflib/pdflib-4.0.1-r3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/pdflib/pdflib-4.0.1-r3.ebuild,v 1.17 2003/11/25 03:45:16 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/pdflib/pdflib-4.0.1-r3.ebuild,v 1.18 2004/01/14 04:42:26 seemant Exp $
DESCRIPTION="A library for generating PDF on the fly"
HOMEPAGE="http://www.pdflib.com/"
diff --git a/media-libs/pdflib/pdflib-5.0.2.ebuild b/media-libs/pdflib/pdflib-5.0.2.ebuild
new file mode 100644
index 000000000000..e84964b98f5d
--- /dev/null
+++ b/media-libs/pdflib/pdflib-5.0.2.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/pdflib/pdflib-5.0.2.ebuild,v 1.1 2004/01/14 04:42:26 seemant Exp $
+
+IUSE="tcltk perl python java"
+MY_PN=${PN/pdf/PDF}-Lite
+MY_P=${MY_PN}-${PV}-Unix-src
+S=${WORKDIR}/${MY_P}
+PYVER="$(/usr/bin/python -V 2>&1 | cut -d ' ' -f 2 | cut -d '.' -f 1,2)"
+DESCRIPTION="A library for generating PDF on the fly"
+HOMEPAGE="http://www.pdflib.com/"
+SRC_URI="http://www.pdflib.com/products/pdflib/download/${MY_P}.tar.gz"
+
+SLOT="5"
+LICENSE="Aladdin"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~arm ~amd64 ~ia64 ~ppc64"
+
+DEPEND=">=sys-apps/sed-4
+ tcltk? ( >=dev-lang/tk-8.2 )
+ perl? ( >=dev-lang/perl-5.1 )
+ python? ( =dev-lang/python-2.2* )
+ java? ( >=virtual/jdk-1.3 )"
+
+src_compile() {
+
+ # fix sandbox violations
+ # NOTE: the basic theory is to not compile pdflib.java during
+ # src_compile() or src_install(), but rather in pkg_postinstall(),
+ # and then install it where it can be found.
+ sed -i \
+ -e "s/all:\t\$(SWIG_LIB) pdflib.jar/all:\t\$(SWIG_LIB)/" \
+ -e "s/install: \$(SWIG_LIB) pdflib.jar/install: \$(SWIG_LIB)/" \
+ ${S}/bind/java/Makefile.in
+
+ local myconf=
+ use tcltk || myconf="--with-tcl=no"
+
+ use perl || myconf="${myconf} --with-perl=no"
+
+ use python \
+ && myconf="${myconf} --with-py=/usr --with-pyincl=/usr/include/python${PYVER}" \
+ || myconf="${myconf} --with-py=no"
+
+ use java \
+ && myconf="${myconf} --with-java=${JAVA_HOME}" \
+ || myconf="${myconf} --with-java=no"
+
+ # libpng-1.2.5 needs to be linked against stdc++ and zlib
+# sed -i -e 's:-lpng:-lpng -lz -lstdc++:' configure
+
+ econf \
+ --enable-cxx \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+
+ # fix sandbox violations
+ # NB: do this *after* build, otherwise we will get linker problems.
+ # all we basically do here is modify the install path for Makefiles that
+ # needs it.
+ sed -i -e "s:LANG_LIBDIR \t\= :LANG_LIBDIR\t\= ${D}:" \
+ ${S}/bind/java/Makefile
+
+ sed -i -e "s:LANG_LIBDIR \t\= :LANG_LIBDIR\t\= ${D}:" \
+ ${S}/bind/perl/Makefile
+
+ sed -i -e "s:LANG_LIBDIR \t\= :LANG_LIBDIR\t\= ${D}:" \
+ ${S}/bind/python/Makefile
+
+ sed -e "s:LANG_LIBDIR \t\= :LANG_LIBDIR\t\= ${D}:" \
+ ${S}/bind/tcl/Makefile
+
+ # ok, this should create the correct lib dirs for perl and python.
+ # yes, i know it is messy, but as i see it, a ebuild should be generic
+ # ... ie. you should be able to just use cp to update it
+ if [ ! -z "`use perl`" ] && [ -x /usr/bin/perl ] ; then
+ local perlmajver="`/usr/bin/perl -v |grep 'This is perl' \
+ |cut -d ' ' -f 4 |cut -d '.' -f 1`"
+ local perlver="`/usr/bin/perl -v |grep 'This is perl' \
+ |cut -d ' ' -f 4`"
+ local perlarch="`/usr/bin/perl -v |grep 'This is perl' \
+ |cut -d ' ' -f 7`"
+ dodir /usr/lib/perl${perlmajver/v/}/site_perl/${perlver/v/}/${perlarch}
+ fi
+ if [ ! -z "`use python`" ] && [ -x /usr/bin/python ] ; then
+ dodir /usr/lib/python${PYVER}/lib-dynload
+ fi
+ #next line required for proper install
+ dodir /usr/bin
+ make prefix=${D}/usr \
+ install || die
+
+ dodoc readme.txt doc/*
+
+ # karltk: This is definitely NOT how it should be done!
+ # we need this to create pdflib.jar (we will not have the source when
+ # this is a binary package ...)
+ if [ "`use java`" ]
+ then
+ insinto /usr/share/pdflib
+ doins ${S}/bind/java/pdflib.java
+
+ mkdir -p com/pdflib
+ mv ${S}/bind/java/pdflib.java com/pdflib
+ javac com/pdflib/pdflib.java
+
+ jar cf pdflib.jar com/pdflib/*.class
+
+ dojar pdflib.jar
+ fi
+}