summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2012-06-14 18:53:37 +0000
committerLuca Barbato <lu_zero@gentoo.org>2012-06-14 18:53:37 +0000
commitdb0fb143b0d5e377f471dbbac5bde2930b264435 (patch)
treeb8296027453047036525bd149e313a70697a0ba1 /media-libs/opus
parentVersion bump (diff)
downloadgentoo-2-db0fb143b0d5e377f471dbbac5bde2930b264435.tar.gz
gentoo-2-db0fb143b0d5e377f471dbbac5bde2930b264435.tar.bz2
gentoo-2-db0fb143b0d5e377f471dbbac5bde2930b264435.zip
New version
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/opus')
-rw-r--r--media-libs/opus/ChangeLog9
-rw-r--r--media-libs/opus/opus-0.9.14.ebuild52
2 files changed, 59 insertions, 2 deletions
diff --git a/media-libs/opus/ChangeLog b/media-libs/opus/ChangeLog
index 427c76b13a25..b9fc9f599bfe 100644
--- a/media-libs/opus/ChangeLog
+++ b/media-libs/opus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/opus
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/opus/ChangeLog,v 1.1 2011/11/19 16:16:02 lu_zero Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/opus/ChangeLog,v 1.2 2012/06/14 18:53:37 lu_zero Exp $
+
+*opus-0.9.14 (14 Jun 2012)
+
+ 14 Jun 2012; Luca Barbato <lu_zero@gentoo.org> +opus-0.9.14.ebuild:
+ New version
*opus-0.9.8 (19 Nov 2011)
diff --git a/media-libs/opus/opus-0.9.14.ebuild b/media-libs/opus/opus-0.9.14.ebuild
new file mode 100644
index 000000000000..6ed374e69e33
--- /dev/null
+++ b/media-libs/opus/opus-0.9.14.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/opus/opus-0.9.14.ebuild,v 1.1 2012/06/14 18:53:37 lu_zero Exp $
+
+EAPI=4
+
+if [[ ${PV} == *9999 ]] ; then
+ SCM="git-2"
+ EGIT_REPO_URI="git://git.opus-codec.org/opus.git"
+fi
+
+inherit autotools ${SCM}
+
+DESCRIPTION="The Opus codec is designed for interactive speech and audio
+transmission over the Internet."
+HOMEPAGE="http://opus-codec.org/"
+SRC_URI="http://downloads.xiph.org/releases/opus/${P}.tar.gz"
+if [[ ${PV} == *9999 ]] ; then
+ SRC_URI=""
+elif [[ ${PV%_p*} != ${PV} ]] ; then # Gentoo snapshot
+ SRC_URI="http://dev.gentoo.org/~lu_zero/${PN}/${P}.tar.xz"
+else # Official release
+ SRC_URI="http://downloads.xiph.org/releases/${PN}/${P}.tar.gz"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc static-libs"
+
+DEPEND="doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ [[ ${PV} == *9999 ]] && eautoreconf
+}
+
+src_configure() {
+ myconf="--enable-custom-modes"
+
+ econf $(use_enable doc) $(use_enable static-libs static) ${myconf}
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete
+ rm -fR "${D}/usr/share/doc/opus"
+ use doc && dohtml -r doc/html/*
+}