summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2012-09-09 09:38:34 +0000
committerLuca Barbato <lu_zero@gentoo.org>2012-09-09 09:38:34 +0000
commit32eb0b173edadd9c90d9c2af854a8ed1e139b5b9 (patch)
treea350efa5525202a34992c299ddb4ebf67ed854d6 /media-libs/opus
parentStable on amd64, x86, ppc and ppc64 wrt bug#433325. (diff)
downloadgentoo-2-32eb0b173edadd9c90d9c2af854a8ed1e139b5b9.tar.gz
gentoo-2-32eb0b173edadd9c90d9c2af854a8ed1e139b5b9.tar.bz2
gentoo-2-32eb0b173edadd9c90d9c2af854a8ed1e139b5b9.zip
New version
(Portage version: 2.2.0_alpha121/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/opus')
-rw-r--r--media-libs/opus/ChangeLog7
-rw-r--r--media-libs/opus/opus-1.0.1_rc3.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/media-libs/opus/ChangeLog b/media-libs/opus/ChangeLog
index cf5ff893ec6a..22fb1ec2442a 100644
--- a/media-libs/opus/ChangeLog
+++ b/media-libs/opus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/opus
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/opus/ChangeLog,v 1.3 2012/07/25 06:20:29 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/opus/ChangeLog,v 1.4 2012/09/09 09:38:34 lu_zero Exp $
+
+*opus-1.0.1_rc3 (09 Sep 2012)
+
+ 09 Sep 2012; Luca Barbato <lu_zero@gentoo.org> +opus-1.0.1_rc3.ebuild:
+ New version
25 Jul 2012; Jeff Horelick <jdhore@gentoo.org> opus-0.9.14.ebuild:
Keyword ~x86 wrt bug 418233
diff --git a/media-libs/opus/opus-1.0.1_rc3.ebuild b/media-libs/opus/opus-1.0.1_rc3.ebuild
new file mode 100644
index 000000000000..d8e85b052884
--- /dev/null
+++ b/media-libs/opus/opus-1.0.1_rc3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/opus/opus-1.0.1_rc3.ebuild,v 1.1 2012/09/09 09:38:34 lu_zero Exp $
+
+EAPI=4
+
+if [[ ${PV} == *9999 ]] ; then
+ SCM="git-2"
+ EGIT_REPO_URI="git://git.opus-codec.org/opus.git"
+fi
+
+inherit autotools ${SCM}
+MY_P=${P/_/-}
+DESCRIPTION="The Opus codec is designed for interactive speech and audio
+transmission over the Internet."
+HOMEPAGE="http://opus-codec.org/"
+SRC_URI="http://downloads.xiph.org/releases/opus/${P}.tar.gz"
+if [[ ${PV} == *9999 ]] ; then
+ SRC_URI=""
+elif [[ ${PV%_p*} != ${PV} ]] ; then # Gentoo snapshot
+ SRC_URI="http://dev.gentoo.org/~lu_zero/${PN}/${P}.tar.xz"
+else # Official release
+ SRC_URI="http://downloads.xiph.org/releases/${PN}/${MY_P}.tar.gz"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc static-libs"
+
+DEPEND="doc? ( app-doc/doxygen )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ [[ ${PV} == *9999 ]] && eautoreconf
+}
+
+src_configure() {
+ myconf="--enable-custom-modes"
+
+ econf $(use_enable doc) $(use_enable static-libs static) ${myconf}
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete
+ rm -fR "${D}/usr/share/doc/opus"
+ use doc && dohtml -r doc/html/*
+}