summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefaan De Roeck <stefaan@gentoo.org>2008-12-21 09:47:41 +0000
committerStefaan De Roeck <stefaan@gentoo.org>2008-12-21 09:47:41 +0000
commitac5bccb25779602766563d0a249ef0e3cfea480a (patch)
tree98f0b8cea090a61c585a4c7ae01ff6ec3cc3ef0d /media-libs/openinventor
parentMasked dev-ruby/ruby-config for removal, bug #251833 (diff)
downloadgentoo-2-ac5bccb25779602766563d0a249ef0e3cfea480a.tar.gz
gentoo-2-ac5bccb25779602766563d0a249ef0e3cfea480a.tar.bz2
gentoo-2-ac5bccb25779602766563d0a249ef0e3cfea480a.zip
Fix bug #251681
(Portage version: 2.2_rc17/cvs/Linux 2.6.27-gentoo-r4 x86_64)
Diffstat (limited to 'media-libs/openinventor')
-rw-r--r--media-libs/openinventor/ChangeLog8
-rw-r--r--media-libs/openinventor/files/bug-251681.patch11
-rw-r--r--media-libs/openinventor/openinventor-2.1.5.10-r3.ebuild105
3 files changed, 123 insertions, 1 deletions
diff --git a/media-libs/openinventor/ChangeLog b/media-libs/openinventor/ChangeLog
index 0d46922ef6dc..43e8d6803c48 100644
--- a/media-libs/openinventor/ChangeLog
+++ b/media-libs/openinventor/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/openinventor
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/openinventor/ChangeLog,v 1.21 2008/11/17 21:16:08 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/openinventor/ChangeLog,v 1.22 2008/12/21 09:47:34 stefaan Exp $
+
+*openinventor-2.1.5.10-r3 (21 Dec 2008)
+
+ 21 Dec 2008; Stefaan De Roeck <stefaan@gentoo.org>
+ +files/bug-251681.patch, +openinventor-2.1.5.10-r3.ebuild:
+ Fix bug #251681
17 Nov 2008; Diego E. Pettenò <flameeyes@gentoo.org>
files/use-byacc.patch:
diff --git a/media-libs/openinventor/files/bug-251681.patch b/media-libs/openinventor/files/bug-251681.patch
new file mode 100644
index 000000000000..2e54cfd07bd8
--- /dev/null
+++ b/media-libs/openinventor/files/bug-251681.patch
@@ -0,0 +1,11 @@
+--- inventor/lib/nodekits/include/Inventor/nodekits/SoSubKit.h.orig 2008-12-21 10:34:25.000000000 +0100
++++ inventor/lib/nodekits/include/Inventor/nodekits/SoSubKit.h 2008-12-21 10:34:33.000000000 +0100
+@@ -192,7 +192,7 @@
+ //
+
+ #define SO_KIT_SOURCE(className) \
+- SO_NODE_SOURCE(className); \
++ SO_NODE_SOURCE(className) \
+ SO__KIT_CATALOG_VARS(className); \
+ SO__KIT_CATALOG_METHODS(className)
+
diff --git a/media-libs/openinventor/openinventor-2.1.5.10-r3.ebuild b/media-libs/openinventor/openinventor-2.1.5.10-r3.ebuild
new file mode 100644
index 000000000000..b7896de5ce45
--- /dev/null
+++ b/media-libs/openinventor/openinventor-2.1.5.10-r3.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/openinventor/openinventor-2.1.5.10-r3.ebuild,v 1.1 2008/12/21 09:47:34 stefaan Exp $
+
+inherit eutils versionator flag-o-matic
+
+MY_PV=$(replace_version_separator 3 '-')
+MY_PN="inventor"
+
+DESCRIPTION="SGI OpenInventor Toolkit and Utilities"
+HOMEPAGE="http://oss.sgi.com/projects/inventor/"
+SRC_URI="ftp://oss.sgi.com/projects/${MY_PN}/download/${MY_PN}-${MY_PV}.src.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="media-libs/mesa
+ x11-libs/openmotif
+ >=media-libs/jpeg-6b
+ >=media-libs/freetype-2.0
+ media-fonts/corefonts"
+DEPEND="dev-util/byacc
+ ${RDEPEND}"
+
+S="${WORKDIR}/${MY_PN}"
+
+pkg_setup() {
+ if ! built_with_use media-libs/mesa motif; then
+ echo
+ eerror "In order to compile openinventor, you need to have media-libs/mesa emerged"
+ eerror "with 'motif' in your USE flags. Please add that flag, re-emerge"
+ eerror "media-libs/mesa, and then emerge openinventor"
+ die "media-libs/mesa is missing motif"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # ordinary yacc fails
+ epatch "${FILESDIR}"/use-byacc.patch
+ # support for amd64, sparc and alpha
+ epatch "${FILESDIR}"/support-archs.patch
+ epatch "${FILESDIR}"/support-sparc.patch
+ # freetype2 wasn't enabled by default
+ epatch "${FILESDIR}"/freetype2-activate.patch
+ # extra #include statement necessary for freetype2
+ epatch "${FILESDIR}"/freetype2-includes.patch
+ # script aiding in manual installation required csh
+ epatch "${FILESDIR}"/no-csh.patch
+ # put files in sane places
+ epatch "${FILESDIR}"/gentoo-paths-v2.patch
+ # fix compilation with gcc-4
+ epatch "${FILESDIR}"/gcc4-support.patch
+ # fix bug #251681
+ epatch "${FILESDIR}"/bug-251681.patch
+}
+
+src_compile() {
+ # -O2 segfaults on amd64 gcc-4.3 with ivman command (bicatali jun.08)
+ replace-flags -O? -O1
+
+ # VLDOPTS: find libraries during linking of executables
+ # VLDDSOOPTS: find libraries during linking of libraries
+ # VCFLAGS / VCXXFLAGS: pass user-chosen compiler flags
+ # OPTIMIZER: do not override user-chosen compiler flags
+ # system
+ emake \
+ VLDOPTS="-L${S}/lib -L${S}/libSoXt" \
+ VLDDSOOPTS="-L${S}/lib -L${S}/libSoXt" \
+ VCFLAGS="${CFLAGS}" VCXXFLAGS="${CXXFLAGS}" \
+ OPTIMIZER= \
+ || die "Build failed"
+
+ # fix RUNME-scripts in the demos directory for new paths
+ sed -i \
+ -e 's:/usr/share/:/usr/share/openinventor/:g' \
+ -e 's:/usr/demos/:/usr/share/openinventor/demos/:g' \
+ $(find apps/demos -name *.RUNME)
+}
+
+src_install() {
+ # IVROOT: serves as DESTDIR
+ # LLDOPTS: delete, so it won't go linking with libraries already on the
+ # system
+ # IVLIBDIR: multilib-strict compliance
+ # LD_LIBRARY_PATH: support executables ran during install
+ emake -j1 \
+ IVROOT="${D}" \
+ LLDOPTS= \
+ IVLIBDIR="${D}usr/$(get_libdir)" \
+ LD_LIBRARY_PATH="${D}usr/$(get_libdir)" \
+ install \
+ || die "Install failed"
+
+ # OpenInventor aliases for TrueType fonts
+ local FONTDIR=/usr/share/fonts/corefonts
+ local ALIASDIR=/usr/share/${PN}/fonts
+ dodir ${ALIASDIR}
+ dosym ${FONTDIR}/times.ttf ${ALIASDIR}/Times-Roman
+ dosym ${FONTDIR}/arial.ttf ${ALIASDIR}/Helvetica
+ dosym ${FONTDIR}/cour.ttf ${ALIASDIR}/Utopia-Regular
+}