summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-02-15 21:55:46 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-02-15 21:55:46 +0000
commit4f25b9e7241e447f397bdc3e286dffd553a2a31e (patch)
treeb4b1cf7a109c0d01326360467e9993c225d09eb4 /media-libs/opencv
parentAdding gcc-4.3 patch per bug 251448. Thanks to Gene Seto <geneseto@hotmail.co... (diff)
downloadgentoo-2-4f25b9e7241e447f397bdc3e286dffd553a2a31e.tar.gz
gentoo-2-4f25b9e7241e447f397bdc3e286dffd553a2a31e.tar.bz2
gentoo-2-4f25b9e7241e447f397bdc3e286dffd553a2a31e.zip
Fixing py bindings failure, patch by John Keeping, fixes #258652
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/opencv')
-rw-r--r--media-libs/opencv/ChangeLog9
-rw-r--r--media-libs/opencv/files/opencv-1.0.0-fix-swig.patch9
-rw-r--r--media-libs/opencv/opencv-1.0.0-r1.ebuild6
3 files changed, 19 insertions, 5 deletions
diff --git a/media-libs/opencv/ChangeLog b/media-libs/opencv/ChangeLog
index 4b9e34261b47..f803ad8c4d83 100644
--- a/media-libs/opencv/ChangeLog
+++ b/media-libs/opencv/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/opencv
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/opencv/ChangeLog,v 1.10 2008/12/27 01:27:46 gentoofan23 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/opencv/ChangeLog,v 1.11 2009/02/15 21:55:46 patrick Exp $
+
+ 15 Feb 2009; Patrick Lauer <patrick@gentoo.org>
+ +files/opencv-1.0.0-fix-swig.patch, opencv-1.0.0-r1.ebuild:
+ Fixing small error in the building of py bindings. Patch from John
+ Keeping, closes #258652
27 Dec 2008; Thomas Anderson <gentoofan23@gentoo.org> metadata.xml,
opencv-1.0.0-r1.ebuild:
diff --git a/media-libs/opencv/files/opencv-1.0.0-fix-swig.patch b/media-libs/opencv/files/opencv-1.0.0-fix-swig.patch
new file mode 100644
index 000000000000..205edf3439b6
--- /dev/null
+++ b/media-libs/opencv/files/opencv-1.0.0-fix-swig.patch
@@ -0,0 +1,9 @@
+--- interfaces/swig/python/pyhelpers.i.orig 2009-02-11 22:24:10.000000000 +0000
++++ interfaces/swig/python/pyhelpers.i 2009-02-11 22:22:15.000000000 +0000
+@@ -1,4 +1,6 @@
+ /* These functions need the SWIG_* functions defined in the wrapper */
++%include "pyname_compat.i"
++
+ %{
+
+ static CvArr * PyObject_to_CvArr(PyObject * obj, bool * freearg);
diff --git a/media-libs/opencv/opencv-1.0.0-r1.ebuild b/media-libs/opencv/opencv-1.0.0-r1.ebuild
index ee03692b2c67..bdd55d7ef608 100644
--- a/media-libs/opencv/opencv-1.0.0-r1.ebuild
+++ b/media-libs/opencv/opencv-1.0.0-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/opencv/opencv-1.0.0-r1.ebuild,v 1.5 2008/12/27 01:27:46 gentoofan23 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/opencv/opencv-1.0.0-r1.ebuild,v 1.6 2009/02/15 21:55:46 patrick Exp $
EAPI="1"
inherit eutils flag-o-matic autotools
@@ -46,7 +46,7 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-cvcapffmpegundefinedsymbols.patch
epatch "${FILESDIR}"/${P}-ffmpeg-0.4.9_p20080326.patch
epatch "${FILESDIR}"/${P}-swiginvalidlinkingoptions.patch
-
+ epatch "${FILESDIR}"/${P}-fix-swig.patch
eautoreconf || die "eautoreconf failed"
}