summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-02-11 04:38:37 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-02-11 04:38:37 +0000
commite0015e82ca607a9541d4e0916ec9ac3a9fd2a691 (patch)
treef0e1eaa2115a412f0838a194412289876fd48444 /media-libs/mesa
parentBump, improves error handling. (diff)
downloadgentoo-2-e0015e82ca607a9541d4e0916ec9ac3a9fd2a691.tar.gz
gentoo-2-e0015e82ca607a9541d4e0916ec9ac3a9fd2a691.tar.bz2
gentoo-2-e0015e82ca607a9541d4e0916ec9ac3a9fd2a691.zip
switch to xorg-x11 and back if necessary, bug #374647 comment 11
(Portage version: 2.2.0_alpha85/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/mesa')
-rw-r--r--media-libs/mesa/ChangeLog6
-rw-r--r--media-libs/mesa/mesa-8.0.ebuild10
2 files changed, 14 insertions, 2 deletions
diff --git a/media-libs/mesa/ChangeLog b/media-libs/mesa/ChangeLog
index 317b42b4cdce..08fe95dd6117 100644
--- a/media-libs/mesa/ChangeLog
+++ b/media-libs/mesa/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/mesa
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/ChangeLog,v 1.378 2012/02/10 18:44:37 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/ChangeLog,v 1.379 2012/02/11 04:38:37 chithanh Exp $
+
+ 11 Feb 2012; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ mesa-8.0.ebuild:
+ switch to xorg-x11 and back if necessary, bug #374647 comment 11
*mesa-8.0 (10 Feb 2012)
diff --git a/media-libs/mesa/mesa-8.0.ebuild b/media-libs/mesa/mesa-8.0.ebuild
index 9d2ff2dc17f3..ebd21f47934d 100644
--- a/media-libs/mesa/mesa-8.0.ebuild
+++ b/media-libs/mesa/mesa-8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-8.0.ebuild,v 1.1 2012/02/10 18:44:37 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-8.0.ebuild,v 1.2 2012/02/11 04:38:37 chithanh Exp $
EAPI=4
@@ -326,6 +326,14 @@ pkg_postinst() {
# Switch to the xorg implementation.
echo
eselect opengl set --use-old ${OPENGL_DIR}
+
+ # switch to xorg-x11 and back if necessary, bug #374647 comment 11
+ OLD_IMPLEM="$(eselect opengl show)"
+ if [[ ${OPENGL_DIR}x != ${OLD_IMPLEM}x ]]; then
+ eselect opengl set ${OPENGL_DIR}
+ eselect opengl set ${OLD_IMPLEM}
+ fi
+
# Select classic/gallium drivers
if use classic || use gallium; then
eselect mesa set --auto