summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2005-08-22 06:00:32 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2005-08-22 06:00:32 +0000
commitaf6f4ee403f1bd6cbd5d900118ddc890085a1452 (patch)
treec9117c11b290e48b7b2e0b2c75fc9fe222a9a048 /media-libs/mesa
parent~amd64 keyword added (diff)
downloadgentoo-2-af6f4ee403f1bd6cbd5d900118ddc890085a1452.tar.gz
gentoo-2-af6f4ee403f1bd6cbd5d900118ddc890085a1452.tar.bz2
gentoo-2-af6f4ee403f1bd6cbd5d900118ddc890085a1452.zip
Split out an arch-specific variable DRI_DRIVERS_${ARCH} for defining which drivers to build. Put it up at the top, to try separating data from code. Perhaps doing something similar in pkg_setup(), but having if...elif and just DRI_DRIVERS, would work reasonably, but it doesn't isolate the data as well.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'media-libs/mesa')
-rw-r--r--media-libs/mesa/ChangeLog9
-rw-r--r--media-libs/mesa/mesa-6.3.2.ebuild9
2 files changed, 15 insertions, 3 deletions
diff --git a/media-libs/mesa/ChangeLog b/media-libs/mesa/ChangeLog
index 70a25e301157..9a7fe5589e16 100644
--- a/media-libs/mesa/ChangeLog
+++ b/media-libs/mesa/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/mesa
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/ChangeLog,v 1.34 2005/08/22 05:54:33 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/ChangeLog,v 1.35 2005/08/22 06:00:32 spyderous Exp $
+
+ 22 Aug 2005; Donnie Berkholz <spyderous@gentoo.org>; mesa-6.3.2.ebuild:
+ Split out an arch-specific variable DRI_DRIVERS_${ARCH} for defining which
+ drivers to build. Put it up at the top, to try separating data from code.
+ Perhaps doing something similar in pkg_setup(), but having if...elif and
+ just DRI_DRIVERS, would work reasonably, but it doesn't isolate the data as
+ well.
22 Aug 2005; Donnie Berkholz <spyderous@gentoo.org>; mesa-6.3.2.ebuild:
Move EXTRA_LIB_PATH blanking out from within a sparc block, because it
diff --git a/media-libs/mesa/mesa-6.3.2.ebuild b/media-libs/mesa/mesa-6.3.2.ebuild
index 2e86e273d96e..61d6e6d1b9b9 100644
--- a/media-libs/mesa/mesa-6.3.2.ebuild
+++ b/media-libs/mesa/mesa-6.3.2.ebuild
@@ -1,9 +1,14 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-6.3.2.ebuild,v 1.2 2005/08/22 05:54:33 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-6.3.2.ebuild,v 1.3 2005/08/22 06:00:32 spyderous Exp $
inherit eutils toolchain-funcs multilib
+# Arches that need to define their own sets of DRI drivers, please do so in
+# a variable up here, and use that variable below. This helps us to separate the
+# data from the code.
+DRI_DRIVERS_SPARC="ffb mach64 mga radeon savage"
+
OPENGL_DIR="xorg-x11"
MY_PN="${PN/m/M}"
@@ -65,7 +70,7 @@ src_unpack() {
# Set up linux-dri configs
if use sparc; then
einfo "Define the sparc DRI drivers."
- echo "DRI_DIRS = ffb mach64 mga radeon savage" >> ${HOSTCONF}
+ echo "DRI_DIRS = ${DRI_DRIVERS_SPARC}" >> ${HOSTCONF}
einfo "Explicitly note that sparc assembly code is not working."
echo "ASM_FLAGS =" >> ${HOSTCONF}
echo "ASM_SOURCES =" >> ${HOSTCONF}