summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2009-12-22 13:50:34 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2009-12-22 13:50:34 +0000
commit95a72b1c52488f1e16a35f8d7a68588cddc32e98 (patch)
tree2947834d85681f3f549d1f184a473e5c0cbc3236 /media-libs/mesa
parentVersion bump #297819 by Alon Bar-Lev. (diff)
downloadgentoo-2-95a72b1c52488f1e16a35f8d7a68588cddc32e98.tar.gz
gentoo-2-95a72b1c52488f1e16a35f8d7a68588cddc32e98.tar.bz2
gentoo-2-95a72b1c52488f1e16a35f8d7a68588cddc32e98.zip
Bump to 7.6.1 (with a patch to fix bug 297891) and 7.7 (fixes bug 297807)
(Portage version: 2.1.7.15/cvs/Linux i686)
Diffstat (limited to 'media-libs/mesa')
-rw-r--r--media-libs/mesa/ChangeLog10
-rw-r--r--media-libs/mesa/files/0001-st-xorg-Adopt-to-new-dirty-clip-rect-type.patch33
-rw-r--r--media-libs/mesa/mesa-7.6.1.ebuild245
-rw-r--r--media-libs/mesa/mesa-7.7.ebuild237
4 files changed, 524 insertions, 1 deletions
diff --git a/media-libs/mesa/ChangeLog b/media-libs/mesa/ChangeLog
index 0aaf74044452..0f2995ef37f0 100644
--- a/media-libs/mesa/ChangeLog
+++ b/media-libs/mesa/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-libs/mesa
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/ChangeLog,v 1.248 2009/12/16 18:16:36 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/ChangeLog,v 1.249 2009/12/22 13:50:33 nirbheek Exp $
+
+*mesa-7.7 (22 Dec 2009)
+*mesa-7.6.1 (22 Dec 2009)
+
+ 22 Dec 2009; Nirbheek Chauhan <nirbheek@gentoo.org>
+ +files/0001-st-xorg-Adopt-to-new-dirty-clip-rect-type.patch,
+ +mesa-7.6.1.ebuild, +mesa-7.7.ebuild:
+ Bump to 7.6.1 (with a patch to fix bug 297891) and 7.7 (fixes bug 297807)
16 Dec 2009; Tomáš Chvátal <scarabeus@gentoo.org> mesa-7.7_rc3.ebuild:
Fix S location.
diff --git a/media-libs/mesa/files/0001-st-xorg-Adopt-to-new-dirty-clip-rect-type.patch b/media-libs/mesa/files/0001-st-xorg-Adopt-to-new-dirty-clip-rect-type.patch
new file mode 100644
index 000000000000..b76725f6a077
--- /dev/null
+++ b/media-libs/mesa/files/0001-st-xorg-Adopt-to-new-dirty-clip-rect-type.patch
@@ -0,0 +1,33 @@
+From 8a1f239ca9ccb61cd6713d1138e24492c84163c5 Mon Sep 17 00:00:00 2001
+From: Jakob Bornecrantz <jakob@vmware.com>
+Date: Tue, 27 Oct 2009 17:35:06 +0100
+Subject: [PATCH] st/xorg: Adopt to new dirty clip rect type
+
+---
+ src/gallium/state_trackers/xorg/xorg_driver.c | 9 +++++----
+ 1 files changed, 5 insertions(+), 4 deletions(-)
+
+diff --git a/src/gallium/state_trackers/xorg/xorg_driver.c b/src/gallium/state_trackers/xorg/xorg_driver.c
+index 847647c..26cf2dd 100644
+--- a/src/gallium/state_trackers/xorg/xorg_driver.c
++++ b/src/gallium/state_trackers/xorg/xorg_driver.c
+@@ -484,11 +484,12 @@ static void xorgBlockHandler(int i, pointer blockData, pointer pTimeout,
+ BoxPtr rect = REGION_RECTS(dirty);
+ int i;
+
++ /* XXX no need for copy? */
+ for (i = 0; i < num_cliprects; i++, rect++) {
+- clip[i].x = rect->x1;
+- clip[i].y = rect->y1;
+- clip[i].width = rect->x2 - rect->x1;
+- clip[i].height = rect->y2 - rect->y1;
++ clip[i].x1 = rect->x1;
++ clip[i].y1 = rect->y1;
++ clip[i].x2 = rect->x2;
++ clip[i].y2 = rect->y2;
+ }
+
+ /* TODO query connector property to see if this is needed */
+--
+1.6.4.4
+
diff --git a/media-libs/mesa/mesa-7.6.1.ebuild b/media-libs/mesa/mesa-7.6.1.ebuild
new file mode 100644
index 000000000000..d519748293cf
--- /dev/null
+++ b/media-libs/mesa/mesa-7.6.1.ebuild
@@ -0,0 +1,245 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-7.6.1.ebuild,v 1.1 2009/12/22 13:50:33 nirbheek Exp $
+
+EAPI="2"
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/mesa/mesa"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git"
+ EXPERIMENTAL="true"
+ IUSE_VIDEO_CARDS_UNSTABLE="video_cards_nouveau"
+fi
+
+inherit autotools multilib flag-o-matic ${GIT_ECLASS} portability
+
+OPENGL_DIR="xorg-x11"
+
+MY_PN="${PN/m/M}"
+MY_P="${MY_PN}-${PV/_*/}"
+MY_SRC_P="${MY_PN}Lib-${PV/_/-}"
+DESCRIPTION="OpenGL-like graphic library for Linux"
+HOMEPAGE="http://mesa3d.sourceforge.net/"
+
+#SRC_PATCHES="mirror://gentoo/${P}-gentoo-patches-01.tar.bz2"
+if [[ $PV = 9999* ]]; then
+ SRC_URI="${SRC_PATCHES}"
+else
+ SRC_URI="ftp://ftp.freedesktop.org/pub/mesa/${PV/_rc*/}/${MY_SRC_P}.tar.bz2
+ ${SRC_PATCHES}"
+fi
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+
+IUSE_VIDEO_CARDS="${IUSE_VIDEO_CARDS_UNSTABLE}
+ video_cards_intel
+ video_cards_mach64
+ video_cards_mga
+ video_cards_none
+ video_cards_r128
+ video_cards_radeon
+ video_cards_radeonhd
+ video_cards_s3virge
+ video_cards_savage
+ video_cards_sis
+ video_cards_sunffb
+ video_cards_tdfx
+ video_cards_trident
+ video_cards_via"
+IUSE="${IUSE_VIDEO_CARDS}
+ debug gallium motif +nptl pic +xcb kernel_FreeBSD"
+
+# keep correct libdrm and dri2proto dep
+# keep blocks in rdepend for binpkg
+RDEPEND="!<x11-base/xorg-server-1.7
+ !<=x11-proto/xf86driproto-2.0.3
+ >=app-admin/eselect-opengl-1.1.1-r2
+ dev-libs/expat
+ >=x11-libs/libdrm-2.4.17
+ x11-libs/libICE
+ x11-libs/libX11[xcb?]
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXxf86vm
+ motif? ( x11-libs/openmotif )
+"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ x11-misc/makedepend
+ >=x11-proto/dri2proto-1.99.3
+ >=x11-proto/glproto-1.4.8
+ x11-proto/inputproto
+ >=x11-proto/xextproto-7.0.99.1
+ x11-proto/xf86driproto
+ x11-proto/xf86vidmodeproto
+"
+
+S="${WORKDIR}/${MY_P}"
+
+# Think about: ggi, svga, fbcon, no-X configs
+
+pkg_setup() {
+ # gcc 4.2 has buggy ivopts
+ if [[ $(gcc-version) = "4.2" ]]; then
+ append-flags -fno-ivopts
+ fi
+
+ # recommended by upstream
+ append-flags -ffast-math
+}
+
+src_unpack() {
+ [[ $PV = 9999* ]] && git_src_unpack || unpack ${A}
+}
+
+src_prepare() {
+ # apply patches
+ if [[ ${PV} != 9999* && -n ${SRC_PATCHES} ]]; then
+ EPATCH_FORCE="yes" \
+ EPATCH_SOURCE="${WORKDIR}/patches" \
+ EPATCH_SUFFIX="patch" \
+ epatch
+ fi
+
+ # The drmClip interface changed with libdrm-2.4.17
+ # bug 297891 (patch from upstream git)
+ epatch "${FILESDIR}/0001-st-xorg-Adopt-to-new-dirty-clip-rect-type.patch"
+
+ # FreeBSD 6.* doesn't have posix_memalign().
+ [[ ${CHOST} == *-freebsd6.* ]] && \
+ sed -i -e "s/-DHAVE_POSIX_MEMALIGN//" configure.ac
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf r600
+
+ # Configurable DRI drivers
+ driver_enable swrast
+ driver_enable video_cards_intel i810 i915 i965
+ driver_enable video_cards_mach64 mach64
+ driver_enable video_cards_mga mga
+ driver_enable video_cards_r128 r128
+ # ATI has two implementations as video_cards
+ driver_enable video_cards_radeon radeon r200 r300 r600
+ driver_enable video_cards_radeonhd r300 r600
+ driver_enable video_cards_s3virge s3v
+ driver_enable video_cards_savage savage
+ driver_enable video_cards_sis sis
+ driver_enable video_cards_sunffb ffb
+ driver_enable video_cards_tdfx tdfx
+ driver_enable video_cards_trident trident
+ driver_enable video_cards_via unichrome
+
+ # all live (experimental) stuff is wrapped around with experimental variable
+ # so the users cant get to this parts even with enabled useflags (downgrade
+ # from live to stable for example)
+ if [[ -n ${EXPERIMENTAL} ]]; then
+ # nouveau works only with gallium
+ use gallium && myconf="${myconf} $(use_enable video_cards_nouveau gallium-nouveau)"
+ if use video_cards_nouveau && ! use gallium ; then
+ elog "Nouveau driver is available only via gallium interface."
+ elog "Enable gallium useflag if you want to use nouveau."
+ echo
+ fi
+ fi
+
+ myconf="${myconf} $(use_enable gallium)"
+ if use gallium; then
+ elog "Warning gallium interface is highly experimental so use"
+ elog "it only if you feel really really brave."
+ elog
+ elog "Intel: works only i915."
+ elog "Nouveau: only available implementation, so no other choice"
+ elog "Radeon: implementation up to the r500."
+ echo
+ myconf="${myconf}
+ --with-state-trackers=glx,dri,egl,xorg
+ $(use_enable video_cards_nouveau gallium-nouveau)
+ $(use_enable video_cards_intel gallium-intel)"
+ if ! use video_cards_radeon && ! use video_cards_radeonhd; then
+ myconf="${myconf} --disable-gallium-radeon"
+ else
+ myconf="${myconf} --enable-gallium-radeon"
+ fi
+ fi
+
+ # Deactivate assembly code for pic build
+ myconf="${myconf} $(use_enable !pic asm)"
+
+ # --with-driver=dri|xlib|osmesa ; might get changed later to something
+ # else than dri
+ econf \
+ --with-driver=dri \
+ --disable-glut \
+ --without-demos \
+ $(use_enable debug) \
+ $(use_enable motif glw) \
+ $(use_enable motif) \
+ $(use_enable nptl glx-tls) \
+ $(use_enable xcb) \
+ --with-dri-drivers=${DRI_DRIVERS} \
+ ${myconf}
+}
+
+src_install() {
+ dodir /usr
+ emake DESTDIR="${D}" install || die "Installation failed"
+
+ # Remove redundant headers
+ # GLUT thing
+ rm -f "${D}"/usr/include/GL/glut*.h || die "Removing glut include failed."
+ # Glew includes
+ rm -f "${D}"/usr/include/GL/{glew,glxew,wglew}.h \
+ || die "Removing glew includes failed."
+
+ # Move libGL and others from /usr/lib to /usr/lib/opengl/blah/lib
+ # because user can eselect desired GL provider.
+ ebegin "Moving libGL and friends for dynamic switching"
+ dodir /usr/$(get_libdir)/opengl/${OPENGL_DIR}/{lib,extensions,include}
+ local x
+ for x in "${D}"/usr/$(get_libdir)/libGL.{la,a,so*}; do
+ if [ -f ${x} -o -L ${x} ]; then
+ mv -f ${x} "${D}"/usr/$(get_libdir)/opengl/${OPENGL_DIR}/lib \
+ || die "Failed to move ${x}"
+ fi
+ done
+ for x in "${D}"/usr/include/GL/{gl.h,glx.h,glext.h,glxext.h}; do
+ if [ -f ${x} -o -L ${x} ]; then
+ mv -f ${x} "${D}"/usr/$(get_libdir)/opengl/${OPENGL_DIR}/include \
+ || die "Failed to move ${x}"
+ fi
+ done
+ eend $?
+}
+
+pkg_postinst() {
+ # Switch to the xorg implementation.
+ echo
+ eselect opengl set --use-old ${OPENGL_DIR}
+}
+
+# $1 - VIDEO_CARDS flag
+# other args - names of DRI drivers to enable
+driver_enable() {
+ case $# in
+ # for enabling unconditionally
+ 1)
+ DRI_DRIVERS="${DRI_DRIVERS},$1"
+ ;;
+ *)
+ if use $1; then
+ shift
+ for i in $@; do
+ DRI_DRIVERS="${DRI_DRIVERS},${i}"
+ done
+ fi
+ ;;
+ esac
+}
diff --git a/media-libs/mesa/mesa-7.7.ebuild b/media-libs/mesa/mesa-7.7.ebuild
new file mode 100644
index 000000000000..64ccf01f0c26
--- /dev/null
+++ b/media-libs/mesa/mesa-7.7.ebuild
@@ -0,0 +1,237 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-7.7.ebuild,v 1.1 2009/12/22 13:50:33 nirbheek Exp $
+
+EAPI="2"
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/mesa/mesa"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git"
+ EXPERIMENTAL="true"
+ IUSE_VIDEO_CARDS_UNSTABLE="video_cards_nouveau"
+fi
+
+inherit autotools multilib flag-o-matic ${GIT_ECLASS} portability
+
+OPENGL_DIR="xorg-x11"
+
+MY_PN="${PN/m/M}"
+MY_P="${MY_PN}-${PV/_*}"
+MY_SRC_P="${MY_PN}Lib-${PV/_/-}"
+DESCRIPTION="OpenGL-like graphic library for Linux"
+HOMEPAGE="http://mesa3d.sourceforge.net/"
+
+#SRC_PATCHES="mirror://gentoo/${P}-gentoo-patches-01.tar.bz2"
+if [[ $PV = 9999* ]]; then
+ SRC_URI="${SRC_PATCHES}"
+else
+ SRC_URI="ftp://ftp.freedesktop.org/pub/mesa/${PV/_rc*/}/${MY_SRC_P}.tar.bz2
+ ${SRC_PATCHES}"
+fi
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+
+IUSE_VIDEO_CARDS="${IUSE_VIDEO_CARDS_UNSTABLE}
+ video_cards_intel
+ video_cards_mach64
+ video_cards_mga
+ video_cards_none
+ video_cards_r128
+ video_cards_radeon
+ video_cards_radeonhd
+ video_cards_savage
+ video_cards_sis
+ video_cards_sunffb
+ video_cards_tdfx
+ video_cards_via"
+IUSE="${IUSE_VIDEO_CARDS}
+ debug gallium motif +nptl pic +xcb kernel_FreeBSD"
+
+# keep correct libdrm and dri2proto dep
+# keep blocks in rdepend for binpkg
+RDEPEND="!<x11-base/xorg-server-1.7
+ !<=x11-proto/xf86driproto-2.0.3
+ >=app-admin/eselect-opengl-1.1.1-r2
+ dev-libs/expat
+ >=x11-libs/libdrm-2.4.17
+ x11-libs/libICE
+ x11-libs/libX11[xcb?]
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXxf86vm
+ motif? ( x11-libs/openmotif )
+"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ x11-misc/makedepend
+ >=x11-proto/dri2proto-1.99.3
+ >=x11-proto/glproto-1.4.8
+ x11-proto/inputproto
+ >=x11-proto/xextproto-7.0.99.1
+ x11-proto/xf86driproto
+ x11-proto/xf86vidmodeproto
+"
+
+S="${WORKDIR}/${MY_P}"
+
+# Think about: ggi, svga, fbcon, no-X configs
+
+pkg_setup() {
+ # gcc 4.2 has buggy ivopts
+ if [[ $(gcc-version) = "4.2" ]]; then
+ append-flags -fno-ivopts
+ fi
+
+ # recommended by upstream
+ append-flags -ffast-math
+}
+
+src_unpack() {
+ [[ $PV = 9999* ]] && git_src_unpack || unpack ${A}
+}
+
+src_prepare() {
+ # apply patches
+ if [[ ${PV} != 9999* && -n ${SRC_PATCHES} ]]; then
+ EPATCH_FORCE="yes" \
+ EPATCH_SOURCE="${WORKDIR}/patches" \
+ EPATCH_SUFFIX="patch" \
+ epatch
+ fi
+ # FreeBSD 6.* doesn't have posix_memalign().
+ [[ ${CHOST} == *-freebsd6.* ]] && \
+ sed -i -e "s/-DHAVE_POSIX_MEMALIGN//" configure.ac
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf r600
+
+ # Configurable DRI drivers
+ driver_enable swrast
+ driver_enable video_cards_intel i810 i915 i965
+ driver_enable video_cards_mach64 mach64
+ driver_enable video_cards_mga mga
+ driver_enable video_cards_r128 r128
+ # ATI has two implementations as video_cards
+ driver_enable video_cards_radeon radeon r200 r300 r600
+ driver_enable video_cards_radeonhd r300 r600
+ driver_enable video_cards_savage savage
+ driver_enable video_cards_sis sis
+ driver_enable video_cards_sunffb ffb
+ driver_enable video_cards_tdfx tdfx
+ driver_enable video_cards_via unichrome
+
+ # all live (experimental) stuff is wrapped around with experimental variable
+ # so the users cant get to this parts even with enabled useflags (downgrade
+ # from live to stable for example)
+ if [[ -n ${EXPERIMENTAL} ]]; then
+ # nouveau works only with gallium
+ use gallium && myconf="${myconf} $(use_enable video_cards_nouveau gallium-nouveau)"
+ if use video_cards_nouveau && ! use gallium ; then
+ elog "Nouveau driver is available only via gallium interface."
+ elog "Enable gallium useflag if you want to use nouveau."
+ echo
+ fi
+ fi
+
+ myconf="${myconf} $(use_enable gallium)"
+ if use gallium; then
+ elog "Warning gallium interface is highly experimental so use"
+ elog "it only if you feel really really brave."
+ elog
+ elog "Intel: works only i915."
+ elog "Nouveau: only available implementation, so no other choice"
+ elog "Radeon: implementation up to the r500."
+ echo
+ myconf="${myconf}
+ --with-state-trackers=glx,dri,egl,xorg
+ $(use_enable video_cards_nouveau gallium-nouveau)
+ $(use_enable video_cards_intel gallium-intel)"
+ if ! use video_cards_radeon && ! use video_cards_radeonhd; then
+ myconf="${myconf} --disable-gallium-radeon"
+ else
+ myconf="${myconf} --enable-gallium-radeon"
+ fi
+ fi
+
+ # Deactivate assembly code for pic build
+ myconf="${myconf} $(use_enable !pic asm)"
+
+ # --with-driver=dri|xlib|osmesa ; might get changed later to something
+ # else than dri
+ econf \
+ --with-driver=dri \
+ --disable-glut \
+ --without-demos \
+ $(use_enable debug) \
+ $(use_enable motif glw) \
+ $(use_enable motif) \
+ $(use_enable nptl glx-tls) \
+ $(use_enable xcb) \
+ --disable-gallium-svga \
+ --with-dri-drivers=${DRI_DRIVERS} \
+ ${myconf}
+}
+
+src_install() {
+ dodir /usr
+ emake DESTDIR="${D}" install || die "Installation failed"
+
+ # Remove redundant headers
+ # GLUT thing
+ rm -f "${D}"/usr/include/GL/glut*.h || die "Removing glut include failed."
+ # Glew includes
+ rm -f "${D}"/usr/include/GL/{glew,glxew,wglew}.h \
+ || die "Removing glew includes failed."
+
+ # Move libGL and others from /usr/lib to /usr/lib/opengl/blah/lib
+ # because user can eselect desired GL provider.
+ ebegin "Moving libGL and friends for dynamic switching"
+ dodir /usr/$(get_libdir)/opengl/${OPENGL_DIR}/{lib,extensions,include}
+ local x
+ for x in "${D}"/usr/$(get_libdir)/libGL.{la,a,so*}; do
+ if [ -f ${x} -o -L ${x} ]; then
+ mv -f ${x} "${D}"/usr/$(get_libdir)/opengl/${OPENGL_DIR}/lib \
+ || die "Failed to move ${x}"
+ fi
+ done
+ for x in "${D}"/usr/include/GL/{gl.h,glx.h,glext.h,glxext.h}; do
+ if [ -f ${x} -o -L ${x} ]; then
+ mv -f ${x} "${D}"/usr/$(get_libdir)/opengl/${OPENGL_DIR}/include \
+ || die "Failed to move ${x}"
+ fi
+ done
+ eend $?
+}
+
+pkg_postinst() {
+ # Switch to the xorg implementation.
+ echo
+ eselect opengl set --use-old ${OPENGL_DIR}
+}
+
+# $1 - VIDEO_CARDS flag
+# other args - names of DRI drivers to enable
+driver_enable() {
+ case $# in
+ # for enabling unconditionally
+ 1)
+ DRI_DRIVERS="${DRI_DRIVERS},$1"
+ ;;
+ *)
+ if use $1; then
+ shift
+ for i in $@; do
+ DRI_DRIVERS="${DRI_DRIVERS},${i}"
+ done
+ fi
+ ;;
+ esac
+}