summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-01-17 21:56:29 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-01-17 21:56:29 +0000
commitfb3efffd73c99c5a4eae52cdb038b40209b1bcb0 (patch)
treef31ed40dc4e990a6a8d88ed546afa37a42bb2f04 /media-libs/mediastreamer
parentPut 196 back in tree for sys-apps/systemd. If you don't use systemd, you shou... (diff)
downloadgentoo-2-fb3efffd73c99c5a4eae52cdb038b40209b1bcb0.tar.gz
gentoo-2-fb3efffd73c99c5a4eae52cdb038b40209b1bcb0.tar.bz2
gentoo-2-fb3efffd73c99c5a4eae52cdb038b40209b1bcb0.zip
Fix build with latest ffmpeg. By Reuben Martin, bug #445168.
(Portage version: 2.2.0_alpha154/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-libs/mediastreamer')
-rw-r--r--media-libs/mediastreamer/ChangeLog8
-rw-r--r--media-libs/mediastreamer/files/mediastreamer-2.8.2-ffmpeg-1.0.patch59
-rw-r--r--media-libs/mediastreamer/mediastreamer-2.8.2.ebuild7
3 files changed, 69 insertions, 5 deletions
diff --git a/media-libs/mediastreamer/ChangeLog b/media-libs/mediastreamer/ChangeLog
index f942008a8bd2..731a9f042d93 100644
--- a/media-libs/mediastreamer/ChangeLog
+++ b/media-libs/mediastreamer/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/mediastreamer
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mediastreamer/ChangeLog,v 1.60 2012/12/17 17:34:55 ago Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mediastreamer/ChangeLog,v 1.61 2013/01/17 21:56:29 aballier Exp $
+
+ 17 Jan 2013; Alexis Ballier <aballier@gentoo.org> mediastreamer-2.8.2.ebuild,
+ +files/mediastreamer-2.8.2-ffmpeg-1.0.patch:
+ Fix build with latest ffmpeg. By Reuben Martin, bug #445168.
17 Dec 2012; Agostino Sarubbo <ago@gentoo.org> mediastreamer-2.8.2.ebuild:
Add ~ppc64, wrt bug #443964
diff --git a/media-libs/mediastreamer/files/mediastreamer-2.8.2-ffmpeg-1.0.patch b/media-libs/mediastreamer/files/mediastreamer-2.8.2-ffmpeg-1.0.patch
new file mode 100644
index 000000000000..293e6e78dcab
--- /dev/null
+++ b/media-libs/mediastreamer/files/mediastreamer-2.8.2-ffmpeg-1.0.patch
@@ -0,0 +1,59 @@
+https://bugs.gentoo.org/show_bug.cgi?id=445168
+
+commit f586917ea4d66f9ba8910f0967a8830e54d50784
+Author: Yann Diorcet <yann.diorcet@belledonne-communications.com>
+Date: Tue Jun 5 11:07:48 2012 +0200
+
+ Fixes for new versions of ffmpeg
+
+diff --git a/src/h264dec.c b/src/h264dec.c
+index c4a84ee..5229b5e 100644
+--- a/src/h264dec.c
++++ b/src/h264dec.c
+@@ -45,7 +45,9 @@ typedef struct _DecData{
+ static void ffmpeg_init(){
+ static bool_t done=FALSE;
+ if (!done){
++#ifdef FF_API_AVCODEC_INIT
+ avcodec_init();
++#endif
+ avcodec_register_all();
+ done=TRUE;
+ }
+diff --git a/src/videoenc.c b/src/videoenc.c
+index 21d016f..fb35760 100644
+--- a/src/videoenc.c
++++ b/src/videoenc.c
+@@ -39,6 +39,10 @@ Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
+ static bool_t avcodec_initialized=FALSE;
+
++#ifndef FF_I_TYPE
++#define FF_I_TYPE AV_PICTURE_TYPE_I
++#endif
++
+ #ifdef ENABLE_LOG_FFMPEG
+
+ void ms_ffmpeg_log_callback(void* ptr, int level, const char* fmt, va_list vl)
+@@ -53,7 +57,9 @@ void ms_ffmpeg_log_callback(void* ptr, int level, const char* fmt, va_list vl)
+
+ void ms_ffmpeg_check_init(){
+ if(!avcodec_initialized){
++#ifdef FF_API_AVCODEC_INIT
+ avcodec_init();
++#endif
+ avcodec_register_all();
+ avcodec_initialized=TRUE;
+ #ifdef ENABLE_LOG_FFMPEG
+@@ -300,10 +306,10 @@ static void prepare_h263(EncState *s){
+ if (s->profile==0){
+ s->codec=CODEC_ID_H263;
+ }else{
++ /*
+ c->flags|=CODEC_FLAG_H263P_UMV;
+ c->flags|=CODEC_FLAG_AC_PRED;
+ c->flags|=CODEC_FLAG_H263P_SLICE_STRUCT;
+- /*
+ c->flags|=CODEC_FLAG_OBMC;
+ c->flags|=CODEC_FLAG_AC_PRED;
+ */
diff --git a/media-libs/mediastreamer/mediastreamer-2.8.2.ebuild b/media-libs/mediastreamer/mediastreamer-2.8.2.ebuild
index 78328ba634d4..7d82e621baaa 100644
--- a/media-libs/mediastreamer/mediastreamer-2.8.2.ebuild
+++ b/media-libs/mediastreamer/mediastreamer-2.8.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mediastreamer/mediastreamer-2.8.2.ebuild,v 1.3 2012/12/17 17:34:55 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mediastreamer/mediastreamer-2.8.2.ebuild,v 1.4 2013/01/17 21:56:29 aballier Exp $
EAPI="4"
@@ -68,7 +68,8 @@ src_prepare() {
|| die "patching help/Makefile.am failed"
epatch "${FILESDIR}/${P}-v4l-automagic.patch" \
- "${FILESDIR}/${P}-autopoint.patch"
+ "${FILESDIR}/${P}-autopoint.patch" \
+ "${FILESDIR}/${P}-ffmpeg-1.0.patch"
# linux/videodev.h dropped in 2.6.38
sed -i -e 's:linux/videodev.h ::' configure.ac || die