summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-12-07 13:15:36 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-12-07 13:15:36 +0000
commit5c086b2532b3378915ace3085f2277743fcfc85b (patch)
tree0558c8805b7d780595626f6ad4a9c67ca02b0e04 /media-libs/lv2core/lv2core-6.0.ebuild
parentx86 stable wrt bug #388279 (diff)
downloadgentoo-2-5c086b2532b3378915ace3085f2277743fcfc85b.tar.gz
gentoo-2-5c086b2532b3378915ace3085f2277743fcfc85b.tar.bz2
gentoo-2-5c086b2532b3378915ace3085f2277743fcfc85b.zip
version bump
(Portage version: 2.2.0_alpha79/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/lv2core/lv2core-6.0.ebuild')
-rw-r--r--media-libs/lv2core/lv2core-6.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-libs/lv2core/lv2core-6.0.ebuild b/media-libs/lv2core/lv2core-6.0.ebuild
new file mode 100644
index 000000000000..ed5ee267a896
--- /dev/null
+++ b/media-libs/lv2core/lv2core-6.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/lv2core/lv2core-6.0.ebuild,v 1.1 2011/12/07 13:15:36 aballier Exp $
+
+EAPI=2
+
+inherit multilib toolchain-funcs
+
+DESCRIPTION="LV2 is a simple but extensible successor of LADSPA"
+HOMEPAGE="http://lv2plug.in/"
+SRC_URI="http://lv2plug.in/spec/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="!<media-libs/slv2-0.4.2"
+
+src_configure() {
+ tc-export CC CXX CPP AR RANLIB
+ ./waf configure --prefix=/usr --libdir=/usr/$(get_libdir) || die "failed to configure"
+}
+
+src_compile() {
+ ./waf || die "failed to build"
+}
+
+src_install() {
+ ./waf --destdir="${D}" install || die "install failed"
+ dodoc AUTHORS README NEWS || die
+}