summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2009-05-10 23:52:41 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2009-05-10 23:52:41 +0000
commit63e43a9118dbf30d207d3c1315f7b0089a0a76b5 (patch)
tree5bdeb6fd6486206d7d7e9757357a4c9a7615dcb1 /media-libs/libwmf
parentEnsure kernel checks only occur when USE=module. FIxes bug 268378. (diff)
downloadgentoo-2-63e43a9118dbf30d207d3c1315f7b0089a0a76b5.tar.gz
gentoo-2-63e43a9118dbf30d207d3c1315f7b0089a0a76b5.tar.bz2
gentoo-2-63e43a9118dbf30d207d3c1315f7b0089a0a76b5.zip
Drop use of internal gd w.r.t. bug 268161. Add fix for bug 269324, include order bug, possibly triggered by gcc-4.4.0.
(Portage version: 2.2_rc28/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/libwmf')
-rw-r--r--media-libs/libwmf/ChangeLog9
-rw-r--r--media-libs/libwmf/files/libwmf-0.2.8.4-pngfix.patch20
-rw-r--r--media-libs/libwmf/libwmf-0.2.8.4-r3.ebuild108
3 files changed, 136 insertions, 1 deletions
diff --git a/media-libs/libwmf/ChangeLog b/media-libs/libwmf/ChangeLog
index d5644ca1f2f1..9ac97bd3da9d 100644
--- a/media-libs/libwmf/ChangeLog
+++ b/media-libs/libwmf/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/libwmf
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libwmf/ChangeLog,v 1.57 2009/03/06 05:18:15 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libwmf/ChangeLog,v 1.58 2009/05/10 23:52:40 loki_val Exp $
+
+*libwmf-0.2.8.4-r3 (10 May 2009)
+
+ 10 May 2009; Peter Alfredsen <loki_val@gentoo.org>
+ +libwmf-0.2.8.4-r3.ebuild, +files/libwmf-0.2.8.4-pngfix.patch:
+ Drop use of internal gd w.r.t. bug 268161. Add fix for bug 269324, include
+ order bug, possibly triggered by gcc-4.4.0.
*libwmf-0.2.8.4-r2 (06 Mar 2009)
diff --git a/media-libs/libwmf/files/libwmf-0.2.8.4-pngfix.patch b/media-libs/libwmf/files/libwmf-0.2.8.4-pngfix.patch
new file mode 100644
index 000000000000..52717735a26e
--- /dev/null
+++ b/media-libs/libwmf/files/libwmf-0.2.8.4-pngfix.patch
@@ -0,0 +1,20 @@
+diff -NrU5 libwmf-0.2.8.4.orig/src/ipa/ipa.c libwmf-0.2.8.4/src/ipa/ipa.c
+--- libwmf-0.2.8.4.orig/src/ipa/ipa.c 2009-05-10 23:41:17.000000000 +0200
++++ libwmf-0.2.8.4/src/ipa/ipa.c 2009-05-11 00:07:43.000000000 +0200
+@@ -33,10 +33,16 @@
+
+ /* Define WMF_API if this is module so that ipa headers are included via "wmfdefs.h" first
+ */
+ #define WMF_IPA 1
+
++#ifndef HAVE_GD
++#ifdef HAVE_LIBPNG
++#include <png.h>
++#endif /* HAVE_LIBPNG */
++#endif /* HAVE_GD */
++
+ #include "wmfdefs.h"
+
+ #include "ipa/ipa.h"
+ #include "ipa/ipa/bmp.h" /* Provides default bitmap functionality */
+
diff --git a/media-libs/libwmf/libwmf-0.2.8.4-r3.ebuild b/media-libs/libwmf/libwmf-0.2.8.4-r3.ebuild
new file mode 100644
index 000000000000..2258edf205ca
--- /dev/null
+++ b/media-libs/libwmf/libwmf-0.2.8.4-r3.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libwmf/libwmf-0.2.8.4-r3.ebuild,v 1.1 2009/05/10 23:52:40 loki_val Exp $
+
+inherit eutils autotools
+
+#The configure script finds the 5.50 ghostscript Fontmap file while run.
+#This will probably work, especially since the real one (6.50) in this case
+#is empty. However beware in case there is any trouble
+
+DESCRIPTION="library for converting WMF files"
+HOMEPAGE="http://wvware.sourceforge.net/"
+SRC_URI="mirror://sourceforge/wvware/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="X expat xml debug doc gtk"
+
+RDEPEND="virtual/ghostscript
+ xml? ( !expat? ( dev-libs/libxml2 ) )
+ expat? ( dev-libs/expat )
+ >=media-libs/freetype-2.0.1
+ sys-libs/zlib
+ media-libs/libpng
+ media-libs/jpeg
+ X? (
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ )
+ gtk? ( >=x11-libs/gtk+-2.1.2 ) "
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ X? (
+ x11-libs/libXt
+ x11-libs/libXpm
+ )"
+# plotutils are not really supported yet, so looks like that's it
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ if ! use doc ; then
+ sed -e 's:doc::' -i Makefile.am
+ fi
+ if ! use gtk ; then
+ sed -e 's:@LIBWMF_GDK_PIXBUF_TRUE@:#:' -i src/Makefile.in
+ fi
+ epatch "${FILESDIR}"/${P}-intoverflow.patch
+ epatch "${FILESDIR}"/${P}-build.patch
+ epatch "${FILESDIR}"/${P}-pngfix.patch
+
+ eautoreconf
+}
+
+src_compile() {
+ if use expat && use xml ; then
+ elog "You can specify only one USE flag from expat and xml, to use expat"
+ elog "or libxml2, respectively."
+ elog
+ elog "You have both flags enabled, we will default to expat (like autocheck does)."
+ myconf="${myconf} --with-expat --without-libxml2"
+ else
+ myconf="${myconf} $(use_with expat) $(use_with xml libxml2)"
+ fi
+
+ # NOTE: The gd that is included is gd-2.0.0. Even with --with-sys-gd, that gd is built
+ # and included in libwmf. Since nothing in-tree seems to use media-libs/libwmf[gd],
+ # we're explicitly disabling gd use w.r.t. bug 268161
+ econf \
+ $(use_enable debug) \
+ $(use_with X x) \
+ --disable-gd \
+ --with-sys-gd \
+ ${myconf} \
+ --with-gsfontdir=/usr/share/ghostscript/fonts \
+ --with-fontdir=/usr/share/libwmf/fonts/ \
+ --with-docdir=/usr/share/doc/${PF} \
+ || die "./configure failed"
+
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ dodoc README AUTHORS CREDITS ChangeLog NEWS TODO
+}
+
+set_gtk_confdir() {
+ # An arch specific config directory is used on multilib systems
+ has_multilib_profile && GTK2_CONFDIR="${ROOT}etc/gtk-2.0/${CHOST}"
+ GTK2_CONFDIR="${GTK2_CONFDIR:-/etc/gtk-2.0}"
+}
+
+pkg_postinst() {
+ if use gtk; then
+ set_gtk_confdir
+ gdk-pixbuf-query-loaders > "${GTK2_CONFDIR}/gdk-pixbuf.loaders"
+ fi
+}
+
+pkg_postrm() {
+ if use gtk; then
+ set_gtk_confdir
+ gdk-pixbuf-query-loaders > "${GTK2_CONFDIR}/gdk-pixbuf.loaders"
+ fi
+}