summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-07-17 19:24:33 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-07-17 19:24:33 +0000
commit281705dccba695f0ea4bc4cebeb24c77b6b6aa15 (patch)
tree22064498f8a7b5c9c8425b0253cd42d5ac8a25cb /media-libs/libwmf
parent[sci-chemistry/gromacs] fix for bug #375473 (diff)
downloadgentoo-2-281705dccba695f0ea4bc4cebeb24c77b6b6aa15.tar.gz
gentoo-2-281705dccba695f0ea4bc4cebeb24c77b6b6aa15.tar.bz2
gentoo-2-281705dccba695f0ea4bc4cebeb24c77b6b6aa15.zip
Reorder xml and expat useflags in order to fix bug #373919. This cause no factical change, just reorders the use deps bit so it is more reasonable wrt xml useflag.
(Portage version: 2.2.0_alpha45/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/libwmf')
-rw-r--r--media-libs/libwmf/ChangeLog8
-rw-r--r--media-libs/libwmf/libwmf-0.2.8.4-r4.ebuild19
2 files changed, 21 insertions, 6 deletions
diff --git a/media-libs/libwmf/ChangeLog b/media-libs/libwmf/ChangeLog
index 11a5765d8969..3f9398b8d848 100644
--- a/media-libs/libwmf/ChangeLog
+++ b/media-libs/libwmf/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/libwmf
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libwmf/ChangeLog,v 1.74 2011/07/17 14:40:15 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libwmf/ChangeLog,v 1.75 2011/07/17 19:24:33 scarabeus Exp $
+
+ 17 Jul 2011; Tomáš Chvátal <scarabeus@gentoo.org>
+ libwmf-0.2.8.4-r4.ebuild:
+ Reorder xml and expat useflags in order to fix bug #373919. This cause no
+ factical change, just reorders the use deps bit so it is more reasonable wrt
+ xml useflag.
17 Jul 2011; Markus Meier <maekke@gentoo.org> libwmf-0.2.8.4-r4.ebuild:
x86 stable, bug #373889
diff --git a/media-libs/libwmf/libwmf-0.2.8.4-r4.ebuild b/media-libs/libwmf/libwmf-0.2.8.4-r4.ebuild
index 5c89a2f74676..c4a88f8a60b7 100644
--- a/media-libs/libwmf/libwmf-0.2.8.4-r4.ebuild
+++ b/media-libs/libwmf/libwmf-0.2.8.4-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libwmf/libwmf-0.2.8.4-r4.ebuild,v 1.5 2011/07/17 14:40:15 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libwmf/libwmf-0.2.8.4-r4.ebuild,v 1.6 2011/07/17 19:24:33 scarabeus Exp $
EAPI=4
@@ -26,8 +26,10 @@ RDEPEND="app-text/ghostscript-gpl
sys-libs/zlib
x11-libs/gdk-pixbuf:2[X?]
virtual/jpeg
- expat? ( dev-libs/expat )
- xml? ( dev-libs/libxml2 )
+ xml? (
+ expat? ( dev-libs/expat )
+ !expat? ( dev-libs/libxml2 )
+ )
X? (
x11-libs/libICE
x11-libs/libSM
@@ -42,7 +44,7 @@ DEPEND="${RDEPEND}
)"
# plotutils are not really supported yet, so looks like that's it
-REQUIRED_USE="xml? ( !expat ) expat? ( !xml )"
+REQUIRED_USE="expat? ( xml )"
DOCS=( README AUTHORS CREDITS ChangeLog NEWS TODO )
@@ -62,15 +64,22 @@ src_prepare() {
}
src_configure() {
+ local myconf
# NOTE: The gd that is included is gd-2.0.0. Even with --with-sys-gd, that gd is built
# and included in libwmf. Since nothing in-tree seems to use media-libs/libwmf[gd],
# we're explicitly disabling gd use w.r.t. bug 268161
+ if use expat; then
+ myconf+=" --disable-libxml2"
+ else
+ myconf+=$(use_with xml libxml2)
+ fi
+
econf \
--disable-static \
$(use_enable debug) \
$(use_with X x) \
$(use_with expat) \
- $(use_with xml libxml2) \
+ ${myconf} \
--disable-gd \
--with-sys-gd \
--with-gsfontdir="${EPREFIX}"/usr/share/ghostscript/fonts \