summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-02-13 14:29:41 +0000
committerAchim Gottinger <achim@gentoo.org>2001-02-13 14:29:41 +0000
commitc8371d9e9ca933c7773a76ee3133ec8f0d7fbe5d (patch)
treede46edaa6630baa8b7d0d425cb6ddf761dd7d2c2 /media-libs/libvorbis
parent*** empty log message *** (diff)
downloadgentoo-2-c8371d9e9ca933c7773a76ee3133ec8f0d7fbe5d.tar.gz
gentoo-2-c8371d9e9ca933c7773a76ee3133ec8f0d7fbe5d.tar.bz2
gentoo-2-c8371d9e9ca933c7773a76ee3133ec8f0d7fbe5d.zip
Maintainence and FHS 2.1 fixes
Added a lot of USE flags GGI support and lcms support for libmng
Diffstat (limited to 'media-libs/libvorbis')
-rw-r--r--media-libs/libvorbis/libvorbis-1.0_beta3-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-libs/libvorbis/libvorbis-1.0_beta3-r1.ebuild b/media-libs/libvorbis/libvorbis-1.0_beta3-r1.ebuild
new file mode 100644
index 000000000000..d20450bc41d5
--- /dev/null
+++ b/media-libs/libvorbis/libvorbis-1.0_beta3-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Peter Gavin <pbg1854@garnet.acns.fsu.edu>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libvorbis/libvorbis-1.0_beta3-r1.ebuild,v 1.1 2001/02/13 14:29:41 achim Exp $
+
+
+A=libvorbis-1.0beta3.tar.gz
+S=${WORKDIR}/libvorbis-1.0beta3
+DESCRIPTION="the Ogg Vorbis sound file format library"
+SRC_URI="http://www.vorbis.com/files/beta3/${A}"
+HOMEPAGE="http://www.xiph.org/ogg/vorbis/index.html"
+
+DEPEND=">=media-libs/libogg-1.0_beta3"
+
+src_compile() {
+
+ try ./configure --prefix=/usr --host=${CHOST}
+ try make
+}
+
+src_install () {
+
+ try make DESTDIR=${D} install
+
+ echo "Removing docs installed by make install"
+ rm -rf ${D}/usr/share/doc
+
+ dodoc AUTHORS COPYING README todo.txt
+ docinto txt
+ dodoc doc/*.txt
+ docinto html
+ dodoc doc/*.{html,png}
+ docinto html/vorbisenc
+ dodoc doc/vorbisenc/*.{css,html}
+ docinto html/vorbisfile
+ dodoc doc/vorbisfile/*.{css,html}
+}
+