summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2005-07-16 18:48:38 +0000
committerMark Loeser <halcy0n@gentoo.org>2005-07-16 18:48:38 +0000
commitbcf4e04691f2f1fa2e7d25f57bbb9a6f7c1031de (patch)
tree9644bfdcee938de8ec7968c4030ee377d7f97ece /media-libs/libvorbis/libvorbis-1.0.1-r2.ebuild
parentdep/style fixes (diff)
downloadgentoo-2-bcf4e04691f2f1fa2e7d25f57bbb9a6f7c1031de.tar.gz
gentoo-2-bcf4e04691f2f1fa2e7d25f57bbb9a6f7c1031de.tar.bz2
gentoo-2-bcf4e04691f2f1fa2e7d25f57bbb9a6f7c1031de.zip
filter -ftracer with gcc-3.4; bug #49472
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'media-libs/libvorbis/libvorbis-1.0.1-r2.ebuild')
-rw-r--r--media-libs/libvorbis/libvorbis-1.0.1-r2.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/media-libs/libvorbis/libvorbis-1.0.1-r2.ebuild b/media-libs/libvorbis/libvorbis-1.0.1-r2.ebuild
index 858edb4d404b..652c2c277763 100644
--- a/media-libs/libvorbis/libvorbis-1.0.1-r2.ebuild
+++ b/media-libs/libvorbis/libvorbis-1.0.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libvorbis/libvorbis-1.0.1-r2.ebuild,v 1.16 2005/05/15 02:18:30 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libvorbis/libvorbis-1.0.1-r2.ebuild,v 1.17 2005/07/16 18:48:38 halcy0n Exp $
inherit libtool flag-o-matic toolchain-funcs
@@ -45,6 +45,13 @@ src_compile() {
# over optimization causes horrible audio artifacts #26463
filter-flags -march=pentium?
+ # gcc-3.4 and k6 with -ftracer causes code generation problems #49472
+ if [ $(gcc-major-version) -eq 3 -a $(gcc-minor-version) -eq 4 ];
+ then
+ is-flag -march=k6* && filter-flags -ftracer
+ is-flag -mtune=k6* && filter-flags -ftracer
+ fi
+
# gcc on hppa causes issues when assembling
use hppa && replace-flags -march=2.0 -march=1.0