summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-02-02 17:02:25 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-02-02 17:02:25 +0000
commitff9744d8de48f2f8d303135e14172a6670b7be9a (patch)
tree15f6e17e02eeb889ae02e91351b986459a9c012f /media-libs/libv4l
parentStable for amd64, wrt bug #396787 (diff)
downloadgentoo-2-ff9744d8de48f2f8d303135e14172a6670b7be9a.tar.gz
gentoo-2-ff9744d8de48f2f8d303135e14172a6670b7be9a.tar.bz2
gentoo-2-ff9744d8de48f2f8d303135e14172a6670b7be9a.zip
Since JPEG 7.x the fancy upsampling has been enabled by default and should explicitely be disabled in apps not supporting it wrt #401865 by Denilson Sá
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/libv4l')
-rw-r--r--media-libs/libv4l/ChangeLog9
-rw-r--r--media-libs/libv4l/files/libv4l-0.8.5-disable_fancy_upsampling.patch13
-rw-r--r--media-libs/libv4l/libv4l-0.8.5-r1.ebuild45
3 files changed, 66 insertions, 1 deletions
diff --git a/media-libs/libv4l/ChangeLog b/media-libs/libv4l/ChangeLog
index 15e87ef15bbb..32e16292463b 100644
--- a/media-libs/libv4l/ChangeLog
+++ b/media-libs/libv4l/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/libv4l
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libv4l/ChangeLog,v 1.61 2012/01/13 16:07:46 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libv4l/ChangeLog,v 1.62 2012/02/02 17:02:25 ssuominen Exp $
+
+*libv4l-0.8.5-r1 (02 Feb 2012)
+
+ 02 Feb 2012; Samuli Suominen <ssuominen@gentoo.org> +libv4l-0.8.5-r1.ebuild,
+ +files/libv4l-0.8.5-disable_fancy_upsampling.patch:
+ Since JPEG 7.x the fancy upsampling has been enabled by default and should
+ explicitely be disabled in apps not supporting it wrt #401865 by Denilson Sá
13 Jan 2012; Mike Frysinger <vapier@gentoo.org> libv4l-0.8.5.ebuild:
Simplify ebuild a bit.
diff --git a/media-libs/libv4l/files/libv4l-0.8.5-disable_fancy_upsampling.patch b/media-libs/libv4l/files/libv4l-0.8.5-disable_fancy_upsampling.patch
new file mode 100644
index 000000000000..7f385df497b4
--- /dev/null
+++ b/media-libs/libv4l/files/libv4l-0.8.5-disable_fancy_upsampling.patch
@@ -0,0 +1,13 @@
+http://bugs.gentoo.org/401865
+http://bugs.debian.org/647273
+
+--- lib/libv4lconvert/jpeg.c
++++ lib/libv4lconvert/jpeg.c
+@@ -390,6 +390,7 @@
+ }
+
+ data->cinfo.raw_data_out = TRUE;
++ data->cinfo.do_fancy_upsampling = FALSE;
+ jpeg_start_decompress(&data->cinfo);
+ /* Make libjpeg errors report that we've got some data */
+ data->jerr_errno = EPIPE;
diff --git a/media-libs/libv4l/libv4l-0.8.5-r1.ebuild b/media-libs/libv4l/libv4l-0.8.5-r1.ebuild
new file mode 100644
index 000000000000..1bf4c3e0f0d5
--- /dev/null
+++ b/media-libs/libv4l/libv4l-0.8.5-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libv4l/libv4l-0.8.5-r1.ebuild,v 1.1 2012/02/02 17:02:24 ssuominen Exp $
+
+EAPI=4
+inherit eutils linux-info multilib toolchain-funcs
+
+MY_P=v4l-utils-${PV}
+
+DESCRIPTION="Separate libraries ebuild from upstream v4l-utils package"
+HOMEPAGE="http://git.linuxtv.org/v4l-utils.git"
+SRC_URI="http://linuxtv.org/downloads/v4l-utils/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="virtual/jpeg"
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-2.6.30-r1"
+
+S=${WORKDIR}/${MY_P}
+
+CONFIG_CHECK="~SHMEM"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-disable_fancy_upsampling.patch
+
+ sed -i \
+ -e "/^PREFIX =/s:=.*:= ${EPREFIX}/usr:" \
+ -e "/^LIBDIR =/s:/lib:/$(get_libdir):" \
+ -e "/^CFLAGS :=/d" \
+ Make.rules || die
+ tc-export CC
+}
+
+src_compile() {
+ emake -C lib
+}
+
+src_install() {
+ emake -C lib DESTDIR="${D}" install
+ dodoc ChangeLog README.lib* TODO
+}