summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-09-06 09:12:02 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-09-06 09:12:02 +0000
commitd48f6007c71d310d7658c43c3cfdbe1858d66ba9 (patch)
tree118e3c68e4fc5f87608710e8da8c11b2932ef750 /media-libs/libv4l
parentversion bump (diff)
downloadgentoo-2-d48f6007c71d310d7658c43c3cfdbe1858d66ba9.tar.gz
gentoo-2-d48f6007c71d310d7658c43c3cfdbe1858d66ba9.tar.bz2
gentoo-2-d48f6007c71d310d7658c43c3cfdbe1858d66ba9.zip
version bump, by Peter Volkov <pva@gentoo.org>, bug #283746
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/libv4l')
-rw-r--r--media-libs/libv4l/ChangeLog7
-rw-r--r--media-libs/libv4l/libv4l-0.6.1.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/media-libs/libv4l/ChangeLog b/media-libs/libv4l/ChangeLog
index 5d981ba5e012..3fa68d33f89f 100644
--- a/media-libs/libv4l/ChangeLog
+++ b/media-libs/libv4l/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/libv4l
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libv4l/ChangeLog,v 1.18 2009/07/17 08:33:39 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libv4l/ChangeLog,v 1.19 2009/09/06 09:12:02 aballier Exp $
+
+*libv4l-0.6.1 (06 Sep 2009)
+
+ 06 Sep 2009; Alexis Ballier <aballier@gentoo.org> +libv4l-0.6.1.ebuild:
+ version bump, by Peter Volkov <pva@gentoo.org>, bug #283746
*libv4l-0.6.0 (17 Jul 2009)
diff --git a/media-libs/libv4l/libv4l-0.6.1.ebuild b/media-libs/libv4l/libv4l-0.6.1.ebuild
new file mode 100644
index 000000000000..2b1c5a83c8d5
--- /dev/null
+++ b/media-libs/libv4l/libv4l-0.6.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libv4l/libv4l-0.6.1.ebuild,v 1.1 2009/09/06 09:12:02 aballier Exp $
+
+inherit multilib toolchain-funcs
+
+DESCRIPTION="V4L userspace libraries"
+HOMEPAGE="http://people.atrpms.net/~hdegoede/
+ http://hansdegoede.livejournal.com/3636.html"
+SRC_URI="http://people.atrpms.net/~hdegoede/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+src_compile() {
+ tc-export CC
+ emake PREFIX="/usr" LIBDIR="/usr/$(get_libdir)" CFLAGS="${CFLAGS}" \
+ || die "emake failed"
+}
+
+src_install() {
+ emake PREFIX="/usr" LIBDIR="/usr/$(get_libdir)" \
+ DESTDIR="${D}" install || die "emake install failed"
+ dodoc ChangeLog README* TODO
+}
+
+pkg_postinst() {
+ elog
+ elog "libv4l includes wrapper libraries for compatibility and pixel format"
+ elog "conversion, which are especially useful for users of the gspca usb"
+ elog "webcam driver in kernel 2.6.27 and higher."
+ elog
+ elog "To add v4l2 compatibility to a v4l application 'myapp', launch it via"
+ elog "LD_PRELOAD=/usr/$(get_libdir)/libv4l/v4l1compat.so myapp"
+ elog "To add automatic pixel format conversion to a v4l2 application, use"
+ elog "LD_PRELOAD=/usr/$(get_libdir)/libv4l/v4l2convert.so myapp"
+ elog
+}