summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-07-02 22:08:20 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-07-02 22:08:20 +0000
commit4e3f4028c80a13beb014c9da3aac8d425b6cc74a (patch)
tree941b687a46932f914e0fd8d2978d60bbab715a30 /media-libs/libtheora
parentinstall the proper stubs instead of hacking around ruby scripts. This fixes p... (diff)
downloadgentoo-2-4e3f4028c80a13beb014c9da3aac8d425b6cc74a.tar.gz
gentoo-2-4e3f4028c80a13beb014c9da3aac8d425b6cc74a.tar.bz2
gentoo-2-4e3f4028c80a13beb014c9da3aac8d425b6cc74a.zip
Fix installation with USE=doc examples, bug #475138 by Conway S. Smith and Jeroen Roovers.
(Portage version: 2.2.0_alpha186/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-libs/libtheora')
-rw-r--r--media-libs/libtheora/ChangeLog6
-rw-r--r--media-libs/libtheora/libtheora-1.1.1-r1.ebuild16
2 files changed, 15 insertions, 7 deletions
diff --git a/media-libs/libtheora/ChangeLog b/media-libs/libtheora/ChangeLog
index 884b8f5caf7f..d9c7ccc7a995 100644
--- a/media-libs/libtheora/ChangeLog
+++ b/media-libs/libtheora/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/libtheora
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libtheora/ChangeLog,v 1.111 2013/06/27 16:22:31 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libtheora/ChangeLog,v 1.112 2013/07/02 22:08:20 aballier Exp $
+
+ 02 Jul 2013; Alexis Ballier <aballier@gentoo.org> libtheora-1.1.1-r1.ebuild:
+ Fix installation with USE=doc examples, bug #475138 by Conway S. Smith and
+ Jeroen Roovers.
*libtheora-1.1.1-r1 (27 Jun 2013)
diff --git a/media-libs/libtheora/libtheora-1.1.1-r1.ebuild b/media-libs/libtheora/libtheora-1.1.1-r1.ebuild
index 668f7e3650b8..bf98347ea1df 100644
--- a/media-libs/libtheora/libtheora-1.1.1-r1.ebuild
+++ b/media-libs/libtheora/libtheora-1.1.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libtheora/libtheora-1.1.1-r1.ebuild,v 1.1 2013/06/27 16:22:31 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libtheora/libtheora-1.1.1-r1.ebuild,v 1.2 2013/07/02 22:08:20 aballier Exp $
EAPI=5
inherit autotools eutils flag-o-matic multilib-minimal
@@ -72,11 +72,6 @@ multilib_src_install() {
install
if use examples && [ "${ABI}" = "${DEFAULT_ABI}" ]; then
- if use doc; then
- insinto /usr/share/doc/${PF}/examples
- doins examples/*.[ch]
- fi
-
dobin examples/.libs/png2theora
for bin in dump_{psnr,video} {encoder,player}_example; do
newbin examples/.libs/${bin} theora_${bin}
@@ -85,3 +80,12 @@ multilib_src_install() {
prune_libtool_files
}
+
+multilib_src_install_all() {
+ if use examples && use doc; then
+ docinto examples
+ dodoc examples/*.[ch]
+ docompress -x /usr/share/doc/${PF}/examples
+ docinto .
+ fi
+}