summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-11-25 21:11:20 +0000
committerSamuli Suominen <drac@gentoo.org>2007-11-25 21:11:20 +0000
commit26ea1517136e939acbd0ca0c842c377edcdd7519 (patch)
treea95f66f8d7dc1948dadf3552de009af2d59716fa /media-libs/libtheora
parentMask new libtheora for testing. (diff)
downloadgentoo-2-26ea1517136e939acbd0ca0c842c377edcdd7519.tar.gz
gentoo-2-26ea1517136e939acbd0ca0c842c377edcdd7519.tar.bz2
gentoo-2-26ea1517136e939acbd0ca0c842c377edcdd7519.zip
Version bump.
(Portage version: 2.1.4_rc3)
Diffstat (limited to 'media-libs/libtheora')
-rw-r--r--media-libs/libtheora/ChangeLog8
-rw-r--r--media-libs/libtheora/files/digest-libtheora-1.0_beta23
-rw-r--r--media-libs/libtheora/files/libtheora-1.0_beta2-flags.patch14
-rw-r--r--media-libs/libtheora/libtheora-1.0_beta2.ebuild57
4 files changed, 81 insertions, 1 deletions
diff --git a/media-libs/libtheora/ChangeLog b/media-libs/libtheora/ChangeLog
index 4d3ab875d57b..09717d11feb6 100644
--- a/media-libs/libtheora/ChangeLog
+++ b/media-libs/libtheora/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/libtheora
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libtheora/ChangeLog,v 1.59 2007/06/04 16:05:29 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libtheora/ChangeLog,v 1.60 2007/11/25 21:11:20 drac Exp $
+
+*libtheora-1.0_beta2 (25 Nov 2007)
+
+ 25 Nov 2007; Samuli Suominen <drac@gentoo.org>
+ +files/libtheora-1.0_beta2-flags.patch, +libtheora-1.0_beta2.ebuild:
+ Version bump.
*libtheora-1.0_alpha7-r1 (04 Jun 2007)
diff --git a/media-libs/libtheora/files/digest-libtheora-1.0_beta2 b/media-libs/libtheora/files/digest-libtheora-1.0_beta2
new file mode 100644
index 000000000000..b1a25e44c2fb
--- /dev/null
+++ b/media-libs/libtheora/files/digest-libtheora-1.0_beta2
@@ -0,0 +1,3 @@
+MD5 6ed9f998a982e996ad53d3686d655cfe libtheora-1.0beta2.tar.bz2 1774632
+RMD160 544bdb94e09fdfcfb76b603dd32c40ed5d6103a2 libtheora-1.0beta2.tar.bz2 1774632
+SHA256 8bd514ddf5836d82a97f9ff2a4b606c9ccf6ed749055a9fb79f7a335c0ef4b20 libtheora-1.0beta2.tar.bz2 1774632
diff --git a/media-libs/libtheora/files/libtheora-1.0_beta2-flags.patch b/media-libs/libtheora/files/libtheora-1.0_beta2-flags.patch
new file mode 100644
index 000000000000..a47cc5771680
--- /dev/null
+++ b/media-libs/libtheora/files/libtheora-1.0_beta2-flags.patch
@@ -0,0 +1,14 @@
+diff -ur libtheora-1.0beta2.orig/configure.ac libtheora-1.0beta2/configure.ac
+--- libtheora-1.0beta2.orig/configure.ac 2007-10-13 00:01:38.000000000 +0300
++++ libtheora-1.0beta2/configure.ac 2007-11-25 22:44:49.000000000 +0200
+@@ -102,8 +102,8 @@
+ case $host in
+ *)
+ DEBUG="-g -Wall -Wno-parentheses -DDEBUG -D__NO_MATH_INLINES"
+- CFLAGS="-Wall -Wno-parentheses -O3 -fforce-addr -fomit-frame-pointer -finline-functions -funroll-loops"
+- PROFILE="-Wall -Wno-parentheses -pg -g -O3 -fno-inline-functions -DDEBUG";;
++ CFLAGS="-Wall -Wno-parentheses"
++ PROFILE="-Wall -Wno-parentheses -pg -g -fno-inline-functions -DDEBUG";;
+ esac
+ fi
+ CFLAGS="$CFLAGS $cflags_save"
diff --git a/media-libs/libtheora/libtheora-1.0_beta2.ebuild b/media-libs/libtheora/libtheora-1.0_beta2.ebuild
new file mode 100644
index 000000000000..f39750b10df4
--- /dev/null
+++ b/media-libs/libtheora/libtheora-1.0_beta2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libtheora/libtheora-1.0_beta2.ebuild,v 1.1 2007/11/25 21:11:20 drac Exp $
+
+inherit autotools eutils
+
+DESCRIPTION="The Theora Video Compression Codec"
+HOMEPAGE="http://www.theora.org"
+SRC_URI="http://downloads.xiph.org/releases/theora/${P/_}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="doc encode examples pic"
+
+RDEPEND=">=media-libs/libogg-1.1
+ encode? ( >=media-libs/libvorbis-1.0.1 )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${P/_}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-flags.patch
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_compile() {
+ local myconf
+
+ use pic && myconf="--disable-asm"
+
+ use doc || export ac_cv_prog_HAVE_DOXYGEN="false"
+
+ econf --disable-dependency-tracking --disable-examples \
+ --disable-sdltest $(use_enable encode) ${myconf}
+
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" docdir="usr/share/doc/${PF}" \
+ install || die "emake install failed."
+
+ dodoc AUTHORS CHANGES README
+
+ prepalldocs
+
+ if use examples; then
+ rm examples/Makefile*
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+ fi
+}