summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-10-27 11:16:37 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-10-27 11:16:37 +0000
commit4c549d6ecfe13922a00ca5c9cbc1bafb9962384f (patch)
tree934207a03f089195d5a41ebd79540930de57e572 /media-libs/libtheora/libtheora-1.1.1.ebuild
parentIn preparation for some upcoming changes to the eclass, I'm masking x11-plugi... (diff)
downloadgentoo-2-4c549d6ecfe13922a00ca5c9cbc1bafb9962384f.tar.gz
gentoo-2-4c549d6ecfe13922a00ca5c9cbc1bafb9962384f.tar.bz2
gentoo-2-4c549d6ecfe13922a00ca5c9cbc1bafb9962384f.zip
version bump, by Arne Babenhauserheide <arne_bab@web.de>, bug #289908
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/libtheora/libtheora-1.1.1.ebuild')
-rw-r--r--media-libs/libtheora/libtheora-1.1.1.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/media-libs/libtheora/libtheora-1.1.1.ebuild b/media-libs/libtheora/libtheora-1.1.1.ebuild
new file mode 100644
index 000000000000..c10e27091414
--- /dev/null
+++ b/media-libs/libtheora/libtheora-1.1.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libtheora/libtheora-1.1.1.ebuild,v 1.1 2009/10/27 11:16:37 aballier Exp $
+
+EAPI=2
+inherit autotools eutils flag-o-matic
+
+DESCRIPTION="The Theora Video Compression Codec"
+HOMEPAGE="http://www.theora.org"
+SRC_URI="http://downloads.xiph.org/releases/theora/${P/_}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc +encode examples"
+
+RDEPEND="media-libs/libogg
+ encode? ( media-libs/libvorbis )
+ examples? ( media-libs/libpng
+ media-libs/libvorbis
+ >=media-libs/libsdl-0.11.0 )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ dev-util/pkgconfig"
+
+VARTEXFONTS=${T}/fonts
+S=${WORKDIR}/${P/_}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.0_beta2-flags.patch
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_configure() {
+ use x86 && filter-flags -fforce-addr -frename-registers #200549
+ use doc || export ac_cv_prog_HAVE_DOXYGEN="false"
+
+ local myconf
+ use examples && myconf="--enable-encode"
+
+ # --disable-spec because LaTeX documentation has been prebuilt
+ econf \
+ --disable-dependency-tracking \
+ --disable-spec \
+ $(use_enable encode) \
+ $(use_enable examples) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" docdir=/usr/share/doc/${PF} \
+ install || die "emake install failed"
+
+ dodoc AUTHORS CHANGES README
+ prepalldocs
+
+ if use examples; then
+ if use doc; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.[ch]
+ fi
+
+ dobin examples/.libs/png2theora || die "dobin failed"
+ for bin in dump_{psnr,video} {encoder,player}_example; do
+ newbin examples/.libs/${bin} theora_${bin} || die "newbin failed"
+ done
+ fi
+}