summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2006-08-24 06:20:53 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2006-08-24 06:20:53 +0000
commit99f7b786fe965ad6fee40cb6149e91e8692b684d (patch)
tree7b867256d992b16b411d2ef5a21fcf59888d4f90 /media-libs/libsoundtouch/libsoundtouch-1.3.1.ebuild
parentInitial commit, ebuild by Robin H. Johnson <robbat2@gentoo.org>. (diff)
downloadgentoo-2-99f7b786fe965ad6fee40cb6149e91e8692b684d.tar.gz
gentoo-2-99f7b786fe965ad6fee40cb6149e91e8692b684d.tar.bz2
gentoo-2-99f7b786fe965ad6fee40cb6149e91e8692b684d.zip
Bump, fixes gcc4 compile.
(Portage version: 2.1.1_pre5-r2)
Diffstat (limited to 'media-libs/libsoundtouch/libsoundtouch-1.3.1.ebuild')
-rw-r--r--media-libs/libsoundtouch/libsoundtouch-1.3.1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-libs/libsoundtouch/libsoundtouch-1.3.1.ebuild b/media-libs/libsoundtouch/libsoundtouch-1.3.1.ebuild
new file mode 100644
index 000000000000..39f3bf83d20c
--- /dev/null
+++ b/media-libs/libsoundtouch/libsoundtouch-1.3.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsoundtouch/libsoundtouch-1.3.1.ebuild,v 1.1 2006/08/24 06:20:53 dberkholz Exp $
+
+inherit autotools
+
+IUSE="static"
+
+MY_P="${P/lib}"
+
+DESCRIPTION="Audio processing library for changing tempo, pitch and playback rates."
+HOMEPAGE="http://www.surina.net/soundtouch/"
+SRC_URI="http://www.surina.net/soundtouch/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~ppc-macos"
+
+RDEPEND="virtual/libc"
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}-respect-cflags.patch
+ eautoreconf
+}
+
+src_compile() {
+ econf $myconf \
+ $(use_enable static) \
+ --disable-integer-samples \
+ --with-pic || die "./configure failed"
+ # fixes C(XX)FLAGS from configure, so we can use *ours*
+ emake CFLAGS="$CFLAGS" CXXFLAGS="$CXXFLAGS" || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" pkgdocdir="/usr/share/doc/${PF}" install || die
+ rm -f ${D}/usr/share/doc/${PF}/COPYING.TXT # remove obsolete LICENCE file
+}