summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-07-23 20:02:40 +0000
committerMike Frysinger <vapier@gentoo.org>2007-07-23 20:02:40 +0000
commit22967fc8aa9bde2407b8f94ac9b972280f2c14b9 (patch)
treedeed5b8d40d1911842d69363ecb5b63ab2a183a4 /media-libs/libsdl
parentStable on ppc wrt bug 185614 (diff)
downloadgentoo-2-22967fc8aa9bde2407b8f94ac9b972280f2c14b9.tar.gz
gentoo-2-22967fc8aa9bde2407b8f94ac9b972280f2c14b9.tar.bz2
gentoo-2-22967fc8aa9bde2407b8f94ac9b972280f2c14b9.zip
Version bump.
(Portage version: 2.1.3_rc8)
Diffstat (limited to 'media-libs/libsdl')
-rw-r--r--media-libs/libsdl/ChangeLog7
-rw-r--r--media-libs/libsdl/files/digest-libsdl-1.2.123
-rw-r--r--media-libs/libsdl/libsdl-1.2.12.ebuild146
3 files changed, 155 insertions, 1 deletions
diff --git a/media-libs/libsdl/ChangeLog b/media-libs/libsdl/ChangeLog
index 9fdce6b4f4de..0a3194f73dd5 100644
--- a/media-libs/libsdl/ChangeLog
+++ b/media-libs/libsdl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/libsdl
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/ChangeLog,v 1.134 2007/07/01 18:05:34 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/ChangeLog,v 1.135 2007/07/23 20:02:40 vapier Exp $
+
+*libsdl-1.2.12 (23 Jul 2007)
+
+ 23 Jul 2007; Mike Frysinger <vapier@gentoo.org> +libsdl-1.2.12.ebuild:
+ Version bump.
01 Jul 2007; Raúl Porcel <armin76@gentoo.org> libsdl-1.2.11-r2.ebuild:
alpha stable wrt #182505
diff --git a/media-libs/libsdl/files/digest-libsdl-1.2.12 b/media-libs/libsdl/files/digest-libsdl-1.2.12
new file mode 100644
index 000000000000..13c679dca615
--- /dev/null
+++ b/media-libs/libsdl/files/digest-libsdl-1.2.12
@@ -0,0 +1,3 @@
+MD5 544b4554986e51eed6d34435cf9c5f3f SDL-1.2.12.tar.gz 2829456
+RMD160 3871023c63ea056eba43ce4f55ee8d3a73ff3022 SDL-1.2.12.tar.gz 2829456
+SHA256 df77eb883efdcc61220eaf7ade38324629c273c278ce8d700a5530369e9b6df9 SDL-1.2.12.tar.gz 2829456
diff --git a/media-libs/libsdl/libsdl-1.2.12.ebuild b/media-libs/libsdl/libsdl-1.2.12.ebuild
new file mode 100644
index 000000000000..a02dd145c783
--- /dev/null
+++ b/media-libs/libsdl/libsdl-1.2.12.ebuild
@@ -0,0 +1,146 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.12.ebuild,v 1.1 2007/07/23 20:02:40 vapier Exp $
+
+inherit flag-o-matic toolchain-funcs eutils libtool
+
+DESCRIPTION="Simple Direct Media Layer"
+HOMEPAGE="http://www.libsdl.org/"
+SRC_URI="http://www.libsdl.org/release/SDL-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+# WARNING:
+# if you have the noaudio, novideo, nojoystick, or noflagstrip use flags
+# in USE and something breaks, you pick up the pieces. Be prepared for
+# bug reports to be marked INVALID.
+IUSE="oss alsa esd arts nas X dga xv xinerama fbcon directfb ggi svga aalib opengl libcaca noaudio novideo nojoystick noflagstrip"
+
+RDEPEND="!noaudio? ( >=media-libs/audiofile-0.1.9 )
+ alsa? ( media-libs/alsa-lib )
+ esd? ( >=media-sound/esound-0.2.19 )
+ arts? ( kde-base/arts )
+ nas? (
+ media-libs/nas
+ x11-libs/libXt
+ x11-libs/libXext
+ x11-libs/libX11
+ )
+ X? (
+ x11-libs/libXt
+ x11-libs/libXext
+ x11-libs/libX11
+ )
+ directfb? ( >=dev-libs/DirectFB-0.9.19 )
+ ggi? ( >=media-libs/libggi-2.0_beta3 )
+ svga? ( >=media-libs/svgalib-1.4.2 )
+ aalib? ( media-libs/aalib )
+ libcaca? ( >=media-libs/libcaca-0.9-r1 )
+ opengl? ( virtual/opengl virtual/glu )"
+DEPEND="${RDEPEND}
+ nas? (
+ x11-proto/xextproto
+ x11-proto/xproto
+ )
+ X? (
+ x11-proto/xextproto
+ x11-proto/xproto
+ )
+ x86? ( || ( >=dev-lang/yasm-0.6.0 >=dev-lang/nasm-0.98.39-r3 ) )"
+
+S=${WORKDIR}/SDL-${PV}
+
+pkg_setup() {
+ if use noaudio || use novideo || use nojoystick ; then
+ ewarn "Since you've chosen to turn off some of libsdl's functionality,"
+ ewarn "don't bother filing libsdl-related bugs until trying to remerge"
+ ewarn "libsdl without the no* flags in USE. You need to know what"
+ ewarn "you're doing to selectively turn off parts of libsdl."
+ epause 30
+ fi
+ if use noflagstrip ; then
+ ewarn "Since you've chosen to use possibly unsafe CFLAGS,"
+ ewarn "don't bother filing libsdl-related bugs until trying to remerge"
+ ewarn "libsdl without the noflagstrip use flag in USE."
+ epause 10
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-1.2.11-libcaca-new-api.patch #40224
+ epatch "${FILESDIR}"/${PN}-1.2.11-sdl-config.patch
+ epatch "${FILESDIR}"/${PN}-1.2.11-xinerama-head-0.patch #145917
+
+ ./autogen.sh || die "autogen failed"
+ elibtoolize
+}
+
+src_compile() {
+ local myconf=
+ if [[ $(tc-arch) != "x86" ]] ; then
+ myconf="${myconf} --disable-nasm"
+ else
+ myconf="${myconf} --enable-nasm"
+ fi
+ use noflagstrip || strip-flags
+ use noaudio && myconf="${myconf} --disable-audio"
+ use novideo \
+ && myconf="${myconf} --disable-video" \
+ || myconf="${myconf} --enable-video-dummy"
+ use nojoystick && myconf="${myconf} --disable-joystick"
+
+ local directfbconf="--disable-video-directfb"
+ if use directfb ; then
+ # since DirectFB can link against SDL and trigger a
+ # dependency loop, only link against DirectFB if it
+ # isn't broken #61592
+ echo 'int main(){}' > directfb-test.c
+ $(tc-getCC) directfb-test.c -ldirectfb 2>/dev/null \
+ && directfbconf="--enable-video-directfb" \
+ || ewarn "Disabling DirectFB since libdirectfb.so is broken"
+ fi
+
+ myconf="${myconf} ${directfbconf}"
+
+ econf \
+ --disable-dependency-tracking \
+ --disable-rpath \
+ --enable-events \
+ --enable-cdrom \
+ --enable-threads \
+ --enable-timers \
+ --enable-endian \
+ --enable-file \
+ --enable-cpuinfo \
+ $(use_enable oss) \
+ $(use_enable alsa) \
+ $(use_enable esd) \
+ $(use_enable arts) \
+ $(use_enable nas) \
+ $(use_enable X video-x11) \
+ $(use_enable dga) \
+ $(use_enable xv video-x11-xv) \
+ $(use_enable xinerama video-x11-xinerama) \
+ $(use_enable X video-x11-xrandr) \
+ $(use_enable dga video-dga) \
+ $(use_enable fbcon video-fbcon) \
+ $(use_enable ggi video-ggi) \
+ $(use_enable svga video-svga) \
+ $(use_enable aalib video-aalib) \
+ $(use_enable libcaca video-caca) \
+ $(use_enable opengl video-opengl) \
+ $(use_with X x) \
+ --disable-video-x11-xme \
+ ${myconf} || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc BUGS CREDITS README README-SDL.txt README.CVS TODO WhatsNew
+ dohtml -r ./
+}